Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Need a basic config for RAS device

Hello all,

I've been assigned a project to update our rapidly aging dialup solution and I have the following assets:

A 2821 router with 1 HWIC-1CE1T1-PRI card

A T1 PRI line

I can figure out configuring IP addresses and such, but what I really need help with is just a basic config that will allow this device to pick up calls like a modem.  As of yet, I can get it to pick up the line, but with no modem negotiating noises and such.


Here is my config as it stands:

Router#
*Aug 19 22:00:20.219: %SYS-5-CONFIG_I: Configured from console by consolesh run
Building configuration...


Current configuration : 2898 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
logging message-counter syslog
!
no aaa new-model
no network-clock-participate wic 0
!
modem-pool test
pool-range 0/322 0/345
called-number XXXXXXX max-conn 24
!
modem country v12 usa
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
!
no ipv6 cef
multilink bundle-name authenticated
!
!
isdn switch-type primary-ni
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
controller T1 0/0/0
framing esf
linecode b8zs
cablelength long 0db
pri-group timeslots 1-24
description XXXXXXX pri
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation ppp
isdn switch-type primary-5ess
isdn protocol-emulate network
isdn incoming-voice modem 56
!
interface Async0/322
no ip address
encapsulation ppp
!
interface Async0/323
no ip address
encapsulation ppp
!
interface Async0/324
no ip address
encapsulation ppp
!
interface Async0/325
no ip address
encapsulation ppp
!
interface Async0/326
no ip address
encapsulation ppp
!
interface Async0/327
no ip address
encapsulation ppp
!
interface Async0/328
no ip address
encapsulation ppp
!
interface Async0/329
no ip address
encapsulation ppp
!
interface Async0/330
no ip address
encapsulation ppp
!
interface Async0/331
no ip address
encapsulation ppp
!
interface Async0/332
no ip address
encapsulation ppp
!
interface Async0/333
no ip address
encapsulation ppp
!
interface Async0/334
no ip address
encapsulation ppp
!
interface Async0/335
no ip address
encapsulation ppp
!
interface Async0/336
no ip address
encapsulation ppp
!
interface Async0/337
no ip address
encapsulation ppp
!
interface Async0/338
no ip address
encapsulation ppp
!
interface Async0/339
no ip address
encapsulation ppp
!
interface Async0/340
no ip address
encapsulation ppp
!
interface Async0/341
no ip address
encapsulation ppp
!
interface Async0/342
no ip address
encapsulation ppp
!
interface Async0/343
no ip address
encapsulation ppp
!
interface Async0/344
no ip address
encapsulation ppp
!
interface Async0/345
no ip address
encapsulation ppp
!
interface Group-Async1
physical-layer async
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
async mode interactive
no peer default ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line 0/322 0/345
modem autoconfigure discovery
transport input all
autoselect ppp
line vty 0 4
login
!
scheduler allocate 20000 1000
end

I pieced together this config with trial and error, as well as using lots of older ASA5000 configs as a guideline, but it's high time I get some real help with this.  I have rudimentary knowledge about Cisco routers, so any links, pointers, best practices, etc. would be awesome.  Thanks!

Everyone's tags (3)
568
Views
0
Helpful
0
Replies
CreatePlease to create content