Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPP Callback not allowed

Hi All

I need some assistance in finding out why I get "Callback not authorized for this user mrx" when debugging ppp negotiation.

I am trying to get the callback working from the local credentials for now.

Here is the config any feedback would be greatly appreciated.

async-bootp dns-server 10.1.33.8 10.1.1.140

isdn switch-type primary-net5

!

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c

modemcap entry mica-noKflex:MSC=&F&D2s53=0s34=0s39=4

!

!

username mrx callback-dialstring 2048403 password 0 mrx

!

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

pri-group timeslots 1-31

!

!

interface Loopback0

ip address 172.17.1.115 255.255.255.255

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.10.3.4 255.255.255.128

duplex auto

speed auto

media-type rj45

no keepalive

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

no keepalive

!

interface Serial1/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

isdn incoming-voice modem

no peer default ip address

!

interface Serial1/1:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

isdn incoming-voice modem

no peer default ip address

!

interface Dialer1

ip unnumbered GigabitEthernet0/0

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

peer default ip address pool dhcp

no cdp enable

ppp callback accept

ppp authentication pap chap ms-chap RAS

!

interface Group-Async1

ip unnumbered GigabitEthernet0/0

encapsulation ppp

no ip mroute-cache

autodetect encapsulation ppp

async mode interactive

peer default ip address pool dhcp

ppp callback accept

ppp authentication pap chap ms-chap

group-range 2/0 3/29

hold-queue 10 in

!

ip local pool dhcp 10.10.3.10 10.10.3.80

ip forward-protocol udp bootpc

ip route 0.0.0.0 0.0.0.0 10.10.3.1

!

no ip http server

ip http authentication local

no ip http secure-server

ip tacacs source-interface Loopback0

!

ip radius source-interface Loopback0

dialer-list 1 protocol ip permit

line con 0

stopbits 1

line aux 0

stopbits 1

line 2/0 2/29

session-timeout 5

script modem-off-hook offhook

script callback callback

modem InOut

transport input all

autoselect during-login

autoselect ppp

line 3/0 3/29

session-timeout 5

script modem-off-hook offhook

script callback callback

modem InOut

transport input all

autoselect during-login

autoselect ppp

line vty 0 4

privilege level 15

transport input telnet

line vty 5 15

privilege level 15

transport input telnet

!

scheduler allocate 20000 1000

!

end

1 REPLY
Silver

Re: PPP Callback not allowed

Hi, try to use the command "login local" under the "line x/y" or use the aaa commands like the example at the next url:

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094338.shtml

HTH

111
Views
0
Helpful
1
Replies
CreatePlease login to create content