Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPP encapsulation problem

Dear all,

I have two 2801 routers with the 12.4(1c) IOS..

I have two VWIC2-1MFT-T1/E1 cards terminated on HWIC 1 slot..

I need establish E1 link between the routers to transmit IP packets through it..

I am not able to configure the PRI on that..

It takes all the commands required for PRI enabling but for D-channel one I configure the encap as PPP my channel goes down..

I am forwarding following outputs ..

Plz Help.

Router A (network side)

!

network-clock-participate wic 1

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

no ip dhcp use vrf connected

!

isdn switch-type primary-net5

!

controller E1 0/1/0

clock source internal

pri-group timeslots 1-31

!

!

interface FastEthernet0/0

ip address 192.168.16.131 255.255.255.0

speed auto

full-duplex

no cdp enable

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/1/0:15

no ip address

(encapsulation ppp) // here's the problem

dialer pool-member 1

isdn switch-type primary-net5

isdn protocol-emulate network

no fair-queue

!

interface Dialer0

ip address 192.168.1.1 255.255.255.0

dialer pool 1

dialer string 310000

dialer-group 1

!

ip classless

!

ip http server

!

access-list 105 permit icmp any any

dialer-list 1 protocol ip permit

!

control-plane

!

disable-eadi

!

Router B (user side)

!

network-clock-participate wic 1

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

no ip dhcp use vrf connected

!

isdn switch-type primary-net5

!

controller E1 0/1/0

pri-group timeslots 1-31

!

!

interface FastEthernet0/0

ip address 192.168.20.1 255.255.255.0

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0:15

no ip address

(encapsulation ppp)

dialer pool-member 1

isdn switch-type primary-net5

!

interface Dialer0

ip address 192.168.1.2 255.255.255.0

dialer pool 1

dialer string 210000

dialer-group 1

!

ip classless

!

ip http server

!

access-list 105 permit icmp any any

dialer-list 1 protocol ip permit

!

control-plane

!

disable-eadi

!

=====================

once I configure s0/1/0:15 as encap PPP

plz note the following output

Cisco1#sh isdn sta

Global ISDN Switchtype = primary-net5

ISDN Serial0/1/0:15 interface

******* Network side configuration *******

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0xFFFF7FFF

Number of L2 Discards = 0, L2 Session ID = 28

Total Allocated ISDN CCBs = 0

debug isdn q921 output:

*Sep 7 15:46:15.791: ISDN Se0/1/0:15 Q921: L2_EstablishDataLink: sending SABME

*Sep 7 15:46:15.791: ISDN Se0/1/0:15 Q921: Net TX -> SABMEp sapi=0 tei=0

*Sep 7 15:46:16.791: ISDN Se0/1/0:15 Q921: Net TX -> SABMEp sapi=0 tei=0

*Sep 7 15:46:17.791: ISDN Se0/1/0:15 Q921: Net TX -> SABMEp sapi=0 tei=0

*Sep 7 15:46:18.791: ISDN Se0/1/0:15 Q921: Net TX -> SABMEp sapi=0 tei=0

*Sep 7 15:46:24.791: ISDN Se0/1/0:15 Q921: L2_EstablishDataLink: sending SABME

*Sep 7 15:46:24.791: ISDN Se0/1/0:15 Q921: Net TX -> SABMEp sapi=0 tei=0

....

one i remove PPP encap...

It shows Multiple_Frame_Established..

Cud any bode plz tell me how to solve this problem with encapsulation

Urgently needed the answer...

7 REPLIES
New Member

Re: PPP encapsulation problem

Hello,

I did not try such a thing before, but if you are using a dialer, you can not change the layer 2 encapsulation, because it is not a leased line, rather it is a normal pri, with lapd. You can not communicate with the teleco's equipent with ppp.

KInd regards,

Bela

Re: PPP encapsulation problem

Probably you have the wrong modules. When you want to set up a point-point connection, you will need the VWIC-xMFT-G703.

Regards,

Leo

New Member

Re: PPP encapsulation problem

Hi

Thanks to all for replies.

But now I don't know what to do at all.

I just need to transmit the data (IP packets) from router A to router B through E1 PRI link with dial-out and dial-in procedures. Any suggestions for that?

And can use HDLC encap on the Serial and Dialer interfaces in this case? Ith that possible, or not?

Thanks In Advance

Re: PPP encapsulation problem

Hello,

try the following changes to your configurations:

Router A

controller E1 0/1/0

--> clock source line primary

pri-group timeslots 1-31

!

interface Serial0/1/0:15

no ip address

-->encapsulation ppp)

dialer pool-member 1

isdn switch-type primary-net5

isdn protocol-emulate network

no fair-queue

!

interface Dialer0

ip address 192.168.1.1 255.255.255.0

--> encapsulation ppp

dialer pool 1

dialer string 310000

dialer-group 1

!

--> ip route 0.0.0.0 0.0.0.0 Dialer0

Router B

controller E1 0/1/0

--> clock source line primary

pri-group timeslots 1-31

!

interface Serial0/1/0:15

no ip address

--> encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

!

interface Dialer0

ip address 192.168.1.2 255.255.255.0

--> encapsulation ppp

dialer pool 1

dialer string 210000

dialer-group 1

!

ip route 0.0.0.0 0.0.0.0 Dialer0

I assume there is a Telco in between your routers, are do you have them configured in a back-to-back setup ?

Regards,

GNT

New Member

Re: PPP encapsulation problem

Hello

Thank you for your suggestions, however our routers haven't the comand "clock source line primary". They have only:

Cisco1(config-controller)#clock source line ?

bits Bits Clocking

independent Independent Source

Re: PPP encapsulation problem

Hello Ivan,

try 'clock source line' and see if you get it to work. The idea is to have the provider take care of the clocking, which is typically, if not always, the case...

Regards,

GNT

New Member

Re: PPP encapsulation problem

Unfortunately, that doesn't work. I tried different ways - line protocol is up only with HDLC encap.

As for a Telco between routers, we have our own Digital Automatic Switching Center, that will be connected between routers. The topology:

LAN1---Cisco1---DASC---Cico2---LAN2

The're no problem with DASC. At present moment, routers are connected directly with each other.

It's interesting to note, that if I configure Controller E1 with 'Channel-group' command, all works perfectly, as with DASC, as without it. I can set encap HDLC or PPP for Serial int - that doesn't matter, files are transmited from LAN1 to LAN2 succesfully.

In any case, thank you everybody. Hope, I'll solve this trouble in the future.

222
Views
6
Helpful
7
Replies
CreatePlease login to create content