Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PPP multilink command absent but multilink works!!

Hi,

i have to routers a 801 -running 12.3.5f IOS- and a 3640 -running 12.2.28a each with one bri wic.

Once, i have tried to use ppp multilink because the customer wanted 128kbps after a certain threshold and so i configured ppp multilink on BOTH routers in the Dialer interface.

After a week or so, i removed the ppp multilink command from BOTH routers because he didn't want a second call to occur.

After a month, he realised that ppp multilink still works and that the 801 makes a second call to the 3640!!

How is this possible if the command ppp multilink does not exist in either routers?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: PPP multilink command absent but multilink works!!

Hi ,

coming to the config of dialer interface on remote roueter ,

interface Dialer0

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer idle-timeout 20

dialer map ip 10.7.1.254 name xxx broadcast

dialer hold-queue 15

dialer load-threshold 255 either

!

As you said dialer load-threshold is used to bring up second B channel..

In this you don't want the second B channel to come up , so what is the use of keeping that command under dialer interface. ?

You can remove that command as you don't want second channel to come up.

Am i correct ?

Thanks,

satish

7 REPLIES
Silver

Re: PPP multilink command absent but multilink works!!

Hi ,

Can you paste the config of th router ?

Thanks,

satish

New Member

Re: PPP multilink command absent but multilink works!!

here it is satish. Be aware of the comment i put in the dialer interface of the 109 config, which is one of the remote sites:

109#sh run

hostname 109

!

interface Ethernet0

ip address 10.10.9.254 255.255.255.0

ip access-group 100 in

no ip directed-broadcast

no cdp enable

!

interface BRI0

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface Dialer0

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer idle-timeout 20

dialer map ip 10.7.1.254 name xxx broadcast

dialer hold-queue 15

dialer load-threshold 255 either

!

//I had to use this command to be sure that the second channel

never comes up even if multilink is not configured. If i don't

issue this command, when the traffic reaches the default threshold,

128/255 i think, the second channel calls again.//

!

dialer-group 1

no cdp enable

ppp authentication pap ms-chap chap

!

ip local pool dialin_pool 10.10.9.250 10.10.9.253

no ip http server

ip classless

ip route 10.1.1.254 255.255.255.255 Dialer0

!

end

and the central router:

username 109 password 7

interface BRI1/0

description ISDN BRI CONNECTION -

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface BRI1/1

description ISDN BRI CONNECTION DDR -

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface BRI1/2

description ISDN BRI -DDR

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface BRI1/3

description ISDN BRI -DDR

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface BRI1/4

description ISDN BRI -DDR

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface BRI1/5

description ISDN BRI -DDR

ip unnumbered Ethernet0/0

ip accounting output-packets

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

interface BRI1/6

description ISDN BRI -DDR

ip unnumbered Ethernet0/0

ip accounting output-packets

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 0

isdn switch-type basic-net3

isdn tei-negotiation first-call

no cdp enable

!

interface Dialer0

ip unnumbered Ethernet0/0

ip accounting output-packets

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

dialer in-band

dialer idle-timeout 30

dialer map ip 10.10.9.254 name 109 broadcast

dialer hold-queue 15

dialer-group 1

no cdp enable

ppp authentication chap

ppp pap refuse

!

ip route 0.0.0.0 0.0.0.0 10.7.1.252

ip route 10.10.9.0 255.255.255.0 10.10.9.254

ip route 10.10.9.254 255.255.255.255 Dialer0

Silver

Re: PPP multilink command absent but multilink works!!

Hi ,

coming to the config of dialer interface on remote roueter ,

interface Dialer0

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer idle-timeout 20

dialer map ip 10.7.1.254 name xxx broadcast

dialer hold-queue 15

dialer load-threshold 255 either

!

As you said dialer load-threshold is used to bring up second B channel..

In this you don't want the second B channel to come up , so what is the use of keeping that command under dialer interface. ?

You can remove that command as you don't want second channel to come up.

Am i correct ?

Thanks,

satish

Hall of Fame Super Silver

Re: PPP multilink command absent but multilink works!!

In my experience ppp authentication should go on both the BRI and the Dialer interfaces. Try configuring ppp authentication on the BRI interfaces and let us know if the behavior changes.

HTH

Rick

New Member

Re: PPP multilink command absent but multilink works!!

Thank you both of you.

I think that the best thing to do is as you said:

remove the load threshold

and use ppp authentication in both physical and dialer interfaces.

New Member

Re: PPP multilink command absent but multilink works!!

I think you are right!

Multichannel is working even after you remove the command " ppp multilink" because "dialer load threshold " command itself uses BoD by default. In other words, You don't need to config the command "ppp multilink" if both two routers are cisco's. "dialer load threshold" command is enough for the multilik

New Member

Re: PPP multilink command absent but multilink works!!

There is also another solution:

Use dialer max-calls

188
Views
0
Helpful
7
Replies
CreatePlease to create content