Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Highlighted
Community Member

PPPoE client on subinterface

I had a config working great on my 2811, so I thought it should work on a 2821 . Below is the config 

Router#sh run
Building configuration...

Current configuration : 1858 bytes
!
! Last configuration change at 04:51:34 UTC Mon Sep 25 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
memory-size iomem 25
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.172.0.1
ip dhcp excluded-address 192.172.0.10
!
ip dhcp pool Lab-Network
network 192.172.0.0 255.255.255.224
default-router 192.172.0.1
dns-server 8.8.8.8
domain-name Herman

!
!
ip dhcp update dns
multilink bundle-name authenticated
!
vpdn enable
!
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn xxxxxxxxxxxxxxxx
!
!
!
!
!
interface FastEthernet0/0
description WAN Interface
no ip address
duplex full
speed 100
no cdp enable
!
interface FastEthernet0/0.1
encapsulation dot1Q 201
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description LAN Interface
ip address 192.172.0.1 255.255.255.224
ip nat inside
ip virtual-reassembly in
duplex full
speed 100
no cdp enable
!
interface Dialer1
description WAN Dialer
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxx
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 10 permit 192.172.0.0 0.0.0.255
!
!
control-plane
!
!
!
line con 0
line aux 0
line 1/0 1/31
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end

 

I copied it line by line, but I'm not able to establish a connection with the Centurylink ONT on the 2821.  I forgot how I was able to establish a pppoe client on the fa0/0.1...so I believe that is the problem..below is the config for the 2821

 

Router#sh run
Building configuration...

Current configuration : 1626 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.172.0.1
!
ip dhcp pool Lab-Network
network 192.172.0.0 255.255.255.224
default-router 192.172.0.1
dns-server 8.8.8.8
domain-name Herman
!
!
ip dhcp update dns
vpdn enable
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 201
no snmp trap link-status
pppoe enable
pppoe max-sessions 10
!
interface GigabitEthernet0/1
description LAN Interface
ip address 192.172.0.1 255.255.255.224
ip nat inside
ip virtual-reassembly
duplex full
speed auto
!
interface GigabitEthernet1/0
ip address pool Lab-Network
!
interface Dialer1
description WAN Dialer
ip address negotiated
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
no cdp enable
ppp chap hostname xxxxxxxx
ppp chap password 0 xxxxxxxxxxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 10 interface Dialer1 overload
!
access-list 10 permit 192.172.0.0 0.0.0.255
!
!
control-plane
!
!
!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output all
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: PPPoE client on subinterface

Hello,

do you have a service contract ? If so, download the 12.4-15T.17 Advanced Security pack, below is the image name:

c2800nm-advsecurityk9-mz.124-15.T17.bin

8 REPLIES

Re: PPPoE client on subinterface

Hi,

You need to remove "pppoe-client dial-pool-number 1" from the main interface and apply to GigabitEthernet0/0.1 sub-interface.


interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 201
no snmp trap link-status
pppoe enable
pppoe-client dial-pool-number 1
pppoe max-sessions 10
!

Don't forget to rate if you find it helpful : )

HTH,
Meheretab
Community Member

Re: PPPoE client on subinterface

under the sub interface the only options I have for pppoe is enable and max-sessions.
VIP Purple

Re: PPPoE client on subinterface

Hello,

are you running 12.4(T) or later ? Upgrade to a 15.x version if possible. PPPoE clients on subinterfaces need 12.4(T) or later...

Community Member

Re: PPPoE client on subinterface

12.4 (3)

VIP Purple

Re: PPPoE client on subinterface

Is that a T release ? Post the output of show version...

Community Member

Re: PPPoE client on subinterface

Router#sho ver
Cisco IOS Software, 2800 Software (C2800NM-ADVSECURITYK9-M), Version 12.4(3f), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Fri 18-Aug-06 18:47 by alnguyen

ROM: System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)

Router uptime is 10 hours, 24 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-advsecurityk9-mz.124-3f.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2821 (revision 53.50) with 245760K/16384K bytes of memory.
Processor board ID FTX1038A4PQ
3 Gigabit Ethernet interfaces
1 terminal line
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Router#
VIP Purple

Re: PPPoE client on subinterface

Hello,

do you have a service contract ? If so, download the 12.4-15T.17 Advanced Security pack, below is the image name:

c2800nm-advsecurityk9-mz.124-15.T17.bin

VIP Purple

Re: PPPoE client on subinterface

Hello,

in addition to the other post, I think you also need to add 'dialer-group 1' to the dialer interface and 'dialer-list 1 protocol ip permit' globally...

1363
Views
10
Helpful
8
Replies
CreatePlease to create content