Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE not working

I use 2514 router connected to ZTE ADSL modem. Do I need somehow to "push" router to dial, how it must to start connecting ? Maybe there is something wrong with configuration:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

vpdn enable

vpdn ip udp ignore checksum

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

interface Ethernet0

no ip address

pppoe enable

pppoe-client dial-pool-number 1

!

interface Ethernet1

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

no ip address

shutdown

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer-group 1

ppp authentication chap callin

ppp chap hostname xxxx

ppp chap password 0 xxxx

ppp pap sent-username xxxx password 0 xxxx

!

ip http server

ip classless

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

P.S. maybe anybody knows step by step link on internet, or can provide it here for correct full PPPoE configuration.

Thanks

3 REPLIES
Silver

Re: PPPoE not working

New Member

Re: PPPoE not working

Try adding this to the Dialer1 interface config:

ppp authentication chap pap callin

Bronze

Re: PPPoE not working

Hi,

The only missing command in your configuration is

!

interface Dialer1

dialer pool 1

!

Add this command it should work.

HTH

Thanks

Raj

119
Views
5
Helpful
3
Replies