Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE on HWIC-4ESW?

2800 running with 12.4(4)T1 with HWIC-4ESW module. Can one define PPPoE

on a switchport interface? Ie:

interface FastEthernet0/1/0

pppoe enable

pppoe-client dial-pool-number 2

no routing dynamic

!

interface Dialer1

bandwidth 5000

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 2

dialer-group 2

no cdp enable

ppp authentication pap callin

ppp pap sent-username xxxx password 7 xxxxx

Thanks,

Hank

7 REPLIES

Re: PPPoE on HWIC-4ESW?

hi

the info available in CCO states that many of the features arent tested on this new module.

It goes on like this "Many features are not supported or tested on these interfaces, including Hot Standby Router Protocol (HSRP), Point-to-Point Protocol over Ethernet (PPPOE) termination, Layer 2 Tunneling Protocol Version 3 (L2TPv3) termination, MAC address assignment, Layer 3 QoS, and others. You should carefully test any desired feature and solution prior to deploying it"

http://www.cisco.com/en/US/products/ps5853/products_qanda_item0900aecd8016c026.shtml

regds

New Member

Re: PPPoE on HWIC-4ESW?

It works with Vlans:

interface FastEthernet0/1/0

switchport access vlan 10

no routing dynamic

!

interface Vlan10

ip address 10.10.0.1 255.255.255.0

ip nat outside

ip virtual-reassembly

pppoe enable

-Hank

New Member

Re: PPPoE on HWIC-4ESW?

Hi Hank,

Could you please elaborate on your working config as I am having trouble duplicating your results - would be hugely appreciated.

Thanks

Paul

New Member

PPPoE on HWIC-4ESW?

Hi,

am trying this configuration on 1941 + HWIC-4ESW.

But it does not recognize the pppoe command !

router.xxxx.com(config)#int vlan 10

.........

router.xxxx.com(config-if)#pppoe enable

                                       ^

% Invalid input detected at '^' marker.

anyone was able to make it ?

am trying this on PT (before deploy)

regards,

Zied.

Hall of Fame Super Gold

Re: PPPoE on HWIC-4ESW?

Cisco may now have coded to block that, as it was never stated supported.

Use a layer 3 interface, not VLAN interface.

New Member

Re: PPPoE on HWIC-4ESW?

Do you mean I'll have to use one of the Gpbs interfaces on the router ?

If yes that would be a big waste (Gbps on PPPoE ADSL)

I was wondering if I can, "any how" get PPPoE in one port from the HWIC-4ESW.

New Member

Re: PPPoE on HWIC-4ESW?

Can you tell me if this would work ?

Create a subinterface gigabitEthernet 0/0.1 and trunk it to one fastethernet from the HWIC-4ESW

after that configure a pppoe client on GE 0/0.1

I'll give it a try and come back to tell.

679
Views
2
Helpful
7
Replies
CreatePlease to create content