Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE Server

I have configured 3640 router to perform as PPPoE server in order to terminate the PPPoE sessions and forward it to a RADIUS server, I?ve included the router configuration below but this configuration isn?t working, your help is highly appreciated?

vpdn enable

!

vpdn-group PPPoE

accept-dialin

protocol pppoe

virtual-template 1

interface Ethernet0/0

description Link To Clients

ip address 172.26.26.1 255.255.255.0

half-duplex

pppoe enable

!

interface Ethernet0/1

description Link To RADIUS/Internet

ip address 192.168.100.252 255.255.255.0

half-duplex

Interface Virtual-Template1

ip unnumbered Ethernet0/0

ppp authentication pap test

ppp authorization test

ppp accounting test

radius-server host 192.168.100.10 auth-port 1912 acct-port 1913 key mysecret

line con 0

line aux 0

line vty 0 4

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions

Re: PPPoE Server

Hi

You need to encorporate that in AAA list

http://www.cisco.com/warp/public/793/access_dial/security.html#specaaa

Pls rate helpful posts.

Regards

JD

3 REPLIES
Silver

Re: PPPoE Server

Please sepcify the result in detail and it is difficult to analyze the problem w/o propoer information.

Please check below link if it may help :

http://www.cisco.com/en/US/products/sw/iosswrel/ps5012/products_feature_guide09186a008014591a.html

http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_feature_guide09186a00800800f4.html

Re: PPPoE Server

Hi

You need to encorporate that in AAA list

http://www.cisco.com/warp/public/793/access_dial/security.html#specaaa

Pls rate helpful posts.

Regards

JD

New Member

Re: PPPoE Server

Thanks all for your help, I've configured the AAA model as below and it wroks fine.

aaa authentication ppp test group radius

aaa authorization network test group radius

aaa session-id common

389
Views
0
Helpful
3
Replies