Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE to Cisco 831 (Ethernet port)

Hello folks !!!

I am tring to stabilish a PPPoE session over a ADSL line but i am facing problems with virtual-template interface.

- I has configured PPPoE without NAT.

- My router works like a DHCP server.

- The ethernet 0 (connected to LAN) has a local ip address

- The ethernet 1 ( connected to ISP provider) is configurated to negociate the ip address.

The problem is that I can see different PPP sessions (to different times of show ppp session all). It is cuased because the Virtual-Template interface (created automatically when the Dialer interface is created) is flapping as well.

I need some help to stabilish the session. Is there any other configuration at Virtual-Template interface ?

All is well configured but i don't know if there is any additonal set at virtual-template interface to not flapp the interface

7 REPLIES
Hall of Fame Super Gold

Re: PPPoE to Cisco 831 (Ethernet port)

Hi,

actually for a simple configuration, virtual-template is not necessary.

Just configure a dialer interface and tie it to pppoe-client command.

Hope this helps, please rate post if it does!

New Member

Re: PPPoE to Cisco 831 (Ethernet port)

Hi,

Yes I already did it but i am receiving the logs above.

%DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

Di1 DDR: Cannot place call, no dialer string set

Above is the currente interface configurations.

interface Ethernet0 (LAN interface)

ip address 10.27.0.1 255.255.255.0

ip virtual-reassembly

ip tcp adjust-mss 1452

no cdp enable

hold-queue 32 in

interface Ethernet1

description $WAN$ (ISP interface)

no ip address

ip virtual-reassembly

duplex auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

crypto map testmap

crypto ipsec df-bit clear

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer wait-for-line-protocol 3

dialer-group 1

ppp authentication chap callin

ppp chap hostname 123456@telemar.com.br

ppp chap password 7 123456

How could I do to clear these logs ?

Hall of Fame Super Gold

Re: PPPoE to Cisco 831 (Ethernet port)

Hi, your dialer might not go up at all, check with debug ppp negotiation and authentication.

New Member

Re: PPPoE to Cisco 831 (Ethernet port)

Hi !!!

I can see in the logs that the pppoe session is not been stabilished. There are these logs:

[log cut]

* Vi1 CHAP: I FAILURE id 1 len 43 msg is "Account password must be plain for chap"

[log cut]

* Vi1 PPP: Phase is terminated

* Dialer-6-UNBIND: Interface Vi1 unbound from profile Di1

[log cut]

What does it mean "Account password must be plain for chap" ?

Hall of Fame Super Gold

Re: PPPoE to Cisco 831 (Ethernet port)

No idea. Try removing CHAP and configure username and password as PAP.

New Member

Re: PPPoE to Cisco 831 (Ethernet port)

Hi !!!

Tks for help sir. I will check it with ISP.

The last question:

I would like to clarify the message sent from ISP's AAA server. Do you know the real sense os this message ? "Account password must be plain for CHAP".

I paste the debugging PPP negociation line bellow.

*Mar 2 01:25:11: Vi1 CHAP: I FAILURE id 1 len 43 msg is "Account password must be plain for CHAP"

I apreciate your help for this issue. We don't know if it should be handled by the ISP or by us. Anyway many thanks for the support and attencion.

Brgds.

Fabio Nunes

Hall of Fame Super Gold

Re: PPPoE to Cisco 831 (Ethernet port)

Hi,

Really the error message doesn't tell me anything to me and you should clarify with ISP.

You can easily try if you have better luck with PAP as mentioned before. Just configure the usenrmae and password, you can remove altogether the "ppp authentication" statement.

Good luck!

666
Views
0
Helpful
7
Replies