cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
862
Views
0
Helpful
3
Replies

PPPoe with DHCP and subnet masks

Steven Smith
Level 7
Level 7

We are using DHCP to give out subnet masks. The client gets the address fine but has the incorrect subnet mask. Example

DHCP Pool of 10.10.10.0/24

IP address the client gets is 10.10.10.3 and a netmask of 255.0.0.0.

Here is the configuration I have on my router.

show run

Building configuration...

Current configuration : 1098 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

username cisco password 0 cisco

no aaa new-model

ip subnet-zero

!

!

no ip domain lookup

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool test

network 10.10.10.0 255.255.255.0

!

!

ip cef

vpdn enable

!

vpdn-group PPPoE

accept-dialin

protocol pppoe

virtual-template 1

!

!

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.0

duplex full

!

interface FastEthernet1/0

no ip address

duplex full

pppoe enable

!

interface Virtual-Template1

mtu 1492

ip unnumbered FastEthernet0/0

peer default ip address dhcp-pool test

ppp authentication pap

!

no ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

Thanks in advance for the help.

3 Replies 3

desai.jaideep
Level 5
Level 5

Hi

I believe you are trying to create PPPoE server....

Pls remove :

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool test

network 10.10.10.0 255.255.255.0

And modify.....

interface Virtual-Template1

peer default ip address pool test

And add.......

ip local pool test 10.10.10.10 10.10.10.254

This should work.

Pls rate helpful posts.

Regards

JD

Actually I used to have that config in there. I am getting IP's to the PPPoe clients with both configs. Just not getting the correct mask.

Instead of DHCP, configure this under your virtual-template to change the mask you're giving out:

ppp ipcp mask 255.255.255.0