Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problem on ISDN Backup line

Hello,

i have a remote site that have two WAN lines, one primary and the another is Backup ISDN (PPP), MY points is about the ISDN line i have made a configuration as the following:

interface BRI0/0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Serial0/1/0

bandwidth 256

ip address 10.1.2.2 255.255.255.252

ip route-cache flow

service-policy output QoS-Policy

ip rtp header-compression

ip rtp priority 32000 1000 80

!

interface Virtual-Template1

no ip address

ppp multilink

ppp multilink interleave

ppp multilink fragment delay 20

ip rtp reserve 32000 1000 64

!

interface Vlan1

no ip address

no snmp trap link-status

!

interface Dialer1

ip address 192.168.99.14 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name cr-02

dialer idle-timeout 500

dialer string XXXX400

dialer load-threshold 128 either

dialer-group 1

no snmp trap link-status

no cdp enable

ppp authentication chap

!

router eigrp 1

network 10.0.0.0

network 192.168.99.0

no auto-summary

eigrp stub connected

!

ip route 0.0.0.0 0.0.0.0 10.100.1.1

ip route 0.0.0.0 0.0.0.0 192.168.99.13 20

But when the primary link is down the ISDN link doent come up, i tried to make a debugging it give me the following messege :

*Aug 4 06:42:27.275: ISDN BR0/0/0 **ERROR**: handle_l2d_srq_mail: Layer 1 inactive.

*Aug 4 06:42:29.507: ISDN BR0/0/0 Q921: L2_EstablishDataLink: sending SABME

*Aug 4 06:42:29.527: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/0, TEI 95 changed to up

*Aug 4 06:42:29.639: ISDN BR0/0/0 **ERROR**: host_disconnect_ack: Call rejected cause No circuit/channel available(0x22) call id 0x818D.

*Aug 4 06:42:31.271: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num XXXX400

*Aug 4 06:42:31.375: ISDN BR0/0/0 **ERROR**: host_disconnect_ack: Call rejected cause No circuit/channel available(0x22) call id 0x818E.

*Aug 4 06:42:33.271: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num XXXX400

*Aug 4 06:42:33.375: ISDN BR0/0/0 **ERROR**: host_disconnect_ack: Call rejected cause No circuit/channel available(0x22) call id 0x818F.

*Aug 4 06:42:35.271: ISDN BR0/0/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num XXXX400

*Aug 4 06:42:35.375: ISDN BR0/0/0 **ERROR**: host_disconnect_ack: Call rejected cause No circuit/channel available(0x22) call id 0x8190.

Success rate is 0 percent (0/5)

ar-BRH#

*Aug 4 06:42:50.375: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/0, TEI 95 changed to down

*Aug 4 06:42:50.383: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

ar-BRH#

*Aug 4 06:43:00.967: ISDN BR0/0/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

*Aug 4 06:43:00.971: ISDN BR0/0/0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

Kindlly your help

THanks

7 REPLIES
Silver

Re: Problem on ISDN Backup line

Where is BACKUP INTERFACE DIELAR1 Command on Serial 0 Interface.

How Serial interface will know about... Dialer interface is there?

See detail of Backup ISDN configuration exaples:

http://www.cisco.com/en/US/tech/tk801/tk379/technologies_configuration_example09186a0080093c7d.shtml

Regards,

Dharmesh Purohit

Hall of Fame Super Silver

Re: Problem on ISDN Backup line

Dharmesh

I do not believe that the original poster intended to use backup interface, and I do not believe that backup interface is necessarily needed here. The floating static default route points to the dialer interface:

ip route 0.0.0.0 0.0.0.0 10.100.1.1

ip route 0.0.0.0 0.0.0.0 192.168.99.13 20

and if the primary static default route is withdrawn the router will begin sending traffic to the dialer.

I do note that in the amount of configuration shown I do not see a way to get to 10.100.1.1 and so there may be a problem with the primary static default route. Or it may be that the address is reachable through some interface not shown in the posted config.

I believe that there is a more fundamental problem shown in the original post. One of the lines indicates that layer 1 is not active. If layer 1 is not active then nothing can be sent over this interface. Perhaps we could have posted the output of show isdn status. This would clarify the status of layer 1 and layer 2 for the ISDN.

HTH

Rick

New Member

Re: Problem on ISDN Backup line

the 10.100.1.1 can be reach through Eigrp so there is no problem of the primary static route, but when i ping the other peer for the isdn 192.168.99.13 the layer 1, and 2 will be active before that it will be deactive

ar-BRH#sh isdn status

Global ISDN Switchtype = basic-dms100

ISDN BRI0/0/0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 101, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

ar-BRH#

thanks

Hall of Fame Super Gold

Re: Problem on ISDN Backup line

Hi Rick,

In almost all part of the world (with the notable exception of North America), the telco switch deactivates L1 and L2 on the S/T bus of ISDN BRI circuits, after few seconds of inactivity. I never got to understand in full why is that, but so it is.

As soon an incoming or outgoing call is attempted, both L1 and L2 are reactivated.

Only recently, ISDN code in IOS has began to address this situation better than before, with the command "isdn tei-negotiation preserve". This way, no time is lost in obtaining a TEI every time the link reactivates.

Hall of Fame Super Gold

Re: Problem on ISDN Backup line

Darmesh,

As I told you already in some other occasion, "backup interface" is not the only method of configuring backup over ISDN.

In fact,it is a limiting mechanism that does not address all the situations.

So please do not assume that all the installations are the same and there is only of way of configuring things.

New Member

Re: Problem on ISDN Backup line

do you any solution for my case

thanks

Hall of Fame Super Gold

Re: Problem on ISDN Backup line

Hi,

seems to me the call is refused by telco. Collect debug isdn q931 to confirm.

518
Views
0
Helpful
7
Replies
CreatePlease to create content