Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problem with Reverse telnet on 2611 (NM-32A)

I have been trying to get 2611 to work as a Terminal server to be able to reverse telnet to couple of routers. But I can't get it to work on the NM module, however it is working through the AUX port.

This is the config of the router:

Current configuration : 725 bytes

!

version 12.2

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1

!

enable secret xxx

!

ip subnet-zero

!

!

!

!

!

!

interface Loopback1

ip address 172.16.1.1 255.255.255.255

!

interface Ethernet0/0

ip address 192.168.100.90 255.255.255.0

half-duplex

!

interface Ethernet0/1

no ip address

half-duplex

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip http server

!

!

line con 0

line 33 64

session-timeout 30

exec-timeout 0 0

password c

login

no exec

transport input all

line aux 0

session-timeout 30

exec-timeout 0 0

password c

login

no exec

transport input all

line vty 0 4

password c

login

!

end

10 REPLIES
Bronze

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hello,

is this the entire configuration ? Have a look at this sample configuration:

!

boot-start-marker

boot-end-marker

!

enable secret 5 XXXXXXXXXXXXXXXXXXXXXXX

!

username root privilege 15 password 7 XXXXXXXXXXXXXXXXXXXXXX

no aaa new-model

ip subnet-zero

no ip domain lookup

!

ip host Router1 2001 172.16.1.1

ip host Router2 2002 172.16.1.1

ip host Router3 2003 172.16.1.1

ip host Router4 2004 172.16.1.1

ip host Router5 2005 172.16.1.1

ip host Router6 2006 172.16.1.1

ip host Router7 2007 172.16.1.1

ip host Router8 2008 172.16.1.1

ip host Router9 2009 172.16.1.1

ip host Router10 2010 172.16.1.1

ip host Router11 2011 172.16.1.1

ip host Router12 2012 172.16.1.1

ip host Router13 2013 172.16.1.1

ip host Router14 2014 172.16.1.1

ip host Router15 2015 172.16.1.1

ip host Router16 2016 172.16.1.1

!

interface Loopback1

ip address 172.16.1.1 255.255.255.255

!

interface Ethernet0/0

ip address 192.168.100.90 255.255.255.0

half-duplex

!

interface Ethernet0/1

no ip address

half-duplex

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip http server

!

line con 0

line 1

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 2

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 3

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 4

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 5

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 6

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 7

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 8

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 9

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 10

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 11

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

speed 38400

line 12

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 13

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 14

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 15

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line 16

session-timeout 30

exec-timeout 0 0

no exec

transport input telnet

line aux 0

line vty 0 4

exec-timeout 60 0

login local

!

end

The line numbering depends on the slot in which the module is inserted, Slot 0 has line numbers 0 thru 32, Slot 1 line numbers 33 thru 65, etc...

In the above example, the module is installed in slot 0.

The third section of each command contains the port number for the devices, and the last two digits of the number designate the port. For example, 2001 follows the first router ("Router1"), meaning this router is on port 1. The last part of the command contains the IP address of the Ethernet port on the console server.

By creating these names, you don't need to know which port the device is on. All you need to do is Telnet to the host (in this case, Router1) off of the console server.

You could also reach this device directly from a PC. For example, you could Telnet to 172.16.1.1 2016 from your PC. This tells the Telnet client to go to port 2016 instead of the default Telnet port 23.

HTH,

Nethelper

New Member

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hi HTH, thank you for the response.

I have been trying a telnet to the loopback IP address on port 2033, which should be the first unit connected. I have been thinking if it could be wrong cabling on the RJ45 connector. I have these colors: Green, white, blue, orange, brown, yellow, red and black in that order from pin 1 to pin 8.

R.

Haukur

Bronze

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hello Haukur,

the colors do not really matter, as long as you are using a rolled cable, which means that all pins are reversed:

1-8

2-7

3-6

4-5

5-4

6-3

7-2

8-1

What happens when you do the telnet, what message does the system give you ?

Regards,

Nethelper

New Member

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hi Nethelper,

How can I know if it is a rolled cabel or not on the Octal cable?

I'm getting the password prompt and after that it I have a connection but nothing is displaying on the screen.

R.

Haukur

Bronze

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hello Haukur,

have a look at the cable depicted in the link below, if this is what yours looks like, it is a rolled cable. As a matter of fact, if it weren't, you would not even get a password prompt. You have your NM installed in slot 0, right ? Can you post the output of 'show line' ? It could also be that the line is busy, try a 'clear line' .

Regards,

Nethelper

New Member

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hi Nethelper,

I'm getting the password prompt from the Terminal server, I have "login" on the lines. I have tried clearing the line and login in again with no luck. I can't see the link you are mentioning. The NM module is in slot 1 on the 2600. I don't have access to the box right now but I'll post the output of show line later today.

R.

Haukur

Bronze

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hello Haukur,

take the ´login´ command off the lines, and see if that makes a difference...

Regards,

Nethelper

New Member

Re: Problem with Reverse telnet on 2611 (NM-32A)

It doesn't matter. Do you know the colors of the RJ45 connectors on the Octal cable?

R.

Haukur

Bronze

Re: Problem with Reverse telnet on 2611 (NM-32A)

Hello Haukur,

have a look at this link, it describes the octal cable in detail:

Asynchronous Connections

CAB-OCTAL-ASYNC Cable Pinouts

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a00801c9a10.shtml

Also, have a look at this link, it describes the exact configuration for a terminal server, check if you might have missed something:

Asynchronous Connections

Configuring a Terminal/Comm Server

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml

Regards,

Nethelper

New Member

Re: Problem with Reverse telnet on 2611 (NM-32A)

The problem is solved, it was the cabling of the RJ45 connectors.

1066
Views
0
Helpful
10
Replies
CreatePlease to create content