Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problems with ssh in 827

Hi, How can I configure to connect to my router with console and by ssh?

This is my configuration, I forgeet something but I do not know what.... using a ssh client I try to connect but always the same responde..always asking for a new pass.

Best regards

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: problems with ssh in 827

Edgar

The original post mentions being able to access the router via console and via SSH. You seem mostly to be describing access via SSH. In the original configuration that you posted it looks to me like connecting to the console should have let you righ in. When you add login and password to the console you should be able to access the console if you enter the password that you configured. Is that working or not?

SSH is for remote access. And it looks to me like the configuration should work, assuming that the key has been generated, and you say that it has. I see that the configuration has a username and password configured. Is that what you want to use to login? If so I would suggest changing the config on the vty from login to login local. This will prompt for a username and password configured on the local router. As configured I would expect it to work if you login with the password configured on the vty.

I also note that the config of the vty has access class configured which controls which addresses can access the router. Am I correct in assuming that you are accessing the router from an address that is in access list 1?

If it is still not working then running debug for SSH and posting the output would help us to figure out what the problem is.

HTH

Rick

4 REPLIES
Silver

Re: problems with ssh in 827

Did you generate key for ssh?

cry key generate rsa

Detailed doc:

http://www.cisco.com/warp/public/707/ssh.shtml

line con 0

exec-timeout 120 0

login ---- ! missing

password xxx ---- ! missing

logging synchronous ---- ! not required, but cool

line vty 0 4

access-class 1 in

exec-timeout 120 0

password 7 xxxxx

login

transport input ssh

bye

FCS

Please rate me if I helped.

New Member

Re: problems with ssh in 827

Hi, I have added few more lines:

line con 0 login and pass.

Rsa is already created...

I still can not login using ssh with a ssh client.....

Hall of Fame Super Silver

Re: problems with ssh in 827

Edgar

The original post mentions being able to access the router via console and via SSH. You seem mostly to be describing access via SSH. In the original configuration that you posted it looks to me like connecting to the console should have let you righ in. When you add login and password to the console you should be able to access the console if you enter the password that you configured. Is that working or not?

SSH is for remote access. And it looks to me like the configuration should work, assuming that the key has been generated, and you say that it has. I see that the configuration has a username and password configured. Is that what you want to use to login? If so I would suggest changing the config on the vty from login to login local. This will prompt for a username and password configured on the local router. As configured I would expect it to work if you login with the password configured on the vty.

I also note that the config of the vty has access class configured which controls which addresses can access the router. Am I correct in assuming that you are accessing the router from an address that is in access list 1?

If it is still not working then running debug for SSH and posting the output would help us to figure out what the problem is.

HTH

Rick

New Member

Re: problems with ssh in 827

Hi, thaks for quickly responding

Many things:

-rsa key is already generated.

-the ip addres from i try to connect is in class 1

-the user and pass for routing administration is the same to line con 0 and vty 0 4.

I use bitvise client to connect by ssh to several devices, for example cisco routers...the banner is show when I try to connect to the 827 but it asks for pass...

best best regards

147
Views
0
Helpful
4
Replies
CreatePlease to create content