Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QoS on 2821/1801 with WIC-1ADSL

Hi,

I'm trying to implement CBWFQ, WRED and traffic shaping on an ADSL service. I'm only using the default class in the Child policy at this stage, but will expand to more later. Can I use the Parent/Child model and if so where do I apply the service-policy output Parent command?

If I can't use Parent/Child to perform the shaping and CBWFQ/WRED, I suppose I need to use ubr/vbr etc on the ATM PVC to perform the shaping. But if I do that, where to I apply the CBWFQ/WRED policy?

Please see config below:

interface atm0

description ATM Interface

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

interface dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname XX

ppp chap password XX

policy-map Child

class class-default

fair-queue

random-detect dscp-based

policy-map Parent

class class-default

shape average 400000

service-policy Child

10 REPLIES
Purple

Re: QoS on 2821/1801 with WIC-1ADSL

You need to shape on the ATM PVC and then apply the child policy under the 'pvc 8/35' configuration level as below:

interface atm0

description ATM Interface

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

service-policy output Child

There is no need (or support) for a shaping parent policy because the shaping will be done at the ATM level.

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: QoS on 2821/1801 with WIC-1ADSL

Thanks for your prompt reply Paresh.

I've done as suggested and configured vbr shaping on the pvc and added the Child policy. However, when I do sh policy-map int I get nothing...?

Jon

Purple

Re: QoS on 2821/1801 with WIC-1ADSL

Can you post your config ?

Paresh

New Member

Re: QoS on 2821/1801 with WIC-1ADSL

Important bits below:

boot-start-marker

boot system flash flash:c2800nm-advipservicesk9-mz.124-3b.bin

boot-end-marker

policy-map Child

class class-default

fair-queue

random-detect dscp-based

interface ATM0/0/0

description ADSL Service

bandwidth 399

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

vbr-nrt 512 399 3392

encapsulation aal5mux ppp dialer

dialer pool-member 1

service-policy output Child

interface Dialer0

description PPP Session

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname xx

ppp chap password xx

Purple

Re: QoS on 2821/1801 with WIC-1ADSL

Hmmm... that all seems to be in order, mate. So the command you entered was 'sh policy-map interface atm0/0/0', wasn't it ?

Paresh

New Member

Re: QoS on 2821/1801 with WIC-1ADSL

Yeah, and 'sh policy-map int' by itself...might upgrade the IOS and see what happens.

Jon

New Member

Re: QoS on 2821/1801 with WIC-1ADSL

I've upgraded to the latest IOS, but still no good. Even though the shaping is configured on the atm vc, should the policy map be put on the dialer int?

Purple

Re: QoS on 2821/1801 with WIC-1ADSL

I suspect that might be the case, since the ATM interface is being used purely as a physical interface and the dialer interface is the logical interface here...

Paresh

Purple

Re: QoS on 2821/1801 with WIC-1ADSL

Actually, I'm not sure if that is correct.... you should still be able to apply a policy to the ATM interface.

One thing that concerns me is the abnormally high value of MBS that you have used. What's the reason for that ? Is it possible that you could set it to something like 1 and see if that makes a difference ?

Paresh

New Member

Re: QoS on 2821/1801 with WIC-1ADSL

The MBS was an error on my part, I had it configured in bits instead of cells. It's now 64 cells, however no change to policy map. Although the dialer int will take the command and show up in a sh policy-map int, I'm concerned that the congestion backpressure from the atm int will not be passed to the dialer ints layer three queues and the CBWFQ/WRED will not kick in. Haven't tested it yet though.

330
Views
0
Helpful
10
Replies