Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Routing via AUX port

I have a dial-up modem connected to my router's AUX port.

Using this setup, I need to get remote users to access our internal servers via dial-up.

The users aren't network admins, so they should not have exec access to the routers. They only need to be able to access the servers on our system, i.e. I need to route their Laptops's traffic via the aux port to the intended server.

Is there a way of configuring the router and modem to do this? Or do I need more equipment in order for this to work?

The router is a 2960 series and the modem is a US Robotics dial up modem.

Any help is greatly appreciated. Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Routing via AUX port

For diarect dial connection, there should not be a lot of difference - the AUX port should run PPP automatically and as long as the PC recognises this it should negotiate and connect.

6 REPLIES
Hall of Fame Super Gold

Re: Routing via AUX port

Yes, configure ppp for the aux and dial-in. Performances won;t be stellar, but it works.

New Member

Re: Routing via AUX port

Hi, thanks for the tip, but I thought you can't configure ppp on AUX ports?

Cisco Employee

Re: Routing via AUX port

These configs are a bit old and crusty , but they should give you an idea on how to set up async routing on the AUX ports. As Paolo says , performance is not brilliant, but it will work ... The chat scripts would likely need to be modified to suit your particular modems -

#####DIALING SIDE############

username PRIROUTER password SAMEPASSWORDS

chat-script modem "" "atdt\T" TIMEOUT 60 CONNECT \c

chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0" "OK"

!

interface Async1

ip address 192.168.10.2 255.255.255.0

encapsulation ppp

async default routing

async mode interactive

dialer in-band

dialer string 5553731

dialer-group 1

ppp authentication chap

!

ip route 0.0.0.0 0.0.0.0 Async1

!

dialer-list 1 protocol ip permit

!

line aux 0

modem InOut

script reset rstusr

transport input all

flowcontrol hardware

script dialer modem

######RECEIVING SIDE##############

Username RouterA password cisco

!

interface Async1

ip address 192.168.10.1 255.255.255.0

encapsulation ppp

async default routing

async mode dedicated

dialer in-band

dialer-group 1

ppp authentication chap

!

ip route 0.0.0.0 0.0.0.0 async1

!

dialer-list 1 protocol ip permit

!

chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0" "OK"

!

line aux 0

modem InOut

script reset rstusr

transport input all

flowcontrol hardware

New Member

Re: Routing via AUX port

Hi, Thanks for the tip. If I were dialing from a Laptop connected to a modem, would there be any differences in the configuration?

Thanks.

Cisco Employee

Re: Routing via AUX port

For diarect dial connection, there should not be a lot of difference - the AUX port should run PPP automatically and as long as the PC recognises this it should negotiate and connect.

New Member

Re: Routing via AUX port

Thanks for the tip, guys. I've finally been able to get this run-down modem to work.

217
Views
8
Helpful
6
Replies
CreatePlease to create content