Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Split tunneling question

I'm trying to configure split tunneling on a site to site vpn connection using an ASA 5505 at the remote site and a 5520 at the HQ site.

The tunnel is established and both inside networks can communicate but I want users at the remote site to use thier local ISP for internet.

In the ASDM 6.4 I browsed to "Remote Access VPN" and selected "Group Policies" under the "Network (Client) Access" drop down. From there I selected my tunnel group policy, selected edit and under the "Advanced", "Split Tunneling" I de-selected the "Inherit" checkboxes on "Policy" and "Network List".

In the "Policy" drop down I selected "Exclude Network List Below" and in the "Network List" drop down I created an extended ACL with two ACE's. One allowing ANY ANY on http and another allowing ANY ANY on https. I named that ACL "Split_Tunnel" and then selected that name under the "Network List" drop down.

I'm missing something because this in itself doesn't allow clients behind the ASA to get internet access.

I should also mention that the remote site is using DSL with a static IP and the modem is configured with DMZ hosting to pass that public IP over to the outside interface of the ASA. The ASA's outside interface is pulling a DHCP address from the DSL modem and the modem is NATting the traffic between the private IP handed to the ASA and the public IP forwarded from the modem.

              

As I said, both inside networks on the local and remote inside LAN's are communicating. I just cant get the users of the remote network to use the DSL for internet access.

Any thoughts?

Thanks!

  • Remote Access
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Split tunneling question

Here you go:

nat (inside,outside) source static local-lan local-lan destination static remote-lan remote-lan

object network obj-10.100.100.0

     subnet 10.100.100.0 255.255.255.0

     nat (inside,outside) dynamic interface

Then "clear xlate" to clear the existing translation.

6 REPLIES
Cisco Employee

Split tunneling question

Can you please share your remote site current configuration so we can help you to configure internet access directly via the remote ISP.

New Member

Split tunneling question

Hi Jennifer,

I just happen to have that handy so here ya go!

ASA Version 8.4(2)
!
hostname 5505
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 10.100.100.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
boot system disk0:/asa842-k8.bin
ftp mode passive
object network local-lan
subnet 10.100.100.0 255.255.255.0
object network remote-lan
subnet 10.100.200.0 255.255.255.0
object-group network obj_any
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list cryptomap extended permit ip object local-lan object remote-lan
access-list split_tunnel extended permit tcp object local-lan any eq www
access-list split_tunnel extended permit tcp object local-lan any eq https
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-645.bin
no asdm history enable
arp timeout 14400
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 10.100.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
crypto ipsec ikev1 transform-set 5505trans esp-aes-256 esp-sha-hmac
crypto map outside 1 match address cryptomap
crypto map outside 1 set pfs
crypto map outside 1 set peer XXX.XXX.XXX.XXX
crypto map outside 1 set ikev1 transform-set 5505trans
crypto map outside interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy 5505_policy internal
group-policy 5505_policy attributes
vpn-tunnel-protocol ikev1
split-tunnel-policy excludespecified
split-tunnel-network-list value split_tunnel
tunnel-group XXX.XXX.XXX.XXX type ipsec-l2l
tunnel-group XXX.XXX.XXX.XXX general-attributes
default-group-policy 5505_policy
tunnel-group XXX.XXX.XXX.XXX ipsec-attributes
ikev1 pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:1f61959023bcae9d9f3d1d2da4260716

Cisco Employee

Split tunneling question

Here you go:

nat (inside,outside) source static local-lan local-lan destination static remote-lan remote-lan

object network obj-10.100.100.0

     subnet 10.100.100.0 255.255.255.0

     nat (inside,outside) dynamic interface

Then "clear xlate" to clear the existing translation.

New Member

Split tunneling question

zippidy do da!

That worked Jennifer!

Awesome! Thanks much!

I'm not entirely keen on why that work so I'll have to disect it and wrap my head around it but it worked perfectly!

Thanks so much!

Cisco Employee

Split tunneling question

Cheers, thanks for the update.

In simple words (hopefully ):

1) nat (inside,outside) source static local-lan local-lan destination static remote-lan remote-lan:

--> no NATing between your local subnet when destination is towards remote LAN subnet.

2) object network obj-10.100.100.0

     subnet 10.100.100.0 255.255.255.0

     nat (inside,outside) dynamic interface

--> for any other destination, PAT that to the ASA outside interface IP Address (public IP).

New Member

Split tunneling question

Thanks for the explaination Jennifer.

I think I got it now. The new NATing is taking me a little bit of getting used to but it's making more sense. The concept of object oriented NAT statements within the context of the object configuration is what threw me.

Thanks again for the help!

Mike

1865
Views
0
Helpful
6
Replies