Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Telnet into router

Hi

I have a cisco 2600 router , I am able to login to router using COM port of my Laptop.

I want to do telnet into the router without directly connecting the laptop to router.

How can i telnet into it without configuring term server ?

what IP address should i give? MY PC is connected to LAN. Can we assign DHCP assigned IP address to router and perform telnet?

Pls clarify.

Thanks

Navaz

  • Remote Access
Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Telnet into router

you dont have 4 port ethernet card in router:  EHWIC-4ESG

please insert this card otherwise u will not able to create vlan.

***Note: This module need minimum 15.1(2)T: IP Base License of the Universal Image

for these routers.  Cisco 1921,1941,2900,3900

Reagrds

10 REPLIES
VIP Purple

Telnet into router

Hi Nawaz,

Here is the basic toplogy:

Router config

-----------------------------

Router#config t

Router(config)#username sandeep privilege 15 secret sandeep

then configure the one of the interface of the router:

Router#config t

Router(config)#interface fa0/0

Router(config-if)#ip address 10.10.10.254 255.255.255.0

Router(config-if)#no shut

Then configure for telnet access

Router#config t

Router(config-if)#line vty 0 15

Router(config-line)#login local

then save the config. by run the wr command

--------------------------------------------------------------------------------------------------------------------

Switch Config:

-----------------------------------

Router#config t

Router(config)#username sandeep privilege 15 secret sandeep

then configure the one of the vlan interface of the switch:

Switch#config t

Switch(config)#interface vlan 1

Switch(config-if)#ip address 10.10.10.1 255.255.255.0

Switch(config-if)#no shut

Then configure the port on swicth where router is connected:

Switch#config t

Switch(config)#interface fa0/0

Switch(config-if)#no shut

Then configure for telnet access

Switch#config t

Switch(config-if)#line vty 0 15

Switch(config-line)#login local

then save the config. by run the wr command

--------------------------------------------------------------------------------------------

Finall you must assign the ip address to computer:

ip : 10.10.10.5

Mask: 255.255.255.0

Gateway: 10.10.10.1

and then try to telnet from your computer to reach router by:

open cmd

then type telnet 10.10.10.254

PC>telnet 10.10.10.254

Trying 10.10.10.254 ...Open

User Access Verification

Username:

.................................................................

Hopoe it helps.

Regards

Dont forget to rate helpful posts.

If you are satisfied with the answer then plz Mark this question as answered.

New Member

Telnet into router

Thanks a lot sandeep.

My set up is looks like this.

      pc1,pc2,pc3-----lan-----router

Pc1 ip address is 172.x.x.x i am at university network .I think this ip  assigned by dhcp.

I have connected one of lan port to router.

Does router assign ip by itself when it connected to lan or we need to configure it as dhcp client?

Else can we manually assign a ip? I dont have any public ip.which ip i should give?

Pc1> telnet routerip

Could you pls help me in this scenario.

Thanks in advance.

VIP Purple

Telnet into router

Hi Abdul,

is there a swicth between router and your PC or you are directly connected to router???

Reagrds

New Member

Telnet into router

I dont have a switch connected to router.

VIP Purple

Telnet into router

HI Abdul,

here is ur topology:

FIRST THING:

Router must have 4 port ethernet card(For Switching....Layer 2..)

Router config

-----------------------------

Router#config t

Router(config)#username sandeep privilege 15 secret sandeep

then configure the one of the interface of the router:

Router#config t

Router(config)#interface vlan 1

Router(config-if)#ip address 172.30.10.254 255.255.255.0

Router(config-if)#no shut

Then configure for telnet access

Router#config t

Router(config)#line vty 0 15

Router(config-line)#login local

create a pool on router:

Router#config t

Router(config)# ip dhcp pool LAN

Router(dhcp-config)# network 172.30.10.0 255.255.255.0

Router(dhcp-config)# default-router 172.30.10.254

Assign iNtreface to each computers:

Router#config t

Router(config)#interface fa0/0/0

Router(config-if)#switchport mode access

Router(config-if)#switchport access vlan 1

then save the config. by run the wr command

then u can try from one of the computer:

PC>telnet 172.30.10.254

Trying 172.30.10.254 ...Open

User Access Verification

Username:

Hope it helps.

Regards

Dont forget to rate helpful posts.

If you are satisfied with the answer then plz Mark this question as answered.

New Member

Is there a way to a Telnet

Is there a way to a Telnet from router to router?

New Member

Telnet into router

I am following the same procedure. But unable to create a vlan on my cisco2600 router.

Router(config)#interface vlan 10

                          ^

% Invalid input detected at '^' marker.

Router(config)#

Router(config)#vlan 10

                ^

% Invalid input detected at '^' marker.

Router(config)#^Z

Router#

Router#

*Mar  1 18:23:52.703: %SYS-5-CONFIG_I: Configured from console by console

Router#vlan database

        ^

% Invalid input detected at '^' marker.

Router#vlan ?

% Unrecognized command

VIP Purple

Telnet into router

you dont have 4 port ethernet card in router:  EHWIC-4ESG

please insert this card otherwise u will not able to create vlan.

***Note: This module need minimum 15.1(2)T: IP Base License of the Universal Image

for these routers.  Cisco 1921,1941,2900,3900

Reagrds

New Member

Telnet into router

Thanks a lot.

I am done.

I have connected a router1 port to LAN and configured a DHCP assigned IP (172.X.X.X).

I am able to telnet into it.

I have created a another setup.

LAN---------------Router1--- (fa0/1)-----f(a0/1)-Router2--(fa0/0)--------fa(0/0)--Router3

R1:

fa0/1=====10.10.10.1

R2:

fa0/1=====10.10.10.2

fa0/0=====20.20.20.1

R3:

fa0/0====20.20.20.2

I telnet to R1 using 172.X Ip.

From R1 to R2 using R1> telnet 10.10.10.2

From R2 to R3 using R2> telnet 20.20.20.2

I suceeded doing so.

is there any other way of doing it? Am i following the steps correctly?

31792
Views
5
Helpful
10
Replies