Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Unable to telnet over asynchronous lines (Aux 0) : cisco 881G

Hi Everybody,

I have a problem to configure reverse telnet in cisco 881g router witch have the Console and the Aux port in the same physical port.

How to ensure that the aux port in use instead of the console port ?

My need is to access to a cisco switch in the same lan as the router.

I have connected the aux port to switch"s console port with a rolled cable, is the cabling correct ?

Please if someone can help on this, i have already seen some posts in this forum but not resolve my problem ?

Thanks,

Everyone's tags (2)
7 REPLIES
Hall of Fame Super Silver

Re: Unable to telnet over asynchronous lines (Aux 0) : cisco 88

Hello Deternay,

>> How to ensure that the aux port in use instead of the console port ?

I agree this is the key point

860/880/890 config guide suggests that configuring the aux port can be enough you should try

see

http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/routconf.html#wp1133900

an example of config that worked for me using the aux port of a C3640 to connect to console of another router:

sh run | beg line aux

line aux 0

modem InOut

transport input all

flowcontrol hardware

the cable was rollover

you need to use show line to find out the line number associated to the aux port on your router

you need a loopback interface with an IP address

you need to telnet to loopback's ip address with port = 2000+line#

you can use a host command as an alias for the reverse telnet operation

Hope to help

Giuseppe

New Member

Re: Unable to telnet over asynchronous lines (Aux 0) : cisco 88

Hi giuslar,

Thanks for your help.

i have configured an ip host with the name SW1.

when i try to telnet, i get just open and the line is still blocked utinl clear it :

Router#sw1
Trying SW1 (93.18.49.192, 2001)... Open


the line config is :

==

line con 0
no modem enable

line aux 0
modem InOut
no exec
transport input all
transport output none

==

show line output :

Router#sh line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*     0 CTY              -    -      -    -    -      0       0     0/0       -
      1 AUX      0/0     - inout     -    -    -      5       0     0/0       -
      3 TTY              -    -      -    -    -      0       0     0/0     Ce0
*     6 VTY              -    -      -    -    -     13       0     0/0       -
      7 VTY              -    -      -    -    -      0       0     0/0       -
      8 VTY              -    -      -    -    -      0       0     0/0       -
      9 VTY              -    -      -    -    -      0       0     0/0       -
     10 VTY              -    -      -    -    -      0       0     0/0       -

Line(s) not in async mode -or- with no hardware support:
2, 4-5

I see that the console port is active ? is this right ?

in 881 router, the console port and aux are in the same physical interface.

Thanks for your help

New Member

Re: Unable to telnet over asynchronous lines (Aux 0) : cisco 88

Hi everybody,

The telnet debug show that the telnet is blocked at the following step :

*Nov 19 08:24:34.318: Telnet1: 1 1 251 1
*Nov 19 08:24:34.318: TCP1: Telnet sent WILL ECHO (1)
*Nov 19 08:24:34.318: Telnet1: 2 2 251 3
*Nov 19 08:24:34.318: TCP1: Telnet sent WILL SUPPRESS-GA (3)
*Nov 19 08:24:34.318: Telnet1: 80000 80000 253 24
*Nov 19 08:24:34.318: TCP1: Telnet sent DO TTY-TYPE (24)
*Nov 19 08:24:34.318: Telnet1: 10000000 10000000 253 31
*Nov 19 08:24:34.318: TCP1: Telnet sent DO WINDOW-SIZE (31)
*Nov 19 08:24:34.322: Telnet6: Sent SB NAWS 80 25
*Nov 19 08:24:34.322: TCP1: Telnet received DO ECHO (1)
*Nov 19 08:24:34.322: TCP1: Telnet received DO SUPPRESS-GA (3)
*Nov 19 08:24:34.322: TCP1: Telnet received WILL TTY-TYPE (24)
*Nov 19 08:24:34.322: Telnet1: Sent SB 24 1
*Nov 19 08:24:34.322: TCP1: Telnet received WILL WINDOW-SIZE (31)
*Nov 19 08:24:34.322: Telnet1: recv SB NAWS 80 25
*Nov 19 08:24:34.322: Telnet6: recv SB 24 1
*Nov 19 08:24:34.322: Telnet6: Sent SB 24 0 vt100
*Nov 19 08:24:34.322: Telnet1: recv SB 24 0 vt100

after no response.

Could someone help on this and explain why we did't receive TTY-location/speed ?

*Nov 19 08:28:10.774: TCP8: Telnet received WONT TTY-LOCATION (23)
*Nov 19 08:28:10.774: TCP8: Telnet received WONT TTY-SPEED (32)

Thanks for your help.

New Member

Re: Unable to telnet over asynchronous lines (Aux 0) : cisco 88

Hi,

the problem is that the AUX port had a initial bad configuration.

You need to set the next parameters:

line aux 0

     speed 9600

     stopbits 2

     databits 8

     transport input all

     terminal-type xterm

And now it's ready.

good Luck

New Member

Re: Unable to telnet over asynchronous lines (Aux 0) : cisco 88

according to Cisco doumentation you need to enter the following command:

line con 0

modem enable

This is because the AUX and Console port are the same physical interface and one can only be active at a time. You have to effectively disable the console port by entering "modem enable" by which then enables the AUX port (for modem or reverse telnet).

This can be seen in the manual on page 5-13, Step 15 on : http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/SCG880-860.pdf

New Member

Re: Unable to telnet over asynchronous lines (Aux 0) : cisco 88

Hi,

the problem is that the AUX port had a initial bad configuration.

You need to set the next parameters:

line aux 0

     speed 9600

     stopbits 2

     databits 8

     transport input all

     terminal-type xterm

And now it's ready.

good Luck

New Member

Try the following:line con 0

Try the following:

line con 0
 modem enable
line aux 0
 no exec
 transport input all

The key command here is the "modem enable" command under the "line con 0" configuration.  This enables the virtual AUX functionality on the console port.

5707
Views
2
Helpful
7
Replies
CreatePlease to create content