Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vpdn over serial (CE>LAC>LNS)

Hi, i'm trying to connect a router with a serial interface to a LAC via ppp with chap auth and the L2TP to an LNS.

CE s1/1 > s2/1 LAC fa1/0 > fa1/4 LNS

i have made sure the credentials are the same for chap etc but this does not seem to work. i can see the call user on the LNS, but it dissapears after only a few seconds. Am i missing something here..? see below for relevant config

####CE DEVICE

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login dialin local

aaa authentication ppp default local

aaa authentication ppp dialin local

aaa authorization network default local

aaa session-id common

ip subnet-zero

!

!

ip cef

!

!

username user@test.com password 0 xxxxx

!

!

!

!

interface Serial1/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/1

bandwidth 2000

no ip address

encapsulation ppp

serial restart-delay 0

ppp authentication chap callin

ppp chap hostname user@test.com

ppp chap password 0 xxxxxxxx

!

#####LAC Device

hostname LAC

!

boot-start-marker

boot-end-marker

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login dialin local

aaa authentication ppp default local

aaa authentication ppp dialin local

aaa authorization network default local

!

aaa session-id common

memory-size iomem 5

ip cef

!

!

!

!

ip host LNS 192.168.20.1

vpdn enable

vpdn search-order domain

!

vpdn-group Remote

request-dialin

protocol l2tp

domain test.com

initiate-to ip 192.168.20.1

l2tp tunnel password 0 tunnel

!

!

username user@test.com password 0 xxxxxxxx

!

interface FastEthernet1/0

ip address 192.168.20.2 255.255.255.0

speed 100

full-duplex

interface Serial2/1

no ip address

encapsulation ppp

serial restart-delay 0

!

##LNS DEVICE

hostname LNS

!

boot-start-marker

boot-end-marker

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login dialin local

aaa authentication ppp default local

aaa authentication ppp dialin local

aaa authorization network default local

!

aaa session-id common

memory-size iomem 5

ip cef

ip host LAC 192.168.20.2

vpdn enable

!

vpdn-group Remote

accept-dialin

protocol l2tp

virtual-template 1

terminate-from hostname LAC

source-ip 192.168.20.1

lcp renegotiation always

l2tp tunnel password 7 1311021C050908

!

username user@test.com password 7 xxxxxxxx

!

interface Loopback150

ip address 192.168.5.1 255.255.255.255

!

!

interface FastEthernet1/4

no switchport

ip address 192.168.20.1 255.255.255.0

duplex full

speed 100

!

interface Virtual-Template1

ip unnumbered Loopback150

peer default ip address pool xDSL_POOL

ppp authentication chap

!

ip local pool xDSL_POOL 192.168.5.5 192.168.5.10

Not sure if i need a dialer inteface somewhere or i'm missing something basic. As i can see the attempts on the LNS i think its almost there? The l2tp tunnel seems stable.

I would appreciate some ideas here alot.

Many thanks in advance.

4 REPLIES
New Member

Re: vpdn over serial (CE>LAC>LNS)

Hi, iknow this is an old post. We're trying to do something similiar. We are using a dialer interface but it is still giving some problems. Did you get it to work?

New Member

Re: vpdn over serial (CE>LAC>LNS)

Yes I did. What problem are you having?

New Member

Re: vpdn over serial (CE>LAC>LNS)

Hi

How did you link the serial interface with the l2tp tunnel?

We thought about using a dialer interface with a dialer pool but it doesn't seem to be working.

New Member

Re: vpdn over serial (CE>LAC>LNS)

Hi

We tried to use a dialer interface to link the incoming serial link witht the l2tp tunnel. But you need a dialer string (usually an ISDN number).

How did you overcome this problem or did you use a different method?

At this point any help will be great.

253
Views
0
Helpful
4
Replies
CreatePlease to create content