Evitando problema devido a Redistribuição de Rota

Introdução


Neste documento veremos algumas técnicas para evitar problemas quando estamos redistribuindo rotas de um protocolo de roteamento em outro.


Pré-requisitos

Requerimentos

Não existem requerimentos específicos para este documento.

Componentes utilizados

As informações deste documento são baseadas nas seguintes versões de hardware e software:


  • Cisco      IOS® Software Release 12.2(10b)
  • Cisco      2500 Series Routers

NOTA: As informações deste documento foram criadas com base em um ambiente especifico de laboratório. Todos os equipamentos utilizados para o desenvolvimento deste documento tinham suas configurações default. Se sua rede está em um ambiente de produção certifique-se de ter entendido os potenciais impactos de qualquer um desses comandos em sua rede.

Convenções

Consulte o Cisco Technical Tips Conventions para mais informações sobre as convenções (em Inglês).

Evitando problema devido a Redistribuição de Rota

Na sessão Distância Administrativa você viu como redistribuição potencialmente pode causar problemas como: roteamento não otimizado, loop de roteamento, ou convergência lenta. Previnir estes tipos de problema é muito simples – Nunca anuncie a informação recebida originalmente do processo de roteamento X de volta para o processo de roteamento X.

Exemplo 1

image001.gif

Na topologia anterior, R2 e R5 estão fazendo redistribuição mútua. RIP está redistribuindo no IGRP e IGRP está redistribuindo no RIP, conforme exibido nas configurações abaixo:

R2:

router igrp 7

network 181.16.0.0

redistribute rip metric 1 1 1 1 1

router rip

network 178.1.0.0

redistribute igrp 7 metric 2

R5:

router igrp 7

network 181.16.0.0

redistribute rip metric 1 1 1 1 1

router rip

network 178.1.0.0

redistribute igrp 7 metric 2

Com a configuração anterior você tem potencial para qualquer um dos problemas descritos anteriormente. A fim de evita-los, você pode filtrar a atualização de rotas da seguinte forma:

R2:

router igrp 7

network 181.16.0.0

redistribute rip metric 1 1 1 1 1

distribute-list 1 in s1

router rip

network 178.1.0.0

redistribute igrp 7 metric 2

access-list 1 deny 192.168.1.0

access-list 1 permit any

R5:

router igrp 7

network 181.16.0.0

redistribute rip metric 1 1 1 1 1

distribute-list 1 in s1

router rip

network 178.1.0.0

redistribute igrp 7 metric 2

access-list 1 deny 192.168.1.0

access-list 1 permit any

A lista de distribuição adicionada às configurações, como exibido acima, filtra qualquer atualização IGRP que vêm para a interface serial 1 dos roteadores. Se as rotas, nas atualizações, são permitidas pela lista de acesso 1, o roteador aceita a atualização, caso contrário, não. Neste exemplo, os roteadores estão sendo informados de que eles não devem aprender a rede 192.168.1.0 através das atualizações IGRP que recebem em sua interface serial 1. Portanto, o único conhecimento que estes roteadores tem sobre a rede 192.168.1.0 é através do RIP a partir do R1.


Também tenha em mente que, neste caso, não é necessário usar a mesma estratégia de filtro para o processo do RIP porque o RIP tem uma distancia administrativa maior que o IGRP. Se as rotas que se originam no domínio IGRP foram anunciadas de volta para R2 e R5 através do RIP, as rotas IGRP ainda prevalecem.


Exemplo 2

image002.gif


Usando a topologia acima, outro método, que as vezes é melhor, para evitar problemas de redistribuição pode ser demonstrado. Este método utiliza route-maps para definir tags para diversas rotas. O Processos de roteamento pode redistribuí as rotas com base nas tags. Note que a redistribuição baseada em tags não funcionam com o RIP versão 1 ou IGRP.


Um dos problemas que você pode encontrar na topologia anterior é o seguinte:


R1 anuncia a rede 192.168.1.0 para R2, que em seguida, redistribui para o EIGRP. R5 aprende a rede via EIGRP e redistribui para o RIPv2. Dependendo da métrica que R5 dafina para a rota RIPv2, R6 pode preferir a rota menos desejável através de R5 em vez de através de R1 para alcançar a rede 192.168.1.0. A seguinte configuração ajuda a evitar isso, definindo tags, e depois redistribuindo com base nas tags:

R2:

router eigrp 7

network 181.16.0.0

redistribute rip route-map rip_to_eigrpmetric 1 1 1 1 1

!--- Redistribui as rotas RIP que são permitidas pelo route-map

!--- rip_to_eigrp

router rip

version 2

network 178.1.0.0

redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistribui as rotas EIGRP e definir as tags de acordo com

!--- eigrp_to_rip route-map

route-map rip_to_eigrp deny 10

match tag 88

!--- Declaração Route-map para negar todas as rotas que têm uma tag

!--- "88" de serem redistribuídas no EIGRP

!--- Note que as rotas com a tag "88" devem ser as rotas EIGRP que

!--- são redistribuídas no RIPv2

route-map rip_to_eigrp permit 20

set tag 77

!--- Declaração Route-map para definir a tag “77” nas rotas RIPv2

!--- redistribuídas no EIGRP.

route-map eigrp_to_rip deny 10

match tag 77

!--- Declaração Route-map para negar todas as rota que tenha uma tag “77”

!--- de serem redistribuídas no RIPv2.

!--- Note que as rotas com tag “77” devem ser as rotas RIPv2 que foram

!--- redistribuídas no EIGRP.

route-map eigrp_to_rip permit 20

set tag 88

!--- Declaração Route-map para definir a tag “88” nas rotas EIGRP que são

!--- redistribuídas no RIPv2

R5:

router eigrp 7

network 181.16.0.0

redistribute rip route-map rip_to_eigrpmetric 1 1 1 1 1

!--- Redistribui as rotas RIPv2 que são permitidas pelo route-map

!--- rip_to_eigrp

router rip

version 2

network 178.1.0.0

redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistribui as rotas EIGRP e define a tag de acordo com o eigrp_to_rip

!--- route-map

route-map rip_to_eigrp deny 10

match tag 88

!--- Declaração Route-map para negar todas as rotas que têm uma tag

!--- "88" de serem redistribuídas no EIGRP

!--- note que as rotas com a tag "88" devem ser as rotas EIGRP que são

!--- redistribuídas no RIPv2

route-map rip_to_eigrp permit 20

set tag 77

!--- Declaração Route-map para definir a tag “77” nas rotas RIPv2

!--- redistribuídas no EIGRP.

route-map eigrp_to_rip deny 10

match tag 77

!--- Declaração Route-map para negar todas as rotas que tenha uma tag “77”

!--- de serem redistribuídas no RIPv2.

!--- Note que as rotas com tag “77” devem ser as rotas RIPv2 que foram

!--- redistribuídas no EIGRP.

route-map eigrp_to_rip permit 20

set tag 88

!--- Declaração Route-map para definir a tag “88” nas rotas EIGRP que são

!--- redistribuídas no RIPv2

Com a configuração realizada acima, você pode olhar para algumas rotas na tabela de roteamento para ver se as tags foram definidas conforme configurado. Abaixo segue uma saída do comando show ip route para rotas específicas em R3 e R1:

R3#show ip route 178.1.10.8

Routing entry for 178.1.10.8/30

  Known via "eigrp7", distance 170, metric 2560512256

  Tag 77, type external

  Redistributing via eigrp7

  Last update from 181.16.2.10 on Serial0, 00:07:22 ago

  Routing Descriptor Blocks:

  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0

      Route metric is 2560512256, traffic share count is 1

      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit

      Reliability 1/255, minimum MTU 1 bytes

      Loading 1/255, Hops 1

R1#show ip route 181.16.2.4

Routing entry for 181.16.0.0/16

  Known via "rip", distance 120, metric 2

  Tag 88

  Redistributing via rip

  Last update from 178.1.10.5 on Serial0, 00:00:15 ago

  Routing Descriptor Blocks:

  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0

      Route metric is 2, traffic share count is 1

EIGRP usa cinco variáveis ​​diferentes para calcular a métrica. No entanto, as rotas redistribuídas não tem esses parâmetros, o que faz com o que as rotas não sejam definidas uniformemente. A melhor prática é definir uma métrica padrão na redistribuição de rotas. Ao definir a métrica padrão, o desempenho do EIGRP pode ser otimizado. No EIGRP, as métricas default são inseridas com o comando:


Router(config-router)#default-metric 10000 100 255 100 1500

Exemplo 3

A redistribuição também pode ocorrer entre diferentes processos do mesmo protocolo de roteamento. A configuração a seguir é um exemplo de uma política de redistribuição utilizada para a redistribuição de dois processos EIGRP em execução no mesmo roteador ou em vários roteadores:

router eigrp 3

redistribute eigrp 5 route-map to_eigrp_3

default-metric 10000 100 255 1 1500

!--- Redistribui as rotas do processo EIGRP 5 no processo EIGRP 3,

!--- definindo as tags de acordo com o route-map to_eigrp_3

router eigrp 5

redistribute eigrp 3 route-map to_eigrp_5

default-metric 10000 100 255 1 1500

!--- Redistribui as rotas EIGRP 3 no EIGRP 5.

!--- Rotas com a tag “33” não serão redistribuídas Devido ao route-map

!--- to_eigrp_5.

!--- Embora o comando default-metric não seja necessário, quando a

!--- redistribuição é entre os diferentes processos do EIGRP, você pode

!--- usá-lo, opcionalmente, como mostrado acima, para anunciar as rotas com

!--- valores específicos para o cálculo da métrica.

route-map to_eigrp_3 deny 10

match tag 55

!--- Declaração Route-map usada para impedir todas as rotas que tenha a tag

!--- “55” de serem redistribuídas no EIGRP 3.

!--- Note que as rotas com tag “55” devem ser as rotas EIGRP 3 que foram

!--- redistribuídas no EIGRP 5.

route-map to_eigrp_3 permit 20

set tag 33

!--- Declaração Route-map para definir a tag “33” nas rotas EIGRP 5 que são

!--- redistribuídas no EIGRP 3.

route-map to_eigrp_5 deny 10

match tag 33

!--- Declaração Route-map usada para impedir todas as rotas que tenha a tag

!--- “33” de serem redistribuídas no EIGRP 5.

!--- Note que as rotas com tag “33” devem ser as rotas EIGRP 3 que foram

!--- redistribuídas no EIGRP 3.

route-map to_eigrp_5 permit 20

set tag 55

!--- Declaração Route-map para definir a tag “33” nas rotas EIGRP 5 que são

!--- redistribuídas no EIGRP 3.

Estes são apenas alguns exemplos de estratégias de filtragem que foram utilizados para a realização deste documento. No entanto, pode haver outras estratégias que podem ser utilizadas. Consulte a seção Filtragem de Informação de Roteamento em Configuring IP Routing Protocol-Independent Features para mais informações (em Inglês).


Exemplo 4


Por exemplo, você tem dois roteadores, um é superior e está rodando BGP, e o outro é inferior e está rodando RIP. Quando você redistribui as rotas BGP no RIP, é possível que você veja alguns pacotes sendo perdidos.

A redistribuição do BGP no RIP geralmente não é recomendada e protocolos como iBGP, OSPF e EIGRP são escaláveis e tem diversas opções disponíveis.

No caso de você encontrar este senário, com redistribuição entre BGP e RIP, e perca alguns pacotes, é possível que você tenha que configurar este comando no RIP:

Router(Config)#router rip

Router(Config-router)# input-queue 1024

Nota: Considere o uso do comando input-queue, se você tem um roteador “de ponta” que envia em alta velocidade para um roteador de baixa velocidade que pode não ser capaz processar estas informações na mesma velocidade. A configuração deste comando ajuda a prevenir a perda de informações da tabela de roteamento.

Exemplo 5

image003.gif


Este exemplo ilustra redistribuição rota estática no RIP. De acordo com a topologia, temos três roteadores (R1, R2, e R3). R1 e R2 têm o RIP configurado na interface Fa 0/0. R1 tem uma rota estática para alcançar a interface Lo 0 de R3 (endereço ip 3.3.3.3/32). Essa rota estática é redistribuída no RIP. R3 está configurado com uma rota default: ip route 0.0.0.0 0.0.0.0 FastEthernet 0/0.

R1(config)# iproute 3.3.3.3 255.255.255.255 10.13.13.3

R1(config)# router rip

R1(config-router) redistribute static metric 10

Em R2, a rota para 3.3.3.3 pode ser visto através do comando show ip route:

R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia- IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.12.12.0/24 is directly connected, FastEthernet0/0

     3.0.0.0/32 is subnetted, 1 subnets

R      3.3.3.3 [120/10] via 192.12.12.1, 00:00:07, FastEthernet0/0


Como Redistribuir Uma Única Rota Estática


A fim de redistribuir uma única rota estática, use route-map para selecionar a rota estática que precisa ser redistribuída.

Router(config)#access-list 1 permit <network no> <mask>

Router(config)#route-map <route-map name> permit 10

Router(config-route-map)#match ip address access list number

Router(config)#router eigrp <As number>

Router(config-router)#redistribute static route-map <mask> metric <value>

Histórico de versão
Revisão #
1 de 1
Última actualização:
‎12-03-2012 07:57 AM
Actualizado por:
 
Etiquetas (1)