Introdução

O uso de um protocolo de roteamento para anunciar rotas que são aprendidas por algum outro meio, como por outro protocolo de roteamento, rotas estáticas ou rotas diretamente conectadas, é chamado de redistribuição de rotas. O ideal é ter apenas um protocolo de roteamento em toda a rede, porém muitas vezes isso não é possível devido a inúmeros fatores, como por exemplo, a fusão de empresas, múltiplos departamentos gerenciados por vários administradores de rede, ambientes com equipamentos de diversos fabricantes e etc. Por esses motivos ter múltiplos protocolos de roteamento é geralmente comum e muitas vezes faz-se necessário redistribuir as rotas aprendidas por um ou outro protocolo.


Diferenças nas características dos protocolos de roteamento, como métricas, distâncias administrativas, se são classfull ou classless podem afetar a redistribuição. Essas diferenças devem ser levadas em consideração para se ter sucesso nas redistribuições de rotas.


Pré-requisitos

Requerimentos

Não existem requerimentos específicos para este documento.


Componentes utilizados

As informações deste documento são baseadas nas seguintes versões de hardware e software:


  • Cisco      IOS® Software Release 12.2(10b)
  • Cisco      2500 Series Routers

NOTA: As informações deste documento foram criadas com base em um ambiente especifico de laboratório. Todos os equipamentos utilizados para o desenvolvimento deste documento tinham suas configurações default. Se sua rede está em um ambiente de produção certifique-se de ter entendido os potenciais impactos de qualquer um desses comandos em sua rede.


Convenções

Consulte o Cisco Technical Tips Conventions para mais informações sobre as convenções (em Inglês).


Métricas

Quando você redistribui informações de rotas de um protocolo para outro, lembre-se que as métricas de cada protocolo desempenham um papel importante na redistribuição. Cada protocolo usa diferentes métricas. Por exemplo, As métricas do RIP são baseadas em contagem de saltos, mas IGRP e EIGRP usam uma composição de métricas baseadas em largura de banda (bandwidth), atraso (delay), confiabilidade (reliability), carga (load) e MTU, porém bandwidth e delay são os únicos utilizados por padrão. Quando rotas são redistribuídas você precisa definir uma métrica que o protocolo que irá receber essas rotas entenda. Existem dois métodos  para definir métricas no processo de redistribuição.

image001.gif

                        

Você pode definir uma métrica para cada redistribuição especifica:

router rip

redistribute static metric 1

redistribute ospf 1 metric 1

Ou você pode utilizar uma métrica padrão para todas as redistribuições (usando o comando default-metric, isto diminui o trabalho, porque elimina a necessidade de definir cada métrica separadamente):

router rip

redistribute static

redistribute ospf 1

default-metric 1

Distância Administrativa

Se o roteador está rodando mais que um protocolo de roteamento e aprende uma rota para o mesmo destino usando os dois protocolos de roteamento, então qual rota deve ser eleita a melhor rota? Cada protocolo usa sua própria métrica para determinar a melhor rota. Não é possível comparar rotas com diferentes tipos de métricas. A distância administrativa resolve esse problema. Distâncias administrativas são atribuídas às rotas de origem de modo que a rota de origem preferida será escolhida como melhor caminho.


Consulte Route Selection in Cisco Routers para mais informações sobre distâncias administrativas e seleção de rotas (em Inglês).


Distância administrativa ajuda na seleção de rotas entre os diferentes protocolos de roteamento. Mas pode causar problemas para a redistribuição. Estes problemas podem ser na forma de loop de roteamento, problemas de convergência ou rotas ineficientes. Veja abaixo uma topologia com a descrição de um possível problema.

image002.gif


Na topologia acima, se R1 está rodando RIP e R2 e R5 estão rodando RIP e IGRP e redistribuindo RIP no IGRP, então existe um problema em potencial. Por exemplo R2 e R5aprendem sobre a rede 192.168.1.0 através de R1 usando RIP. Este conhecimento é redistribuído no IGRP. R2 aprende sobre a rede 192.168.1.0 através de R3. E R5 aprende sobre esta rede a partir de R4 usando IGRP.  IGRP tem um valor menor de distância administrativa que RIP (100 x 120); Por este motivo, as rotas IGRP são as utilizadas na tabla de roteamento. Agora existe um potencial loop roteamento. Mesmo que o Split Horizon, ou qualquer outro mecanismo para ajudar a rede a ficar livre de loops entrarem em ação, ainda há um problema de convergência.


Se R2 e R5 estão também redistribuindo IGRP no RIP (também conhecido como redistribuição mútua) e a rede 192.168.1.0 não estiver diretamente conectada a R1 (R1 está aprendendo de outro roteador acima dele), então existe um problema que R1 vai aprender a rede 192.168.1.0 de R2 e R5 com uma melhor métrica que a original.


Nota: O mecanismo de redistribuição de rotas é proprietário nos roteadores Cisco.  As regras para redistribuição em um roteador Cisco ditam que a rota redistribuída esteja presente na tabela de roteamento. Não é suficiente que a rota esteja presente na tabela de topologia ou na database. Rotas com uma menor distância administrativa (AD) sempre são instaladas na tabela de roteamento. Por exemplo, Se uma rota estática redistribuída no IGRP em R5, e então IGRP consequentemente redistribuiu no RIP no mesmo roteador (R5), a rota estática não é redistribuída no RIP porque isto nunca teve na tabela de roteamento do IGRP. Isto é devido as fato que rotas estáticas tem uma AD de 1 e rotas IGRP tem AD de 100 e a rota estática está instalada no tabela de roteamento. De modo a redistribuir a rota estática no IGRP em R5, você precisa usar o comando redistribute static nas configurações de roteamento do RIP (router rip).


O comportamento padrão para o RIP, IGRP e EIGRP é de anunciar as rotas diretamente conectadas quando um seguimento de rede sob um protocolo de roteamento inclui a interface conectada da subrede. Há dois métodos de receber uma rota conectada.


·         Uma interface é configurada com um endereço de IP e máscara, a subrede correspondente é considerada uma rota conectada.

·         Uma rota estática é configurada com apenas uma interface de saída, e não um IP de um vizinho (next-hop), isto é considerada uma rota estática.


Router#conf t 
   Router(config)#ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)#end
 
   Router#show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Um comando network configurado no EIGRP, RIP ou IGRP que inclui (ou “cobre”) qualquer um desses tipos de rotas conectadas inclui a sub-rede para anúncio.

Por exemplo, se uma interface tem o IP 10.0.23.1 e máscara 255.255.255.0, a sub-rede 10.0.23.0/24 é uma rota conectada e será anunciada por um desses protocolos de roteamento quando o comando network for configurado conforme a seguir:


router rip | igrp # | eigrp #
   network 10.0.0.0

Esta rota estática 10.0.77.0/24 é também anunciada por este protocolo de roteamento, porque é uma rota conectada e está “coberta” pelo segmento de rede.

Leia a sessão Evitando problemas devido à Redistribuição de Rota deste documento para obter dicas de como evitar esses problemas.


Sintaxe de Redistribuição e Exemplos de Configuração

IGRP e EIGRP

Esta saída de comando exibe uma redistribuição no IGRP/EIGRP de rota estática, OSPF, RIP e IS-IS.

router igrp/eigrp1

network 131.108.0.0

redistribute static

redistribute ospf 1

redistribute rip

redistribute isis

default-metric 10000 100 255 1 1500

IGRP e EIGRP precisam de cinco métricas quando redistribuem outros protocolos: bandwidth, delay, reliability, load, e MTU, respectivamente. A seguir um exemplo das métricas do IRGP:

                          

Metric

 

Value

 

bandwidth

 

In units of kilobits per second; 10000 for Ethernet

 

Delay

 

In units of tens of microseconds; for Ethernet it   is100 x 10 microseconds = 1 ms

 

Reliability

 

255 for 100 percent reliability

 

Load

 

Effective load on the link expressed as a number   from 0 to 255 (255 is 100 percent loading)

 

MTU

 

Minimum MTU of the path; usually equals that for   the Ethernet interface, which is 1500 bytes

 

Múltiplos processos do IGRP e do EIGRP podem rodar no mesmo roteador, com redistribuição de rotas entre eles. Por exemplo IGRP1 e IGRP2 podem rodar no mesmo roteador. Porém rodar dois processos do mesmo protocolo no mesmo roteador é raramente necessário e pode consumir muito processador e memória.

A redistribuição de IGRP/EIGRP em outro processo IGRP/EIGRP não requer nenhuma conversão de métrica, não existe a necessidade de definir as métricas ou de utilizar o comando default-metric na redistribuição.

Uma redistribuição de rota estática recebe preferência sobre uma rota sumarizada porque a distância administrativa das rotas estáticas é 1 enquanto que a distância administrativa das rotas EIGRP sumarizadas é 5. Isto acontece quando uma rota estática é redistribuída com o uso do redistribite static sob o processo EIGRP e o processo EIGRP tem a rota padrão.


OSPF

Esta saída de comando exibe a redistribuição no OSPF de rotas estáticas, IGRP, EIGRP e IS-IS.

router ospf 1

network 131.108.0.0 0.0.255.255 area 0

redistribute static metric 200 subnets

redistribute rip metric 200 subnets

redistribute igrp 1 metric 100 subnets

redistribute eigrp 1 metric 100 subnets

redistribute isis metric 10 subnets

A métrica do OSPF é um valor de custo baseado no calculo: “108/ bandwidth do link em bits/sec”. Por exemplo, o custo OSPF para um link Ethernet é 10, pois, 108/107 = 10.


Nota: Se a métrica não é especificada, o OSFP define a métrica padrão de 20 para todos os protocolos, exceto rotas BGP que tem métrica 1.

Quando esta é uma rede que foi dividida em sub-redes, você precisa usar o comando subnet para redistribuir no OSFP. Sem esse comando o OSPF ira redistribuir somente a maior rede.


Isto é possível para executar mais que um processo OSPF em um mesmo reteador. Porém executar mais de um processo do mesmo protocolo é raramente necessário e pode consumir muita memória e processo.

Você não precisa definir nenhuma métrica ou usar o comando default-metricquando redistribui um processo OSPF no outro.


RIP

Nota: Esta seção do documento destina-se tanto a RIP versão 1 quanto ao RIP versão 2

Esta saída exibe redistribuição no RIP de rotas estáticas, IGRP, EIGRP, OSPF, e IS-IS.

router rip

network 131.108.0.0

redistribute static

redistribute igrp 1

redistribute eigrp 1

redistribute ospf 1

redistribute isis

default-metric 1

A métrica do RIP é composta de contagens de saltos, e o valor máximo válido como métrica é 15. Qualquer valor acima de 15 é considerado infinito, pode-se usar o valor 16 para descrever uma métrica inalcançável no RIP. Quando se distribui um protocolo no RIP a Cisco recomenda que você use uma métrica baixa como 1. Uma métrica alta como 10, limita o RIP ainda mais. Se você define a métrica 10 para redistribuir as rotas no RIP essas rotas somente poderão ser anunciadas para os próximos 5 saltos seguintes, ponto em que a métrica excede 15 saltos. Por definição com a métrica 1 você habilita a rota a dar o número máximo de saltos possíveis em um domínio RIP. Mas, isto aumenta a possibilidade de acontecer loop de roteamento caso exista múltiplos pontos de redistribuição e um roteador aprenda sobre a rede com uma métrica melhor que o ponto de distribuição original, como explicado na seção Distancia

Administrativa deste documento. Portanto, você tem que garantir que  a métrica não é nem muito alta, para que esta seja anunciada para todos os roteadores, nem muito baixa, levando a loop de roteamento quando há múltiplos pontos de redistribuição.


Redistribuindo Rotas Estáticas com Exceção do Gateway de último Recurso no RIP Usando Route Map


Esta configuração é um exemplo de redistribuição de rotas estáticas no RIP com exceção do gateway de último recurso através de routemap.

Configuração inicial para este exemplo:

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.32.32.3

ip route 10.32.42.211 255.255.255.255 192.192.192.102

ip route 10.98.0.0 255.255.255.0 10.32.32.1

ip route 10.99.0.0 255.255.255.0 10.32.32.1

ip route 10.99.99.0 255.255.255.252 10.32.32.5

ip route 67.129.103.128 255.255.255.240 10.32.31.1

ip route 156.55.231.0 255.255.255.0 10.32.32.5

ip route 172.16.28.0 255.255.252.0 10.32.32.5

ip route 192.168.248.0 255.255.255.0 10.32.32.5

ip route 199.43.0.0 255.255.255.0 10.32.32.5

ip route 204.103.0.0 255.255.255.0 10.32.32.5

Para realizar esta configuração siga estes passos na ordem apresentada:


1.     Crie uma access-list (lista de acesso), contendo todas as redes que precisam ser redistribuídas

Router#show access-lists 10

Standard IP access list 10

10 permit 10.32.42.211

20 permit 10.98.0.0, wildcard bits 0.0.0.255

30 permit 10.99.0.0, wildcard bits 0.0.0.255

40 permit 67.129.103.128, wildcard bits 0.0.0.15

50 permit 156.55.231.0, wildcard bits 0.0.0.255

60 permit 172.16.28.0, wildcard bits 0.0.3.255

70 permit 192.168.248.0, wildcard bits 0.0.0.255

80 permit 199.43.0.0, wildcard bits 0.0.0.255

90 permit 204.103.0.0, wildcard bits 0.0.0.255


2.     Chame esta lista de acesso em um route-map

Route-map TEST

Match ip address 10


3.     Faça a redistribuição no RIP utilizando o route-map e remova o comando default information originate do processo RIP

       Router RIP

       version 2

       network 10.0.0.0

       redistributestatic route-map TEST

       no auto-summary

IS-IS

Esta saída de comando exibe uma redistribuição no IS-IS de rotas estáticas, RIP, IGRP,EIGRP e OSPF


router isis

network 49.1234.1111.1111.1111.00

redistribute static

redistribute rip metric 20

redistribute igrp 1 metric 20

redistribute eigrp 1 metric 20

redistribute ospf 1 metric 20

A métrica IS-IS deve ser um número compreendido entre 1 e 63. Não existe a opção default-metric no IS-IS, com isso, você deve definir uma métrica para cada protocolo, como exibido no exemplo acima. Caso nenhuma métrica seja especificada para as rotas que  estão sendo redistribuídas no IS-IS a métrica 0 é utilizada por padrão.


Rotas Diretamente Conectadas


Redistribuir redes que estão diretamente conectadas em um protocolo de roteamento não é uma práatica comum e por essa razão não é exibido em nenhum exemplo. Porém, é importante você saber que pode ser feito, tanto direta quanto indiretamente. Para distribuir rotas diretamente conectadas utilize o comando redistribute connected. Você também deve definir a métrica para este caso. Você também pode redistribuir rotas indiretamente conectadas nos protocolos de roteamento, conforme o exemplo:

image003.gif


Neste exemplo, o roteador B tem duas interfaces Fast Ethernet. FastEthernet 0/0 está na rede 10.1.1.0/24 e a FastThernet 0/1 está na rede 20.1.1.0/24. O roteador B está rodando EIGRP com o roteador A e OSPF com o roteador C. O roteador B está redistribuindo as rotas dos processos EIGRP e OSPF.  A configuração à seguir é referente ao roteador B:

      

Router B

 

interface FastEthernet0/0

ip  address 10.1.1.4 255.255.255.0

interface FastEthernet0/1

ip  address 20.1.1.4 255.255.255.0

router eigrp 7

redistribute ospf 7 metric 10000 100 255 1 1500

network 10.1.1.0 0.0.0.255

auto-summary

no eigrp  log-neighbor-changes

!

router ospf 7

log-adjacency-changes

redistribute eigrp 7 subnets

network 20.1.1.0   0.0.0.255 area 0

 

Se você olhar a tabela de roteamento do Router B, você verá o seguinte:

routerB#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodicdownloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets

C       20.1.1.0 is directly connected, FastEthernet0/1

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, FastEthernet0/0

Em relação a configuração e a tabela de roteamento acima, podemos fazer três comentários:

  • As redes em questão estão na tabela de roteamento do roteador B como      diretamente conectadas.
  • A rede 10.1.1.0/24 faz parte do processo EIGRP e a rede 20.1.1.0/24 faz      parte do processo OSPF.
  • Router B está redistribuindo as rotas entre o EIGRP e o OSPF.

Abaixo estão as tabelas de roteamento dos roteadores A e C:

routerA#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, FastEthernet0

     20.0.0.0/24 is subnetted, 1 subnets

D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0

routerC#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodicdownloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets

C       20.1.1.0 is directly connected, FastEthernet1

O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

O roteador A tem aprendido sobre a rede 20.1.1.0/24 via EIGRP, que é exibida como uma rota externa, porque esta rede foi redistribuída do OSPF para o EIGRP. O roteador C tem aprendido sobre a rede 10.1.1.0/24 via OSPF como uma rota externa, porque esta rede foi redistribuída do EIGRP para o OSPF. Ainda que o roteador B não esteja redistribuindo redes diretamente conectadas, ele anuncia a rede 10.1.1.0/24 pois esta faz parte do processo EIGRP que é redistribuída para o OSPF. De forma similar, o roteador B anuncia a rede 20.1.1.0/24, pois esta faz parte do processo OSPF que é redistribuída para o EIGRP.

Consulte Redistributing Connected Networks into OSPF para mais informações sobre as rotas conectadas sendo redistribuídas no OSPF, (em Inglês).

Nota: Por padrão, somente informações aprendidas por EBGP são candidatas à redistribuição no IGP quando o comando redistribute bgp é utilizado. Rotas IBGP não são redistribuídas no IGP a menos que o comando bgp redistribute-internal seja configurado no comando router bgp. Mas precauções devem ser tomadas para prevenir loops  dentro do Autonomous System (Sistema autônomo) quando rotas IBGP são redistribuídas no IGP.

13367
Apresentações
5
Útil
0
Comentários