cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
New Member

Alto consumo da CPU snmp

PEssoal

Estou implantando um nexus 3064 para rodar:

ospf v2 e v3

queue

lacp

Ele ainda não está em produção. Está com versão 7 do NXOS e notei no monitoramento que a cpu está dando picos de 60%. Procurei e não acha o serviço que estava causando isso. Foi quando desconfiei do snmp. Ao desativar, a cpu cai para 10%. O que pode ser pois não tem anda rodando nele ainda. Só tem uma queue de teste e mesmo assim ainda não está rodando.

show processes cpu sort


PID Runtime(ms) Invoked uSecs 1Sec Process
----- ----------- -------- ----- ------ -----------
23297 1167604 1515169 770 8.00% t2usd
27 4616312 22508664 205 5.00% ksmd
22739 94 47 2003 4.00% ecp
21411 850564 427357 1990 2.00% pfmclnt
21396 5065 86038 58 1.00% syslogd
21637 94 60 1579 1.00% u6rib
1 3404 12881 264 0.00% init
2 6 294 21 0.00% kthreadd
3 25831 313333 82 0.00% ksoftirqd/0
5 22 233 96 0.00% kworker/u:0
6 1598 141109 11 0.00% migration/0
7 1450 13154 110 0.00% watchdog/0

.....

e finaliza assim:

CPU util  :   51.79% user,   16.41% kernel,   31.79% idle

O que posso fazer para resolver?

3 RESPOSTAS

Olá Fernando, 

Olá Fernando, 

Você tem snmp ativo ainda? Não consigo ver o processo em "show processes cpu sort"

Você pode anexar um arquivo com "show ver, sh proc cpu sort | ex 0.0, sh proc cpu hist, show run | in snmp-server" ? ou showtech melhor, eu preciso checar algumas coisas. 

Saudações,

Claudio G

New Member

Tenho sim!!!

Tenho sim!!!

Eu fiz o seguinte, zerei o switch e fui ativando cada função pouco a pouco e esperando um tempo para monitorar.

Ativei o snmp, ficou sem problemas.

Ativei e configurei o ospf v2, ficou sem problemas.

Ativei e configurei o ospfv3 e aí que descobri o problemas. Após alguns minutos a cpu tem picos de 74%.

Sabe o que pode ser? 

Segue minha conf do ospf v3:

feature ospf
feature ospfv3
feature interface-vlan
feature lldp

interface Vlan1100
description UPSTREAM-OSPF-BORDA
no shutdown
ip address x.x.x.x/30
ipv6 address xxxx:xxxx:x:x::2/64
ip router ospf 1 area 0.0.0.0
no ospfv3 passive-interface
ipv6 router ospfv3 1 area 0.0.0.0

interface Ethernet1/49
description PE0-CISCOxCORE-CISCO
switchport
switchport access vlan 1100

interface loopback0
ip address 10.99.99.0/32
ip ospf network point-to-point
ipv6 router ospfv3 1 area 0.0.0.0
ip route 0.0.0.0/0 168.205.37.253
ipv6 route 0::/0 xxxx:xxxx:1:1::1
router ospf 1
router-id 10.99.99.0
network x.x.x.x/30 area 0.0.0.0
redistribute direct route-map RM-OSPF-IPv4-OUT
redistribute static route-map RM-OSPF-IPv4-OUT
area 0.0.0.0 default-cost 10
router ospfv3 1
router-id 10.99.99.0
address-family ipv6 unicast

Processamento após a sessão ospf ipv6 subir:

PE0-CISCO(config-if)# show system resources
Load average: 1 minute: 0.86 5 minutes: 0.31 15 minutes: 0.23
Processes : 474 total, 3 running
CPU states : 48.48% user, 8.58% kernel, 42.92% idle
CPU0 states : 12.37% user, 6.18% kernel, 81.44% idle
CPU1 states : 84.00% user, 10.00% kernel, 6.00% idle
Memory usage: 3903308K total, 2523576K used, 1379732K free

PE0-CISCO(config-if)# show processes cpu sort


PID Runtime(ms) Invoked uSecs 1Sec Process
----- ----------- -------- ----- ------ -----------
27 1676386 1309951 1279 4.00% ksmd
12609 247955 521669 475 4.00% t2usd
7744 844 738 1144 1.00% vsh
11308 95 71 1347 1.00% u6rib
1 2840 4762 596 0.00% init
2 2 170 15 0.00% kthreadd
3 1347 36287 37 0.00% ksoftirqd/0
5 33 219 153 0.00% kworker/u:0

o restante é 0%.  Como pode ver, não aparece esse consumo de processamento os processos. Quando derrubo a sessão ospv3 o processamento cai para 7 com picos de 11%.

Segue retorno dos comandos solicitados:

oftware
BIOS: version 4.0.0
NXOS: version 7.0(3)I4(5)
BIOS compile time: 12/06/2016
NXOS image file is: bootflash:///nxos.7.0.3.I4.5.bin
NXOS compile time: 12/23/2016 16:00:00 [12/24/2016 00:37:34]


Hardware
cisco Nexus3064 Chassis
Intel(R) Celeron(R) CPU P4505 @ 1.87GHz with 3903308 kB of memory.
Processor Board ID FOC16256KTT

Device name: PE0-CISCO
bootflash: 1635720 kB
usb1: 0 kB (expansion flash)

Kernel uptime is 0 day(s), 7 hour(s), 1 minute(s), 32 second(s)

Last reset at 344661 usecs after Thu May 4 11:19:58 2017

Reason: Reset Requested by CLI command reload
System version: 7.0(3)I4(5)
Service:

plugin
Core Plugin, Ethernet Plugin

I

PE0-CISCO(config-router)# sh proc cpu sort | ex 0.0


PID Runtime(ms) Invoked uSecs 1Sec Process
----- ----------- -------- ----- ------ -----------
27 2068511 1624813 1273 5.00% ksmd
11368 253 140 1807 1.00% netstack
11409 82356 339167 242 1.00% snmpd
12218 123 55 2242 1.00% rpm
12224 94 57 1657 1.00% m6rib
12290 34446 160734 214 1.00% ethpm
CPU util : 63.26% user, 14.79% kernel, 21.93% idle

PE0-CISCO(config)# show run | in snmp-server
snmp-server user admin network-admin auth md5 0x8ca84df48eec81e2a82201117dce56c3 priv 0x8ca84df48eec81e2a82201117dce56c3 localizedkey
snmp-server community public group network-operator

Fernando, 

Fernando, 

Eu gostaria ajudar, mas eu sei snmp. 


Eu recomendo que você abra um caso TAC e Alguém irá verificar o problema.

Claudio 

19
Apresentações
0
Kudo
3
Respostas