cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
New Member

Cisco 1841 - Liberar acesso a host da rede privada.

Pessoal,

Estou precisando de uma ajuda com a configuração de um roteador Cisco 1841 conectado a uma DSL da GVT (IP) Fixo.

A configuração das interfaces está assim...

FastEthernet0/0 (Conecta-se com o modem da GVT)
FastEthernet0/1 (Conecta-se com o Switch da rede 10.10.10.0)
Dialer1 (Disca PPPOE, faz a autenticação na GVT e recebe o IP fixo 201.XX.XXX.XXX)

Da rede interna eu consigo acesso à Internet, todavia, não consigo acessar o meu servidor web (10.10.10.5) ligado à rede 10.10.10.0, vindo da Internet.

Já tentei várias configurações de ACLs, mas nenhuma me permitiu acessar o servidor de fora da rede privada. Quando tento conectar recebo a mensagem de que a conexão foi recusada. Abaixo segue a configuração que estou usando.

Building configuration...
Current configuration : 5026 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HomeNet
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.20
!
ip dhcp pool LAN_address_range
  network 10.10.10.0 255.255.255.0
  dns-server 200.175.5.139 200.175.89.139 8.8.8.8 8.8.4.4
  default-router 10.10.10.1
  lease 7
!
ip dhcp pool static-pool
  import all
  origin file flash://staticmap
  default-router 10.10.10.1
!
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
username cisco privilege 15 secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXX.
archive
log config
 hidekeys
!
!
interface FastEthernet0/0
description ADSL WAN Connection
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 10
no cdp enable
!
interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
interface Dialer1
ip address negotiated
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1440
no ip mroute-cache
dialer pool 10
no cdp enable
ppp authentication pap callin
ppp pap sent-username XXXXXXXXX@turbonetpro password 0 XXXXX
ppp ipcp route default
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 10 interface Dialer1 overload
ip nat inside source static tcp 10.10.10.5 8010 interface FastEthernet0/0 8010
!
access-list 10 permit 10.10.10.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 101 permit tcp any host 201.XX.XXX.XXX eq www
no cdp run
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end


É minha primeira tentativa de configurar um Cisco e estou apanhando bastante. Agradeço se alguém puder me ajudar.

Marcio

Marcas (2)
1 SOLUÇÃO ACEITE

Soluções aceites

Olá Marcio,tenta mudar esta

Olá Marcio,

tenta mudar esta linha: ip nat inside source static tcp 10.10.10.5 8010 interface FastEthernet0/0 8010

por: ip nat inside source static tcp 10.10.10.5 8010 interface dialer1 8010

E não apliquei a acl 101, pois você está usando a porta 8010 no NAT e a porta 80 na ACL.

 

3 RESPOSTAS

Olá Marcio,tenta mudar esta

Olá Marcio,

tenta mudar esta linha: ip nat inside source static tcp 10.10.10.5 8010 interface FastEthernet0/0 8010

por: ip nat inside source static tcp 10.10.10.5 8010 interface dialer1 8010

E não apliquei a acl 101, pois você está usando a porta 8010 no NAT e a porta 80 na ACL.

 

New Member

Olá André,Assim funcionou

Olá André,

Assim funcionou somente para acesso a partir de uma máquina conectada via Internet. Os hosts da rede interna 10.10.10.0 não conseguem acesso ao servidor na porta 8010 por meio do domain name, conforme abaixo:

A partir de um host da rede interna, exemplo 10.10.10.99:

Se digito no browser http://10.10.10.5:8010 eu consigo acessar a página web normalmente.

Se digito no browser http://www.domain.com.br:8010 eu recebo uma mensagem dizendo "O servidor recusou a conexão"

A partir de uma máquina conectada na Internet

Se digito no browser http://www.domain.com.br:8010 eu consigo acessar a página web normalmente.

Como faço para permitir acesso para os hosts da rede interna usando o nome do dominio? No momento os demais sites da Internet podem ser acessados normalmente (cnn.com, google.com, etc).

Grato,

Marcio

 

Marcio, acredito que isso

Marcio, acredito que isso seja configuração do servidor web, mas ai já não conheço o suficiente para ajudar.

626
Apresentações
0
Kudo
3
Respostas