cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
New Member

Inter-vlan routing problem?

I have catalyst 2960 cisco switch having 8 vlans each one with ip helper address and and assign one port to the vlans, all vlans are then assigned to a trunk port the trunk port is connected to Cisco 3800 series router.  Cisco Router 3800 series Router have 2 interface one with the public IP and one with the private ip connected to to 2960 switch trunk port (NAT overload is enabled) now I want to configure inter vlan routing, I have created dhcp pool for every vlan in the router, I created gi0/1.2 sub interface on the router and enable encapsulation dot1q 2 for vlan 2 now computers on vlan to can recive ip from the dhcp pool and can ping public and private ip but cannot ping beyond public ip due to intervlan routing please help me the router configurations are as follow.

Current configuration : 1548 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

dot11 syslog

ip source-route

ip cef

!

!

!

--More--

ip dhcp pool noc

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 4.2.2.2

!

ip dhcp pool vlan2

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 4.2.2.2

!

!

ip name-server 4.2.2.2

ip name-server 66.0.28.45

multilink bundle-name authenticated

!

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface GigabitEthernet0/0

ip address 182.50.190.140 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1.2

encapsulation dot1Q 2

ip address 192.168.2.1 255.255.255.0

!

router rip

version 2

network 182.50.0.0

network 192.168.0.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 182.50.190.254

!

no ip http server

no ip http secure-server

!

ip nat inside source list 100 interface GigabitEthernet0/0 overload

ip nat inside source list 101 interface GigabitEthernet0/0 overload

!

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

access-list 101 permit ip 192.168.2.0 0.0.0.255 any

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

2 RESPOSTAS

Inter-vlan routing problem?

Hi Sayed

Your Router need know which is the" Inside" interface to NAT/PAT.

Try the follows:

interface GigabitEthernet0/1.2

ip nat inside

I hope this help ...

Cheers Bruno Rangel Please remember to rate helpful responses using the stars bellow and identify helpful or correct answers .

Inter-vlan routing problem?

Hi Sayed how are you? I hope fine!

Did you solved your issue?

Please remember to rate helpful responses and identify the correct answers.

Cheers Bruno Rangel Please remember to rate helpful responses using the stars bellow and identify helpful or correct answers .
574
Apresentações
0
Kudo
2
Respostas