cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
New Member

LACP com acesso CDN Netflix

Amigos,

Sou ISP e hoje meu desenho de rede está assim:

(LINK OPERADORA 1, LINK OPERADORA 2, PTT)=>BORDA mikrotik CR1072 com BGP v44/v6=>CDNS GOOGLE, NETFLIX, LAN E ETC....depois desse um LACP para o segundo roteador OSPF ccr1072 aonde estão ligados meus servidores PPPOes, DNS, ERP, cluster com rede em anel.

Como vai ficar:

(LINK OPERADORA 1, LINK OPERADORA 2, PTT)=> SWITCH CISCO NEXUS CORE BORDA=>BORDA CISCO Asr 9001 com BGP v44/v6=>CDNS GOOGLE, NETFLIX, LAN E ETC....depois desse um LACP para o segundo roteador OSPF ccr1072 aonde estão ligados meus servidores PPPOes, DNS, ERP, cluster com rede em anel.

O switch cisco Core da borda está dividido em dois.

Da porta 1 a 32 vlan 5(Rede lan aonde vão ficar os CDNs, Lan que desce para o OSPF ccr1072 com LACP e LAN com LACP da borda ASR9001) e o restante na vlan 6(Rede aonde entram os links das operadoras + LACP Wan Asr9001).

Até aí está tudo ok como mostro nas conf abaixo. O problema é que os CDNS não tem Vlan e o google e Netflix não colocam e preciso ter Vlan para separar os tráfego para não entrar tudo via LACP vlan 5 da LAN que vai para borda Asr9001.

Como faço para ter uma segunda vlan(até já configurei mas claro que não chega na borda porque o netflix não tem essa vlan) para o Netflix e google chegarem até a borda?

Segue conf do switch:

CISCO-CORE# show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Eth1/1, Eth1/2, Eth1/49/1
Eth1/49/2, Eth1/49/3, Eth1/49/4
Eth1/50/1, Eth1/50/2, Eth1/50/3
Eth1/50/4, Eth1/51/1, Eth1/51/2
Eth1/51/3, Eth1/51/4, Eth1/52/1
Eth1/52/2, Eth1/52/3, Eth1/52/4
5 LAN-CDN active Po1, Po2, Eth1/3, Eth1/4
Eth1/5, Eth1/6, Eth1/9, Eth1/11
Eth1/12, Eth1/13, Eth1/14
Eth1/15, Eth1/16, Eth1/17
Eth1/18, Eth1/19, Eth1/20
Eth1/21, Eth1/22, Eth1/23
Eth1/24, Eth1/25, Eth1/26
Eth1/27, Eth1/28, Eth1/29
Eth1/30, Eth1/31, Eth1/32
6 BORDA active Eth1/33, Eth1/34, Eth1/35
Eth1/36, Eth1/37, Eth1/38
Eth1/39, Eth1/40, Eth1/41
Eth1/42, Eth1/43, Eth1/44
Eth1/45, Eth1/46, Eth1/47
Eth1/48
1101 netflix active Po2, Po3, Eth1/5, Eth1/6
Eth1/7, Eth1/8
1102 VLAN1102 active Po2, Eth1/5, Eth1/6
1111 PE0 active Po1, Po2, Eth1/3, Eth1/4
Eth1/5, Eth1/6

VLAN Type Vlan-mode
---- ----- ----------
1 enet CE
5 enet CE
6 enet CE
1101 enet CE
1102 enet CE
1111 enet CE

 

12 RESPOSTAS

Boa tarde, pelo contexto que

Boa tarde, pelo contexto que entendi você precisar deixar as CDN's em uma VLAN, porem elas elas estão trabalhando em untagged.

Bem o que você vai fazer é deixar a portas onde estão as CDN's em access em alguma vlan, por exemplo vlan 10, ai você vai passar essa vlan na porta trunk que vai para seu roteador core e criar essa vlan no roteador core.

Quando os frames no sentido ingress das CDN's entrar no Nexus vai ser tagueado na vlan 10, e quando os frames no sentido egress sair para as CDN's sair vai ser removido essa tag nessa caso tag 10 e com isso vai chegar nas CDN's como um frame untagged.

Espero ter ajudado.

Abraços

New Member

Boa tarde,

Boa tarde,

Tentei fazer como falou mas encontrei dois problemas:

1)Quando vou finalizar a configuração do LACP em access colocando somente uma vlan aparece o erro:

CISCO-CORE(config-if-range)# channel-group 3 mode active
command failed: port not compatible [port allowed VLAN list]

2)

Pensei em fazer dessa forma que você passou mas o problema é que no roteador de borda que vai receber essa ele vai receber outras na mesma porta então, ele está com a vlans 5,1111,1102 logo essas portas estão como trunk.

Como outra opção pensei em deixar as portas 7 e somente com a Vlan 5 pois é a vlan que separa o switch para receber os equipamentos da LAN. Será que funciona?

Boa tarde.

Boa tarde.

Você precisa deixar o port-channel em modo trunk em passar as vlan's nele, exemplo:

interface Ethernet0/23
switchport trunk allowed vlan 22
switchport mode trunk
channel-group 3 mode active
!
interface Ethernet0/24
switchport trunk allowed vlan 22
switchport mode trunk
channel-group 3 mode active
!
interface Port-channel3
switchport trunk allowed vlan 22
switchport mode trunk

Não entendi o questionamento 2, se a porta já esta em trunk está de forma correta.

Se tiver mais dúvidas faz um desenho da topologia e o que necessita fazer para avaliarmos.

Abraço

New Member

Amanhã irei tentar e lhe

Amanhã irei tentar e lhe retorno. Faço também meu desenho de rede para entender melhor mas, para adiantar, 

Uma Vlan 10  de um switch nexus em um port channel LACP access pode falar com uma Vlan 10 borda ASR9001 em uma port channel LACP em trunk?

Resumindo, access vlan 10 fala com trunk vlan 10?

Pelo o que entendi, tanto o switch quanto a borda tem que estar em trunk.

abs

Correto em trunk entre o

Correto em trunk entre o ASR9K e o Nexus , access nas portas dos servidores CDN.

Abraço

New Member

Então, O netflix vai entrar

Então, O netflix vai entrar no lacp das portas 7 e 8 do nexus, o nexus irá falar com o asr9001 por lacp nas portas 3 e 4 do nexus. Entendeu?

New Member

COnsegui colocar para rodar.

COnsegui colocar para rodar. LACP netflix em access vlan e LACP borda trunk com vlans 5, 10,1111

Só estou com uma dúvida para saber se realmente o LACP está reconhecendo 20GB:

Po1 BORDA-LAN connected trunk full a-10G --
Po4 LACP-NETFLIX-ACCES connected 10 full 10G --

Está assim no status

e assim no resumo dos LACPs:

CISCO-CORE(config-if)# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
1 Po1(SU) Eth LACP Eth1/3(P) Eth1/4(P)
2 Po2(SD) Eth LACP Eth1/5(D) Eth1/6(D)
4 Po4(SU) Eth LACP Eth1/7(P) Eth1/8(P)

port-channel1 is up
Hardware: Port-Channel, address: 547f.ee3c.efcb (bia 547f.ee3c.efcb)
Description: BORDA-LAN
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/3, Eth1/4
Last clearing of "show interface" counters never
1 interface resets
30 seconds input rate 40379184 bits/sec, 19641 packets/sec
30 seconds output rate 458142376 bits/sec, 39837 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 38.40 Mbps, 17.43 Kpps; output rate 405.66 Mbps, 35.22 Kpps
RX
17164142 unicast packets 10616 multicast packets 3328 broadcast packets
17178086 input packets 6579279781 bytes
3627293 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 9073 input discard
0 Rx pause
TX
31266613 unicast packets 17079 multicast packets 1543 broadcast packets
31285235 output packets 44395633705 bytes
1056232 jumbo packets
0 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

port-channel4 is up
Hardware: Port-Channel, address: 547f.ee3c.efcf (bia 547f.ee3c.efcf)
Description: LACP-NETFLIX-ACCESS
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
full-duplex, 10 Gb/s
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/7, Eth1/8
Last clearing of "show interface" counters never
2 interface resets
30 seconds input rate 462740144 bits/sec, 40363 packets/sec
30 seconds output rate 39342584 bits/sec, 19703 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 407.96 Mbps, 35.51 Kpps; output rate 37.92 Mbps, 17.50 Kpps
RX
32286664 unicast packets 8479 multicast packets 2483 broadcast packets
32297626 input packets 45695330688 bytes
0 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 31557 input discard
0 Rx pause
TX
17648895 unicast packets 10117 multicast packets 647 broadcast packets
17659659 output packets 6632857439 bytes
0 jumbo packets
0 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

Boa tarde.

Boa tarde.

Pela saída do comando está tudo ok:

1 Po1(SU) Eth LACP Eth1/3(P) Eth1/4(P)
4 Po4(SU) Eth LACP Eth1/7(P) Eth1/8(P)

Pela saída do comando as portas estão dentro do bundle.

Pode verificar assim os frames por porta:

show interfaces port-channel 1 counters etherchannel

Pode colocar o commando  history BPS all dentro nas interfaces e no port-channel para monitorar estatistas.

Abraço

New Member

Tem algum comando que eu

Tem algum comando que eu possa monitrar o tráfego em tempo real?

Pergunto porque o show interface ele mostra o rate mas tenho que ficar repetindo o comando para analisar a mudança do tráfego. Como faço para monitorar em tempo real?

Boa tarde.

Boa tarde.

Para monitorar em real-time precisa de uma servidor SNMP ou netflow para fazer a coleta e gerar os gráficos.

O que pode ser feito é configurar o load-interval nas interfaces com o menor valor possível (Depende da plataforma os valores).

Abraços!

Bom dia.

Bom dia.

Deu certo?

Se precisar de mais alguma ajuda pode fazer sua solicitação.

Se fui útil por favor marque a pergunta como respondida e qualifique =)

Abraços!

New Member

Obrigado pela ajuda. Estou

Obrigado pela ajuda. Estou usando o zabbix para monitorar. Achei que tinha algum comando que mostrasse em tempo real. Irei monitorar pelo zabbix.

mais uma vez obrigado

132
Apresentações
29
Útil
12
Respostas
CriarFaça o para criar o conteúdo