cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
Cisco Employee

Protocolo de roteamento Border Gateway Protocol (BGP) - Pergunte ao Especialista

O BGP, que o RFC 1771 define, permite que você crie roteamentos de interdomínio sem loops entre sistemas autônomos . Um sistema autonomo é um conjunto de roteadores em uma única administração técnica. Roteadores em um sistema autonomo podem usar vários Gateway Protocols interiores (IGPs) para trocar informações de roteamento dentro do sistema autonomo. Os roteadores podem usar um protocolo de gateway exterior para rotear pacotes fora do sistema autonomo.

Faça suas perguntas de quarta-feira, 24 de Setembro a sexta-feira 2 de Setembro de 2016

Especialista em Destaque



Juan Carlos Rangel é formado em Engenharia de Sistemas de Computador pela Universidade das Americas em Cidade do Mexico (UDLA) e trabalha na Cisco como Engenheiro TAC na area dos protocolos de roteamento. Tem bom conhecimento da rede America Movil Internacional por ter trabalhado no centro de atendimento ao cliente da Telmex. Também trabalhou em empresas como HUAWEI, CITI e atualmente CISCO. Possui as seguintes certificações: CCNP R&S, CCNP Security, CCNP Service Provider,Huawei HCDA e ITIL v3 Foundation.

Juan Carlos pode não ser capaz de responder a cada pergunta, devido ao volume esperado durante este evento. Lembre-se que você pode esclarecer suas dúvidas também em nossa sub-comunidade de Routing & Switching.

 

** Classificações incentivam a participação! **
Por favor assegurar-se de classificar as respostas as perguntas!

  

  • Routing & Switching
2 SOLUÇÕES ACEITES

Soluções aceites
Cisco Employee

allowas-in.png

Obrigado pela pergunta

Vou mostrar um exemplo do BGP Allowas-in

Na topologia temos os seguientes roteadores

Router_A , R1 e R2

Configuração do Roteador_A

---------------------------------------------------------------

Router_A#

interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
no switchport
ip address 192.1.12.2 255.255.255.0
!
router eigrp 100
network 1.1.1.1 0.0.0.0
network 2.2.2.2 0.0.0.0
network 3.3.3.3 0.0.0.0
network 192.1.12.0
auto-summary
!

-------------------------------------------------------------------------------------

Configuração do roteador R1

R1#interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 192.1.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
network 192.1.12.0
no auto-summary
!
router bgp 121
no synchronization
bgp router-id 22.22.22.22
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255 

! Este é o endereço Lo22 para anunciar no BGP
 redistribute eigrp 100 

! Redistribuição das rotas EIGRP no eBGP
neighbor 172.16.12.2 remote-as 500

! Conexão eBGP com a operadora 
neighbor 172.16.12.2 ebgp-multihop 5
no auto-summary
!

Este exemplo mostra que o EIGRP corre entre Router_A e R1:

r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.1.12.2              Fa0/0             14 01:17:12  828  4968  0  7

Este exemplo mostra como Router R1 aprende rotas de Router _A através do protocolo EIGRP:

r1#show ip route eigrp 100
D    1.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    2.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0

Este exemplo mostra como Router R1 estabelece uma conexão eBGP com a operadora no AS500

r1#show ip bgp summary
BGP router identifier 22.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.12.2     4        500      86      76       19    0    0 00:25:13        2

Este exemplo mostra como R1 anuncia rotas aprendidas do BGP


r1#show ip bgp
BGP table version is 19, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          192.1.12.2          156160         32768 ?
*> 2.0.0.0          192.1.12.2          156160         32768 ?
*> 3.0.0.0          192.1.12.2          156160         32768 ?
*> 10.10.12.0/24    172.16.12.2              0             0 500 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
r> 172.16.12.0/24   172.16.12.2              0             0 500 i
*> 192.1.12.0       0.0.0.0                  0         32768 ?

Esta é a conectividade com o Router 2 através da nuvem da Internet.

r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!! 

Configuração do roteador R2

------------------------------------------------------

R2#

interface Loopback33
ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
ip address 10.10.12.1 255.255.255.0

router bgp 121
no synchronization
bgp router-id 33.33.33.33
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255

! Este é o endereço Lo33 para anunciar

neighbor 10.10.12.2 remote-as 500

! Esta é a conexão eBGP  com a operadora

neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary

---------------------------------------------------

Roteador R2 não aprende rotas do roteador R1

Esse é um comportamento natural, porque o BGP tenta evitar loops de roteamento. Por exemplo, a publicidade de todos os prefixos que contêm numerous duplicados do Sistema Autônomo (ASN) é desativado por padrão. Rotas redistribuídas EIGRP (1.0.0.0, 2.0.0.0, 3.0.0.0) e a rota interna BGP 22.22.22.22 a partir de R1 não são recebidos por R2 como eles são originários do mesmo ASN através da Internet. R2 ve seu próprio AS (121) na AS-PATH, então R2 não toma essas rotas.

r2#show ip bgp
BGP table version is 20, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 I

A fim de permitir a publicidade de todos os prefixos que contêm ASN duplicados, tem que utilizer o commando neighbor allowas-in no modo de configuração no roteador R2.

r2(config-router)#neighbor 10.10.12.2 allowas-in

Depois tem que reiniciar a sessão BGP

r2#clear ip bgp*

Aagora ja temos na tabela de BGP as rotas do Roteador R1

r2#show ip bgp
BGP table version is 10, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          10.10.12.2                             0 500 121 ?
*> 2.0.0.0          10.10.12.2                             0 500 121 ?
*> 3.0.0.0          10.10.12.2                             0 500 121 ?
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 22.22.22.22/32   10.10.12.2                             0 500 121 i
*  33.33.33.33/32   10.10.12.2                             0 500 121 i
*>                  0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i
*> 192.1.12.0       10.10.12.2                             0 500 121 ?

Agora temos alcançabilidade para endereço Lo22 do R1

r2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

Cisco Employee

Obrigado pela pergunta

Obrigado pela pergunta

Na seguiente topologia temos um exemplo do BGP Multihop

Em alguns casos, um roteador Cisco pode executar eBGP com um roteador de terceiros que não permite a conexão direta. Para conseguir a conexão, você pode usar eBGP multihop. O multihop eBGP permite uma conexão vizinha entre dois pares externos que não têm conexão direta. O multihop é apenas para eBGP e não para iBGP.

Configuração

RTA#
router bgp 100
neighbor 180.225.11.1 remote-as 300
neighbor 180.225.11.1 ebgp-multihop
RTB#
router bgp 300
neighbor 129.213.1.2 remote-as 100

RTA indica um vizinho externo que não tem conexão direta. RTA precisa indicar o uso do comando neighbor ebgp-multihop. Por outro lado, o RTB indica um vizinho que tem ligação directa, que é 129.213.1.2. Por causa desta conexão direta, RTB não precisa do comando vizinho ebgp-multihop. Você também deve configurar uma IGP ou roteamento estático para permitir que os vizinhos sem conexão para alcançar o outro.

Se quer utilizar os atributos do BGP, são no seguiente ordem

Weight

Local preference

AS-PATH length

Origin

MED

Se tem alguma outra duvida, sinta-se a vontade de me perguntar

Saudações

5 RESPOSTAS

Boa tarde Juan.

Boa tarde Juan.

Segue abaixo uma pergunta feita durante o webcast.

Trabalho na NET(Claro S.A), temos 16 datacenters que recebem full routing IPv6 da EBT, portanto para permitir a troca de prefixos entre as operações NET utilizamos o atributo allowas-in. Por favor, poderiam citar exemplos de cenários onde está configuração e o atributo allowas-in é necessario e os riscos de desativar o mecanismo de prevenção de loop?

Atenciosamente.

Equipe CSC Português

Cisco Employee

allowas-in.png

Obrigado pela pergunta

Vou mostrar um exemplo do BGP Allowas-in

Na topologia temos os seguientes roteadores

Router_A , R1 e R2

Configuração do Roteador_A

---------------------------------------------------------------

Router_A#

interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
no switchport
ip address 192.1.12.2 255.255.255.0
!
router eigrp 100
network 1.1.1.1 0.0.0.0
network 2.2.2.2 0.0.0.0
network 3.3.3.3 0.0.0.0
network 192.1.12.0
auto-summary
!

-------------------------------------------------------------------------------------

Configuração do roteador R1

R1#interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 192.1.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
network 192.1.12.0
no auto-summary
!
router bgp 121
no synchronization
bgp router-id 22.22.22.22
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255 

! Este é o endereço Lo22 para anunciar no BGP
 redistribute eigrp 100 

! Redistribuição das rotas EIGRP no eBGP
neighbor 172.16.12.2 remote-as 500

! Conexão eBGP com a operadora 
neighbor 172.16.12.2 ebgp-multihop 5
no auto-summary
!

Este exemplo mostra que o EIGRP corre entre Router_A e R1:

r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.1.12.2              Fa0/0             14 01:17:12  828  4968  0  7

Este exemplo mostra como Router R1 aprende rotas de Router _A através do protocolo EIGRP:

r1#show ip route eigrp 100
D    1.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    2.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0

Este exemplo mostra como Router R1 estabelece uma conexão eBGP com a operadora no AS500

r1#show ip bgp summary
BGP router identifier 22.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.12.2     4        500      86      76       19    0    0 00:25:13        2

Este exemplo mostra como R1 anuncia rotas aprendidas do BGP


r1#show ip bgp
BGP table version is 19, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          192.1.12.2          156160         32768 ?
*> 2.0.0.0          192.1.12.2          156160         32768 ?
*> 3.0.0.0          192.1.12.2          156160         32768 ?
*> 10.10.12.0/24    172.16.12.2              0             0 500 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
r> 172.16.12.0/24   172.16.12.2              0             0 500 i
*> 192.1.12.0       0.0.0.0                  0         32768 ?

Esta é a conectividade com o Router 2 através da nuvem da Internet.

r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!! 

Configuração do roteador R2

------------------------------------------------------

R2#

interface Loopback33
ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
ip address 10.10.12.1 255.255.255.0

router bgp 121
no synchronization
bgp router-id 33.33.33.33
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255

! Este é o endereço Lo33 para anunciar

neighbor 10.10.12.2 remote-as 500

! Esta é a conexão eBGP  com a operadora

neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary

---------------------------------------------------

Roteador R2 não aprende rotas do roteador R1

Esse é um comportamento natural, porque o BGP tenta evitar loops de roteamento. Por exemplo, a publicidade de todos os prefixos que contêm numerous duplicados do Sistema Autônomo (ASN) é desativado por padrão. Rotas redistribuídas EIGRP (1.0.0.0, 2.0.0.0, 3.0.0.0) e a rota interna BGP 22.22.22.22 a partir de R1 não são recebidos por R2 como eles são originários do mesmo ASN através da Internet. R2 ve seu próprio AS (121) na AS-PATH, então R2 não toma essas rotas.

r2#show ip bgp
BGP table version is 20, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 I

A fim de permitir a publicidade de todos os prefixos que contêm ASN duplicados, tem que utilizer o commando neighbor allowas-in no modo de configuração no roteador R2.

r2(config-router)#neighbor 10.10.12.2 allowas-in

Depois tem que reiniciar a sessão BGP

r2#clear ip bgp*

Aagora ja temos na tabela de BGP as rotas do Roteador R1

r2#show ip bgp
BGP table version is 10, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          10.10.12.2                             0 500 121 ?
*> 2.0.0.0          10.10.12.2                             0 500 121 ?
*> 3.0.0.0          10.10.12.2                             0 500 121 ?
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 22.22.22.22/32   10.10.12.2                             0 500 121 i
*  33.33.33.33/32   10.10.12.2                             0 500 121 i
*>                  0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i
*> 192.1.12.0       10.10.12.2                             0 500 121 ?

Agora temos alcançabilidade para endereço Lo22 do R1

r2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

Boa tarde Juan.

Boa tarde Juan.

Você poderia nos esclarecer como seta as prioridades no multihop?

Obrigado.

Equipe CSC Português

Cisco Employee

Obrigado pela pergunta

Obrigado pela pergunta

Na seguiente topologia temos um exemplo do BGP Multihop

Em alguns casos, um roteador Cisco pode executar eBGP com um roteador de terceiros que não permite a conexão direta. Para conseguir a conexão, você pode usar eBGP multihop. O multihop eBGP permite uma conexão vizinha entre dois pares externos que não têm conexão direta. O multihop é apenas para eBGP e não para iBGP.

Configuração

RTA#
router bgp 100
neighbor 180.225.11.1 remote-as 300
neighbor 180.225.11.1 ebgp-multihop
RTB#
router bgp 300
neighbor 129.213.1.2 remote-as 100

RTA indica um vizinho externo que não tem conexão direta. RTA precisa indicar o uso do comando neighbor ebgp-multihop. Por outro lado, o RTB indica um vizinho que tem ligação directa, que é 129.213.1.2. Por causa desta conexão direta, RTB não precisa do comando vizinho ebgp-multihop. Você também deve configurar uma IGP ou roteamento estático para permitir que os vizinhos sem conexão para alcançar o outro.

Se quer utilizar os atributos do BGP, são no seguiente ordem

Weight

Local preference

AS-PATH length

Origin

MED

Se tem alguma outra duvida, sinta-se a vontade de me perguntar

Saudações

Hola Juan

Hola Juan

Disculpa en la presentación en el tema de Dual-homed puedes compartir a mayor detalle la configuración del otro PE que seria Telmex. Así mismo la configuración del  prefix-list ANTI-LOOP.

Otra consulta para el funcionamiento del community se debe colocar el comando send-community en ambos equipos CE y PE.

Me puedes explicar como funciona el route-map dualhome en el PE de UNINET, este permite prefijos que contengan 8151:285 pero no importa que en la comunidad se esté enviando 8151:285 28513:285 28513:1281.

Desde el CE porque se le envía la comunidad 8151:285 28513:285 28513:1281  y donde se está utilizando la 28513:1281.

Saludos

Wilson Veliz

207
Apresentações
15
Kudo
5
Respostas
Não foi possível apresentar este widget.