Cómo convertir un Router en Múltiples Routers (VRF Lite)

Buenas,

El día de hoy vamos a hablar de VRF-Lite; la capacidad que nos provee un router para dividir a este router y su tabla de enrutamiento en múltiples; de ahí su nombre VRF (Virtual Routing and Forwarding).

Podemos pensar, OK convertir un router en múltiples routers.. Pero... Que ventajas me puede traer esto?

Un ejemplo podría ser en el caso de un proveedor de servicios (ISP) con múltiples clientes.

Creen ustedes que los diferentes clientes deben de ser accesados por los otros clientes, deben ellos de compartir el medio?

Por supuesto que no y VRF Lite nos permitiría esto ya que cada VRF tendrá su propia tabla de enrutamiento y los clientes en diferentes VRF's no podrán accesar otros clientes en diferentes VRFs.

Vamos a ver si nos quedo claro,

Hora de realizar un Laboratorio

VRF

En este escenario básicamente dividimos la interface fastethernet 1/0 en múltiples sub-interfaces y asignamos cada sub-interface a un VRF específico (Interface fastethernet 1/0.10 en VPN_10 y fastethernet1/0.20 en VPN_20).

Vamos a ver la configuración para explicar paso a paso el propósito de cada comando:

hostname R1
!
ip vrf VPN_10
rd 10:10
!
ip vrf VPN_20
rd 20:20
!
interface FastEthernet1/0.10
encapsulation dot1Q 10
ip vrf forwarding VPN_10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/0.20
encapsulation dot1Q 20
ip vrf forwarding VPN_20
ip address 192.168.20.1 255.255.255.0
!

Empezaremos con la creación del VRF:

ip vrf VPN_10 : Estamos creando una tabla de enrutamiento virtual en este router denominada VPN_10

rd 10:10 : Estamos creando un identificador para las rutas en un VRF específico; en futuros eventos veremos que yo al utilizar VRF's puedo comunicar dos redes con el mismo direccionamiento IP en diferentes VRFs ya que a cada prefijo de red se le asignara el RD como identificador y por ende será único.

El número puede ser al azar.

Normalmente se utiliza ASN:Número al azar o Dirección_IP:Número al azar.

Interface x/x

ip vrf forwarding VPN_10 : Este comando asocia a la interface a una tabla de enrutamiento específico (Nota: Este comando remueve la configuración de IP previamente configurada en esta interface por ende debes de volver a asignarla).

Vamos a pasar ahora a ver la configuración de Router 3 en este escenario (No se explicara cada uno de los comandos ya que el significado de ellos es el mismo)

hostname R3
!
ip vrf VPN_10
rd 10:10
!
ip vrf VPN_20
rd 20:20
!
interface FastEthernet1/0.10
encapsulation dot1Q 10
ip vrf forwarding VPN_10
ip address 192.168.10.2 255.255.255.0
!
interface FastEthernet1/0.20
encapsulation dot1Q 20
ip vrf forwarding VPN_20
ip address 192.168.20.2 255.255.255.0
!

Configuraremos dos loopbacks en R3 tambíen:

interface Loopback1
ip vrf forwarding VPN_10
ip address 192.168.30.1 255.255.255.0
!
interface Loopback2
ip vrf forwarding VPN_20
ip address 192.168.40.1 255.255.255.0

Ahora verifiquemos  la configuración de VRF en R1

R1#sh ip vrf
Name Default RD Interfaces
VPN_10 10:10 Fa1/0.10
VPN_20 20:20 Fa1/0.20

R1#sh ip vrf interfaces
Interface IP-Address VRF Protocol
Fa1/0.10 192.168.10.1 VPN_10 up
Fa1/0.20 192.168.20.1 VPN_20 up

Perfecto, ahora veamos las tablas de enrutamiento en R1,

Pregunta: Cuantas tablas de enrutamiento con la configuración previa tiene R1?

Tiene 3 : VPN_A , VPN_B y la Global (En la global estan las interfaces que no pertenecen a ningún VRF)

1- La Tabla de Enrutamiento Global

R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

Como podemos observar no tenemos ninguna ruta

2-La Tabla de Enrutamiento de VPN_10

R1#sh ip route vrf VPN_10

Routing Table: VPN_10
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet1/0.10
L 192.168.10.1/32 is directly connected, FastEthernet1/0.10

Podemos observar únicamente la interfaz asignada en R1 a esta tabla de enrutamiento

3-La tabla de enrutamiento de VPN_20

R1#sh ip route vrf VPN_20

Routing Table: VPN_20
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, FastEthernet1/0.20
L 192.168.20.1/32 is directly connected, FastEthernet1/0.20

De igual manera solamente tenemos la interfaz asociada a dicho VRF

Comportamiento de enrutamiento con VRFs

Vamos  a hablar ahora de enrutamiento en un VRF; con el escenario mencionado anteriormente vamos a hacer que los hosts en la interface de R1 en VPN_10 pueda accesar la loopback de R3 en VPN_10.

Simplemente se crea una ruta estática haciendo referencia al VRF_10

ip route vrf VPN_10 192.168.30.0 255.255.255.0 192.168.10.2

Posteriormente pruebo conectividad y veo que todo funciona de la manera correcta

R1#ping vrf VPN_10 192.168.30.1 source fastEthernet 1/0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/79/100 ms

Nota: A la hora de hacer Ping debo incluir que tabla de enrutamiento utilizar para alcanzar cierto destino ya que por defecto utilizara la global

Por último verifiquemos la tabla de enrutamiento de R1 con ese cambio:

R1#sh ip route vrf VPN_10

Routing Table: VPN_10
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet1/0.10
L 192.168.10.1/32 is directly connected, FastEthernet1/0.10
S 192.168.30.0/24 [1/0] via 192.168.10.2

Podemos ver la ruta estática incluida previamente,

Espero y hayan disfrutado leyendo este  tutorial.

Jcarvaja

     http://laguiadelnetworking.com

Historial de versiones
Revisión n.º
1 de 1
Última actualización:
‎09-10-2013 09:18 PM
Actualizado por:
 
Etiquetas (1)
Comentarios
New Member

Muy buen tuto .

 

Consulta las loopback por defecto por que las tiene presentes en la tabla VRF ?