configuracion de IPSLA con IP Dinamica en cisco 891-k9

Este documento tiene como finalidad, ordenar y sintetisar la discusion creada para poder configurar el IPSLA en un router 891.

Discusión

https://supportforums.cisco.com/es/discussion/12107736/configurar-cisco-891-para-balanceo-de-carga

 

Para poder hacerlo vamos a tener que configurar las siguientes herramientas:

 

1) IP SLA

 

2) Object Track

 

3) 2 conexiones de ISP

 

imagen de ipsla

 
  

 

Para poder realizar esa topología, se ingresan los siguientes comandos en el router R1.

 

Ip route 4.2.2.2 255.255.255.255 fa0/0 permanent

ip sla 10

icmp-echo 4.2.2.2 source-interface fa0/0

ip sla schedule 10 life forever start-time now

!

track 10 ip sla 10

track 11 list boolean and

object 10 not

!

interface fa0/0

ip dhcp client route track 10

ip address dhcp

!

interface fa0/1

ip dhcp client route track 11

ip address dhcp

 

Nota: Esta es la configuracion de la lista de acceso "listadeacceso" que se utilizara enseguida.

ip acccess-list extended listadeacceso

permit tcp 192.168.1.0 0.0.0.255 any

permit icmp 192.168.1.0 0.0.0.255 any

petmit udp 192.168.1.0 0.0.0.255 any 

  • ip nat inside source list listadeacceso interface fa0/0 overload interface vlan X

ip nat inside

exit

interface fa0/0

ip nat outside

 

 

Si esta activo el overload, hay que desactivarlo

  • no ip nat inside source list listaacceso interface fa0/0 overload

 

route-map ISP1

match ip address Listadeacceso

match interface fa0/0

exit

route-map ISP2

match ip address Listadeacceso

match interface fa0/1

exit

ip nat inside source route-map ISP1 interface fa0/0 overload

ip nat inside source route-map ISP2 interface Fa0/1 overload

 

Donde Fa0/0 es el que conecta a ISP primario y Fa0/1 conecta al secundario.

Con este modo ya queda configurado el IPSLA con IP pública dinamica.

 

Agradezco a czeledon y a Ricardo Troyo por el apoyo brindado para configurar el router cisco 891. Siempre estuvieron al pendiente de los errores y resultados de cada configuración.

Historial de versiones
Revisión n.º
1 de 1
Última actualización:
‎03-20-2014 12:30 PM
Actualizado por:
 
Etiquetas (1)