Ejemplo de configuración del Router Cisco para el servicio Metro Ethernet de CANTV

Introducción.

La finalidad de este documento es compartir ejemplos de configuración básica del Router Cisco para poder ser utilizado con el servicio de Metro Ethernet de CANTV en Venezuela. Las configuraciones detalladas en este documento pueden aplicarse ademas para conectar el Router Cisco con otros proveedores de Servicio de Internet.

A continuación, la terminología utilizada en este documento.

  • ISP - Nos referimos a CANTV de Venezuela en este documento.
  • LAN - Hace referencia al equipo que se encuentra en la red local del cliente.
  • interface WAN - Este es el puerto en el Router que conecta con el equipo del ISP.
  • interface LAN - Este es el puerto en el Router que conecta con la LAN.
  • IP WAN Router - La dirección IP que debe ser configurada en el Router Cisco en la interface WAN. Por ejemplo: 201.248.xx.49/30
  • IP WAN CANTV - Dirección IP configurada del lado del ISP. Por ejemplo: 201.248.xx.50/30
  • IP LAN POOL - Este es el direccionamiento IP público el cual es otorgado por el ISP. Este es comúnmente un rango de 8 direcciones IP con una mascara de red /29 o 255.255.255.248. Por ejemplo: 200.11.xx.176/29. Este rango utilizado a manera de ejemplo es particionado de la siguiente forma:
    • Dirección del segmento red 200.11.xx.176 (no utilizable)
    • Primera dirección IP asignable a nodos en el segmento de red. 200.11.xx.177
    • Ultima dirección IP asignable a nodos en el segmento de red. 200.11.xx.182
    • Dirección de broadcast del segmento de red 200.11.xx.183 (no utilizable)
  • NAT - Por sus siglas en ingles Network Address Translation, es muy comúnmente configurada en Routers para permitir acceso a Internet a equipos en la LAN configurados con direcciones IPv4 privadas (no ruteables a Internet). El objetivo es realizar una translación de IPv4 privada a alguna de las direcciones IP públicas disponibles de la IP LAN POOL.

 

Configuración Base.

Configurar la interface WAN y ruta a Internet. En este caso específico, el ISP ademas de la dirección IP, asigna una VLAN la cual debe ser configurada propiamente en una sub-interface de la interface WAN.

!
interface GigabitEthernet0/0
 description interface WAN
no shutdown
!
interface GigabitEthernet0/0.xyz <-xyz debe ser reemplazado por el número de la VLAN.
encapsulation dot1q xyz <-xyz debe ser reemplazado por el número de la VLAN.
 ip address x.x.x.x 255.255.255.252  <- Sustituye x.x.x.x por IP WAN Router.
 no shutdown
!

Se debe de configurar una ruta estática en el Router con el fin de enviar el trafico de Internet hacia el equipo del ISP.

ip route 0.0.0.0 0.0.0.0 y.y.y.y     <- Sustituye y.y.y.y por IP WAN CANTV.

Comprobación. El Router debe de ser ahora capaz de comunicarse con el ISP, la forma de comprobarlo es haciendo la prueba de 'ping' a la IP WAN CANTV.

Router#ping 201.248.xx.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 201.248.xx.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/51/56 ms
Router#

Escenario 1)

El Router Cisco estará configuration para realizar el proceso de NAT. Este con el fin de permitir al direccionamiento IPv4 privado configurado en la LAN, utilizar alguna IP disponible en IP LAN POOL para la translación y envio de paquetes hacia la Internet.

!
interface GigabitEthernet0/0.xyz
description sub-interface WAN
ip nat outside
!
interface GigabitEthernet0/1
description interface LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shutdown
!
!
!
ip access-list extended NAT_ACL
permit ip 192.168.1.0 0.0.0.255 any
!
!
route-map NAT_ISP_1 permit 10
match ip address NAT_ACL
match interface GigabitEthernet0/0.xyz <- Sub-interface derivada de la WAN interface.
!
! utiliza cualquier IP de la IP LAN POOL en vez de z.z.z.z. Copiala 2 veces como se indica.
!
ip nat pool NAT_IP_PUBLICA z.z.z.z z.z.z.z netmask 255.255.255.248
!
ip nat inside source route-map NAT_ISP_1 pool NAT_IP_PUBLICA overload
!
end

Comprobación. El Router debe ser ahora capaz de realizar una prueba de ping hacia Internet utilizando la dirección IP de la interface LAN como origen de la comunicación.

Router#ping 8.8.8.8 source 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/40/48 ms
Router#

Como un valor agregado, el Router Cisco tiene la cualidad opcional de ser utilizado como servidor DHCP. Esto es una ventaja ya que permite entregar dinámicamente los parámetros de red a las Computadoras locales logrando que estas sean capaces de tener conectividad automática a la red tan pronto como se conecten a esta.

!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
end

Escenario 2)

Es además posible utilizar un Firewall / UTM para controlar y monitorear el tráfico de datos entre la red local y el Internet. En dicho caso, es deseable que el Firewall / UTM sea quien controle el proceso de NAT. Podemos no utilizar NAT en el Router y permitir que el uso de este sea únicamente en el Firewall / UTM. Es innecesario el uso de NAT en ambos dispositivos simultaneamente.

Utiliza la configuración mostrada en la sección "Configuración Base" he incluye lo siguiente: 

!
interface GigabitEthernet0/1
description interface LAN
ip address 200.11.xx.177 255.255.255.248 <-IP LAN POOL.
no shutdown
!
end

Comprobación. Una vez el Firewall / UTM es propiamente configurado con una dirección IP de la IP LAN POOL en su interface conectada al Router y una ruta para dirigir el tráfico de Internet hacia el Router Cisco, este debe de ser capaz de acceder a Internet.

NOTA: El Firewall / UTM ahora debe de realizar la funcionalidad de NAT para permitir el acceso a Internet desde la LAN.

Conclusión.

El Router Cisco es capaz de soportar funcionalidades avanzadas y escenarios mas complejos que los descritos en este documento. Como por ejemplo, puede correr protocolos de enrutamiento dinámicos, así como reglas de Seguridad, túneles VPN, servicios de Voz sobre IP y demás. Este documento cubre únicamente las configuraciones mínimas necesarias para proveer conectividad entre el ISP y la LAN.

Nota final:

Router# wr     <- Este comando guarda la configuración en el Router.
Comentarios

Hola 

Muchas gracias por compartir, estamos seguros será muy útil para aquellos que se desenvuelven en esta tecnología. 

New Member

Muchas gracias por su documento. De gran ayuda para manejar estos dos posible escenarios.

Comenté esto anteriormente pero creo que no se alcanzó a publicar (muy tarde no recuerdo si hice click en enviar)

Una de las razones por las que hay tantas preguntas acerca de como configurar los routers Cisco es debido a que antes la empresa CANTV incluía en su propuesta económica un Router que se podía pagar a plazos directo en la factura del servicio. Esto le daba un valor agregado al servicio y la mayoría de los clientes lo solicitaban. Dicho router venía preconfigurado para el día de implementación del servicio asi que los clientes obtenían una solución Llave en Mano y los sysadmin rara vez, si no es que nunca tenían que ni siquiera ver o tener idea que dichas configuraciones necesitaban ser realizadas. Prácticamente se asumía (incorrectamente) que la configuración del router era parte del servicio.

Debido a nuevas políticas del proveedor no se ofrecen mas los routers incluidos en el servicio y cada cliente es responsable de proveerlo por si mismo. Obviamente los receptores del servicio muchas veces tienen idea de que hay que configurar pero no están acostumbrados a la sintaxis de configuración de IOS

New Member

Hola, soy nuevo en estos temas, solo tengo conocimientos de los productos ubiquiti. tengo un router usado cisco meraki mr62, quiero resetearlo y configurarlo, serìa tan amable de ayudarme en este proceso.

Hola honier.gm@gmail.com,

Desafortunadamente, la gama de productos Cisco Meraki se encuentra fuera de mi conocimiento.

Te recomiendo preguntar en los foros de la comunidad de Cisco en la sección de Wireless por la información solicitada.

Lamento no poderte ser de mucha ayuda con dicho producto.

Saludos.

New Member

ok, no se preocupe, gracias por responder

New Member

Hola hector

Tengo un router rv110w y nesecito realizar la configuracion que tu comentas pero por mas que intento no lo puedo lograr, cantv me dio lo siguiente IP WAN 190.202.3.201 , IP LAN 190.202.0.96 , vlan 121

De antemano muchas gracias por tu ayuda

Hola normanjgutierrezf@gmail.com,

En tu caso, el ISP (CANTV) espera recibir los paquetes provenientes de tu red con la VLAN tag 121 en el encabezado Ethernet. Dichos VLAN tags son formalmente conocido como el estándar IEEE 802.1Q. En equipos Cisco, en ocaciones se les denomina simplemente 'dot1q'.

Para lograr conectividad entre tu Router y CANTV, la interface WAN en tu Router tendría que enviar los paquetes incluyendo dicha VLAN tag.

He revisado el manual del equipo RV110w, el cual he encontrado siguiente la siguiente liga:

http://www.cisco.com/c/dam/en/us/td/docs/routers/csbr/rv110w/administration/guide/rv110w_admin.pdf

Desafortunadamente, pareciera que el RV110w, siendo un equipo diseñado principalmente para el hogar, no soporta el envio de paquetes con VLAN tag en el puerto WAN.

Lo ya comentado por el compañero Ricardo Prado en el siguiente link es correcto:

https://supportforums.cisco.com/es/discussion/13120891

Necesitas ya sea un Switch que soporte 802.1Q entre tu Router y el equipo de CANTV, o un Router que soporte propiamente el envio de paquetes con 802.1Q tags (VLAN tags).

Te recomendaría analizar los equipos Cisco de la serie 800s, los cuales cuentan con Sistema Operativo Cisco IOS el cual es por linea de comandos.

Cisco 800 Series Routers

http://www.cisco.com/c/en/us/products/routers/800-series-routers/index.html

O también, equipos Cisco ISR (Integrated Services Routers)

http://www.cisco.com/c/en/us/products/routers/branch-routers/index.html#~tab-products

Dichos equipos soportan lo requerido para conectar tu red al servicio de CANTV.

Espero esta información haya sido de ayuda.

Saludos.

New Member

Hola Amigo Norman, a menos que algún experto de Cisco por acá conozca algún metodo especial.

NO CREO QUE SEA POSIBLE

Ese modelo (no estoy seguro si toda la serie RV)  cuenta con un puerto WAN dedicado

En este caso no tiene la funcionalidad de soportar una VLAN en el puerto WAN . y hasta donde tengo entendido los puertos lan son mas bien un switch, por lo cual no podrías usar un puerto como wan y otro como LAN.

Saludos cordiales

New Member

muchas gracias por la informacion

New Member

Hector buenas tardes, disculpa la molestia pero al parecer eres una basta fuente de conocimiento, estoy tratando de concetar un uc 540 con la metro ethernet de cantv, tendras alguna info?

agradecido de antemano

Hola Christian,

Tengo entendido que el Cisco UC 540 soporta únicamente ser configurado utilizando la herramienta Cisco Configuration Assistance (CCA).

Las mismas bases compartidas en este documento pueden ser aplicadas para tu equipo. 

Lamentablemente, no tengo experiencia con el CCA.

Espero puedas obtener mas ayuda con la documentación del CCA

http://www.cisco.com/c/en/us/support/cloud-systems-management/configuration-assistant-cca/products-maintenance-guides-list.html

o en los sección correcta del Cisco Support Community:

https://supportforums.cisco.com/community/5951/small-business-routers

Saludos Cordiales.

New Member

Hola Hector,

   Muchas gracias por tu información.

   Yo tengo un escenario de conexión diferente y te agradecería mucho si me puedes ayudar.

   1.- CANTV me entregó un modem OneAccess modelo 1424 que ya vino configurado de la siguiente forma: Vlan 396, wan: 190.205.80.217 / 255.255.255.252, Lan 190.205.50.144 / 255.255.255.248

   2.- Mi router es un Cisco Rvs4000 que no maneja vlans en el Puerto wan.

   3.- Estoy conectando mi router Rvs4000 al modem OneAccess a través de un suiche Cisco SG200-08P que si maneja Vlans

   4.- Los dos puertos del suiche Cisco SG-200 que conectan con el modem OneAccess y con el router Cisco RVS400 están configurados como trunks, untag 396 y PVID 396.

   5.- La configuración del WAN en el router RVS4000 es a través de un IP fijo con la siguiente configuración:  190.205.50.147 / 255.255.255.248, Gateway 190.205.50.145 y DNS 200.44.32.12

   Desde el router RVS4000 puedo hacer ping al 8.8.8.8 pero no recibo paquetes de vuelta.

Te agradezco mucho la ayuda que me puedas dar.

Saludos,

Moises

New Member

Amigo, buenas noches, si su router tiene un puerto dedicado para WAN no soporta VLANs en el puerto no va a poder tener conexión con el servicio Metro ethernet de CANTV.

Si necesita un router Cisco hay muy buenas opciones de segunda mano en páginas de internet dedicadas al comercio. Aunque puede usar tambien algunos modelos de routers de otras marcas o incluso un servidor linux.

No le servirá (creo que ningun) router cisco de la serie RV, si va a optar por Cisco ni serie 800, como regla de dedo, si el router que va a adquirir tiene un puerto WAN dedicado, no servría a sus propósitos , le recomiendo los modelos de las series  29xx y los 31xx le puede servir, tambien CREO que los 17xx 18xx le pudieran servir pero básicamente muy pocos de la gama SOHO o SMB resultarían adecuados para la conexión al metro ethernet. Yo en lo personal he tenido resultados positivos con los serie 1800, 1900, 2900, 3100 y 3900.

Este documento de Héctor le permitirá configurarlos en menos de 10 minutos y disfrutar de su servicio.

La VLAN en el puerto que mira al one-access de cantv es básicamente uno de los principales requisitos para que las centrales de cantv lo identifiquen como usuario. Desconozco mucho sobre como se maneja a nivel de TELCO este tipo de conexiones, pero segun entiendo, estamos usando la infraestructura de la TELCO en capa 2, es decir es como si estuvieramos detras de un switch y lo único que nos diferencia de los demás usuarios es básicamente la VLAN junto con los rangos de IP que nos dieron en la hoja de servicios.

Espero haberle ayudado y también espero que si dije alguna barbaridad o incorrección técnica alguien me corrija.

Saludos

New Member

Hola angphc,

   Muchas gracias por tu respuesta pero no sé si tomaste en consideración que me estoy conectado al modem Oneaccess del servicio Metro Ethernet de CANTV a través de un suiche Cisco SG200 que soporta Vlans con lo que puedo conectar el Puerto wan dedicado de mi router RV a una vlan configurando los puertos del suiche correctamente. De hecho puedo enviar paquetes con un ping pero no los recibo de vuelta.

  Solo quería saber si tomaste esto en consideración o solo pensaste que estaba tratando de conectar mi Puerto wan dedicado directamente al servicio Metro Ethernet de CANTV.

  Gracias por tu respuesta.

Moises

New Member

Amigo para saber si resoliviste, estuve fuera unos días.

en caso que no, se me ocurren varias cosas. Pero la primera es que desde donde estás haciendo ping no se está apuntando a un servidor de DNS válido (por lo que comentas que puedes hacer ping a 8.8.8.8) o un asunto de enrutamiento

Tu red es algo asi?

INTERNET<--->ONEACCES_SCANTV<---SWITCHSG20-->ROUTERRV<---->LAN

Es decir tu LAN no toca el switch SG

¿estas poniendo el RV a dar dhcp y el administra tu lan?

de ser asi, te recomiendo para probar que pongas como ip wan en to router la primera IP del pool que te dió cantv.

Igual avisa si solucionaste o no. Sería interesante ver los resultados de tu caso.

Cualquier cosa si necesitas mas ayuda abre un nuevo thread  o no se si este sistema permite MP, digo para que no llenemos de ruido el thread.

New Member

Hola Hector, como estas?. Muchas gracias por la información. Estoy realizando una configuración muy parecida, cantv me otorgo la vlan con un ID, en donde lo configuro?. 

Y otra cosa, estoy realizando esta configuracion en un router cisco 1900. este no posee gigabitethernet, como podria hacerlo en las fast ethernet? no se si seria asi:

interface fast X.

switchport encapsulation dot1q
switchport mode trunk
switchport trunk native vlan X (dada por cantv)
switchport trunk allowed vlan X (dada por cantv).

New Member

Buenas tardes, en su caso solo necesita reemplazar todo lo que diga GigabitEthernet por FastEthernet

En ese caso si iba a poner

GigabitEthernet0/1.xyz <<--- xyz es su vlan ID que le dio CANTV

quedaría

FastEthernet0/1.xyz

Y asi con todo slos comandos que digan GigabitEthernet, va a reemplazar la palabra Gigabit por Fast

y listo debería configurar sin ningún problema

New Member

Buenas. Amigo estoy planteando una configuración y quisiera poder recibir algo de ayuda. No tengo presupuesto para la conexión methor de cantv pero tengo unos 6 aba a la mano. Como podría balancear todas las conexiones tengo switch Cisco y router 1921 a la mano. Que configuracion puedo plantear.

New Member

Hector, espero te encuentres bien.

Te escribo ya que presento un inconveniente con la configuración de mi Red MetroEthernet.

La topología que tengo es la que muestras en el Ejemplo 1, configuro todo de acuerdo a lo que indicas en el tutorial y logro tener salida hacia la calle desde el router. Sin embargo, configuro mi computadora con una dirección privada que se encuentra dentro de mi red LAN y la misma no hace PING hacia la WAN de CANTV. 

Te dejo la configuración de mi Router Cisco 1841.

Las direcciones que manejo son las siguientes:

Dirección WAN CANTV: 201.XXX.XXX.157

Dirección WAN Cliente: 201.XXX.XXX.158

Máscara WAN 255.255.255.252

En el lado de la red LAN, tengo la el segmento 192.168.3.0/24 

A continuación te detallo la configuración de mi equipo para ver si logras visualizar algún error o algo que falte.

interface FastEthernet0/0.XXX
description WAN_PORT
encapsulation dot1Q XXX
ip address 201.XXX.XXX.158 255.255.255.252
ip nat outside
ip virtual-reassembly
!
interface FastEthernet0/1
description LAN_PORT
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 201.XXX.XXX.157
!
!
ip http server
no iphttp secure-server
ip dns server
ip nat pool NAT_IP_PUBLICA 192.168.3.0 192.168.3.0 netmask 255.255.255.0
ip nat inside source route-map NAT_ISP_1 pool NAT_IP_PUBLICA overload
!
ip access-list extended NAT_ACL
permit ip 192.168.3.0 0.0.0.255 any
!
!
!
!
route-map NAT_ISP_1 permit 255
match ip address NAT_ACL
match interface FastEthernet0/0.XXX

Muchísimas gracias.

New Member

El pool NAT_IP_PUBLICA que has definido no es correcto. Lo debes definir con la/s dirección/es IP pública/s asignadas. En tu caso, entiendo que será la IP pública de la interfaz WAN (201.249.XXX.158). Por lo tanto, quedaría:

ip nat pool NAT_IP_PUBLICA 201.249.XXX.158 201.249.XXX.158 netmask 255.255.255.252

Saludos,

New Member

El Meraki MR62 es un AP de exteriores. Todos los equipos Meraki se gestionan desde el cloud. Es decir, se conectan a los servidores de Meraki a través de Internet y tú puedes configurarlo conectándote al Dashboard Meraki también a través de Internet. Para ello, debes darte de alta en Meraki, crear una organización, solicitar al anterior propietario del AP registrado en Meraki que gestione con Meraki el cambio de organización (de la anterior a la tuya) del AP, tener una licencia vigente para ese AP (comprarla, en caso de que no esté vigente).

A continuación, debes hacer un factory reset (pulsando más de 10 segundos el botón mediante un clip) y dejar que el AP se conecte a Internet. Para ello, debes tener un servidor de DHCP que le asigne IP y que el router o FW le permita el acceso.

A partir de ahí, el AP se conectará al cloud, lo verás en el Dashboard y podrás empezar a configurarlo. La configuración es muy simple.

Saludos,

New Member

Saludos Hector, tengo una situacion q no he podido resolver a ver en que me puedes ayudar

Tengo un Router Cisco 1941

cantv me asigna la siguiente informacion:

vlan xyz

IP LAN: 201.xxx.xxx.16 / 28.

En el router tengo la siguiente configuracion:

interface GigabitEthernet0/0
 description Interfaz-LAN
 ip address 200.xxx.xxx.241 255.255.255.248 secondary
 ip address 172.23.8.1 255.255.248.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description conexion-WAN
 no ip address
 ip virtual-reassembly
 duplex full
 speed 100
!
interface GigabitEthernet0/1.zxy
 description conexion Metro-LAn
 encapsulation dot1Q zxy
 ip address 192.168.xxx.253 255.255.255.0
!
interface GigabitEthernet0/1.xyz
 description conexion Metro-Internet
 encapsulation dot1Q xyz
 ip address 200.xxx.xxx.38 255.255.255.252
 ip nat outside
 ip virtual-reassembly
!
ip nat inside source list 101 interface GigabitEthernet0/1.xyz overload
ip route 0.0.0.0 0.0.0.0 200.xxx.xxx.37
!
access-list 101 permit ip 172.23.8.0 0.0.7.255 any

he realizado infinitas pruebas pero nada que puedo resolver.

La idea es que las ip LAN que me da CANTV son para que sirvan de ip publica para que apunten a un servidor y se asocien a un dominio.

Agradezco su respuesta positiva.

Hola johs25@gmail.com,

  1. ¿Cuál es el resultado del comando 'ping 8.8.8.8' ejecutándolo en el Router?
  2. ¿Se tiene la IP LAN pública otorgada por CANTV configurada en tu Router?
  3. ¿Qué pruebas exactamente estas realizando?

Saludos.

New Member

Saludos Hector Gracias por responderme creo que no me hice entender de respondere las preguntas y luego te reformulare nuevamente la pregunta.

Respuestas.

1.ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/96/100 ms

2.La IP LAN Publica otorgada por CANTV es este pool 201.xxx.xxx.16 / 28 no configurado en el router esa es mi pregunta como logro configurarla.

3. Las pruebas es configurando estas IP LAN publica en un router cisco 1941 para dar salida a varios servidores por ejemplo www.ejemplo1.com que debe apuntar a 201.xxx.xxx.18, entre otros.

Reformulacion de la pregunta la configuracion mostrada en la anterior pregunta es la configuracion actual del router cisco 1941, es decir, el esta en funcionamiento con esa configuración para prestar el servicio de internet, voz, datos, y es parte de una red metro cobre de tres sedes en intranet.

Repito el esta configurado para prestar esos servicios.

El caso es que desde agosto del año 2016 Se solicita a CANTV un pool de IP LAN ya que la unica salida que tenemos la tiene el router con la IP LAN pública 200.xxx.xxx.38 y otra 200.xxx.xxx.37. Y se necesita es salir con los dominios www.ejemplo1.com.

En ese sentido, se le solicita a CANTV un pool mas grade para dos Circuitos este que estoy presentando y otro. CANTV nos envia su aprobacion cito textualmente:

Estimado, finalmente la solicitud de un nuevo bloque de IP fue aprobado. Por tal motivo te informo que este es el nuevo bloque de IP  barra /28 para el  cliente:XXXX (XXXX27). vlan xyz

IP LAN:     201.xxx.xxx.16   / 28

Nota: las  IP se entregan ya configuradas en el router  de CANTV. Al menos que el cliente no lo requiera así.

Debido a que CANTV ya no configura nuestros router con las IP LAN pública, sino que debo ser yo quien las configure y no se como hacer ya que no he tenido esperiencia en el campo de configuracion de router cisco y llevo 7 meses en ello y no he logrado hacer nada sino solo documentandome de vez en cuanto por lo ocupado que he esta en otras actividades y ahora debo configurarlas en dos router de dos sedes distantes para darle salida.

Mi pregunta realmente debo eliminar la configuracion que tiene actualmente con la

IP LAN pública 200.xxx.xxx.37/ 30.

y sustituirla por este nuevo pool de

IP LAN pública 201.xxx.xxx.16   / 28.

Hola johs25@gmail.com,

  • No debes de modificar 200.xxx.xxx.37/ 30, siendo que este es el direccionamiento Punto-a-Punto que tiene tu Router con CAN TV.
  • Si has solicitado un nuevo direccionamiento púlico a CAN TV y ellos te lo han otorgado, solo tienes que configurar el direccionamiento en el Router.

De este ser 201.xxx.xxx.16/28 como mencionas,

  • 201.xxx.xxx.17 puede ser configurada en tu Router.
  • El rango 201.xxx.xxx.18 hasta 201.xxx.xxx.30 puede ser configurada en tus Servidores.

Siendo que tu Router únicamente tiene 2 puertos GigabitEthernet disponibles, tendras que configurar el nuevo direccionamiento como 'secundario' en la interface 'GigabitEthernet0/0'.

configure terminal
!
interface GigabitEthernet0/0
 ip address 201.xxx.xxx.17 255.255.255.248 secondary
!
end

Saludos.

New Member

Buenos días, forfin consegui algo de este cangrejo, mi problema es que, estoy trabajando en una empresa, que tiene estos equipos nada normales, como son los modem normales de Cantv, sino el Modem Access 1424, el cual le ha dado dolores de cabeza a los tecnicos que han pasado, y como no hay documentacion de la empresa , relacionado al Router Cisco y su configuración, opte por ubicar a una persona que sabe de Cisco, pero veo que tambien hay otro problema el Modem.

en fin el Router Cisco funciona perfecto en la distribucion del internet, la cual no sabia que Cantv dio estos equipos, el esta conectado a un Swich TP... y a su vez el modem esta conectado al Router Inalambrico TP... .

El Router Inalambrico perfectamente se ve via Web desde su interfaz , desde un computador o Laptop Inalambrico, mas no se ve desde la red cableada, donde esta el Servidor.

Será que hay que desahibilitar el Firewall de Cantv? o que configuracion hay que hacer.

Nota: El router Inalambrico esta el la misma red que el Swich y el Cisco, eso creo yo, ya que haciendo un tracert a la IP Publica, ver imagen adjunta.

No existe documentacion, de la configuracion que se realizo desde un inicio.

Se necesita ver lo del Router Inalambrico via web por: Camaras de Seguridad y la Central Telefonica Asterisk.

Saludos

Anna Carolina Díaz Riera

Yo hubiese eliminado el Modem , pero no se las funciones que hace, alguien me podría explicar.

New Member

Saludos Hector mil disculpas por ocupar tu valioso tiempo.

De  acuerdo a lo que mencionas en la anterior respuesta todo esta correcto.

configure el router con la ip que mencionastes

 ip address 201.xxx.xxx.17 255.255.255.248 secondary

Y el router me responde desde la url

Configure uno de los servidores de la red para probar si se veia externamente de la siguiente manera

        address 201.xxx.xxx.18
        netmask 255.255.255.248
        gateway 201.xxx.xxx.17

y no se ve ni recibe ping.

Que me falta para que se vea el servidor externamente?

Hola johs25@gmail.com,

Sugiero verificar si el direccionamiento público otorgado por CAN TV puede utilizarse correctamente para comunicarse a Internet.

Para esto, puedes realizar un 'ping' originandolo desde el Router con la IP que justo has configurado.

Por ejemplo:

Router# ping 8.8.8.8 source 201.xxx.xxx.17
  • Si obtienes que el resultado del 'ping' es satisfactorio, tendras que revisar tu Servidor.
  • Si el 'ping' falla, tendras que checar con CAN TV el por que este direccionamiento no esta propiamente 'ruteado' a Internet.

Saludos.

New Member

Saludos Hector, nuevamente gracias por tu tiempo.

El resultado del 'ping',

Router# ping 8.8.8.8 source 201.xxx.xxx.17

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet sent with a source address of 201.xxx.xxx.17
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 268/282/292 ms

Creo que correcto,

De ser asi, Que debo revisar en el servidor?

Realmente no necesito navegar en el servidor solo requiero que la ip publica se vea en el exterior para asociarlo a un dominio web www.ejemplo.com.

Adjunto el archivo de configuracion del router.

Hola johs25@gmail.com,

  • Es el 'ping' ejecutado desde el Servidor con destino su "Default Gateway" (201.xxx.xxx.17) exitoso?
Servidor> ping 201.xxx.xxx.17
  • En dado caso que sea exitosa la prueba anterior, puede el Servidor completar el ping a Internet?
Servidor> ping 8.8.8.8
  • ¿Qué prueba estas exactamente realizando?

Estoy dando por sentado, las correcta configuración del direccionamiento IP en el servidor:

address 201.xxx.xxx.18
netmask 255.255.255.248
gateway 201.xxx.xxx.17

Saludos.

Hola anna.diaz,

No entiendo del todo tu duda.

  • ¿Cuál es exactamente tu pregunta?
  • Necesitas ayuda con el "Router inalambrico"?
  • ¿Cuál es la marca y modelo de este?

Saludos.

New Member

Saludos Hector, gracias por tiempo y mil disculpas por no chequear debidamente la configuracion del apache en el servidor. Efectivamente el problema era de configuracion del apache.

En resumen, mi problema de hace 8 meses fue el de colocar en la configuracion del router lo siguiente.

interface GigabitEthernet0/0
 ip address 201.xxx.xxx.17 255.255.255.248 secondary

y finalmente configurar los servidores y servicio web.

Muchas Gracias por su valiosa ayuda y este aprendizaje.

Tengo otro problema con otro router pero lo posteare mas tarde, estare haciendo pruebas primeramente y luego solicitare su ayuda de ser necesaria.

Hola johs25@gmail.com,

Me alegra haberte podido ayudar con esta problemática.

Saludos y que tengas un buen dia.

New Member

Hola Héctor, tengo una metro por fibra, cantv me suministro estos datos

IP wan 201.XXX.140.96/30

IP lan 201.YYY.YYY.141 (sin mascara)

Vlan xyz

He configurado el router 1841 con la ip wan en la F0/0 y en la F0/1 con un segmento privado

Ya tengo conexión saliendo por la f0/0.xyz

Mi pregunta es:

- a la ip lan Le falta la máscara para configurar el pool de IP públicas para la lan o equivoco?

Pd.  tengo salida con la ip wan del router 

De antemano gracias ! 

Hola cyclopsld,

Es correcto. Cantv debe de proveerte con la máscara de red para la pool de IP públicas que te ha otorgado.

Saludos.

Hola Héctor, buenas tardes:

Gracias por compartir tus conocimientos, tengo que configurar un Metro Internet de CANTV solo para dar acceso a internet a una localidad, y este artículo tuyo me ha servido un montón para tratar de entender el asunto. Antes de comprar el router, quisiera preguntarte para estar seguro, si el 1841 con 256 Mb de DRAM y 32 Mb de Flash es suficiente para este proyecto?

Hace falta tener instalada alguna licencia o tarjeta adicional?

Gracias de antemano por tu colaboración.

Saludos

Hola Guillermo,

El Router a escoger para cualquier proyecto dependera de varias consideraciones, donde la principal es la cantidad de tráfico que se espera el Router pueda procesar/transmitir.

Este importante factor además es impactado por la cantidad de opciones que el Router tenga habilitadas en su configuración final como por ejemplo, Crypto (VPN), ZBF (Firewall), ACLs, NAT, PBR, Netflow, NBAR, etc, etc.

Mientras menor la cantidad de opciones habilitadas, el Router podrá enfocarse mejor en procesar el tráfico de red lo más rápido que a este le sea posible.

Desconozco los detalles de tu implementación/proyecto.

Te comento que el Router Cisco modelo 1841 ha sido descontinuado y por este motivo no es soportado mas por el TAC de Cisco ni es capaz de utilizar las versiones mas recientes del Sistema Operativo Cisco IOS.

Esta información esta disponible en este documento:

http://www.cisco.com/c/en/us/products/collateral/routers/1800-series-integrated-services-routers-isr/eol_c51-625662.html

Acerca de tus dudas, este Router trae 2 puertos FastEthernet (10/100 Mbps), por lo que podrás conectarlo hacia la WAN y LAN mediante cable Ethernet.

Es importante mencionar que si lo que requieres es conectividad por T1 hacia la WAN o similar, el Router deberá contar con una tarjeta adicional.

Hasta donde conozco, este modelo no requiere licencia adicional para habilitar las opciones básicas como las detalladas en este documento (IP address, Routing estático y NAT).

Te comparto un documento oficial detallando muy brevemente las capacidades de varios equipos ya retirados del mercado, incluyendo el 1841. En este se menciona un limite teorico de hasta 38.40 Mbps para este modelo.

https://www.cisco.com/web/partners/downloads/765/tools/quickreference/routerperformance.pdf

Además, este otro documento detalla un poco mas las posibilidades del equipo, lo cual te puede ser de ayuda.

http://www.cisco.com/c/dam/en/us/products/collateral/routers/1800-series-integrated-services-routers-isr/prod_white_paper0900aecd801738fa.pdf

En mi opinión personal, yo usaria este Router únicamente para instalaciones menores que cuenten con una cantidad no mayor a 10 usuarios (o tal vez menor). Esto debido a que el equipo realmente ya es muy viejo y probablemente no soporte la demanda de tráfico de las redes de datos actuales (aplicaciones de video, voz, streaming por Internet, etc).

Espero esta información te haya sido de ayuda.

Saludos.

New Member

Hola Guillermo, ya héctor te contestó ampliamente con datos técnicos muy válidos y buenos para tener en cuenta a la hora de implementar.

Te cuento que he usado sin problemas  los routers 1841 para usar los servicios metro ethernet de cantv. Asumiendo que es un enlace a cobre lo máximo a lo que puedes llegar es 8mbps simétricos está dentro de las capacidades del router manejar ese ancho de banda (serían en todo caso 16mbps lo máximo que manejarías, 8 de subida, y 8 de bajada) suponiendo que: lo configures como la Opción 2 de este documento y dejar que otro dispositivo haga las funciones de NAT, DHCP, y routeo etc.. Asi dejarías todo el poder del router a hacer una única tarea que sería funcionar como interfaz de encapsulamiento entre tu red local y la red de servicios de cantv que es lo único que realmente necesitas, encapsular tu tráfico en la vlan que ellos te asignen.

Obviamente es un router totalmente descontinuado y si hay un pequeño riesgo en cuanto a que en el futuro no puedas manejar mayores anchos de banda (no me acuerdo donde leí que el máximo que maneja es alrededor de 30 y tantos Mbps) en caso de que migraras a servicios de fibra con mayores anchos de banda (carísimos por cierto en cantv, cuesta casi 10 veces mas el enlace de fibra de 10mbps que el de cobre de 8mbps). Al ser un equipo descontinuado no tienes acceso a versiones mas nuevas del f/w  y obviamente en caso de una falla de hardware no vas a tener ningún soporte de ningún tipo en ningún lado. Aunque seamos sinceros. Cisco es Cisco, y rara vez en un equipo de este nivel vas a tener fallas a nivel de hardware. Hay estudios independientes que estiman el MTBF de los equipos Cisco es de ¡30 años!

Parafraseando lo que se decía de IBM en otros tiempos: A nadie lo han despedido por recomendar o comprar cisco

Dada las condiciones económicas actuales yo en lo personal considero beneficioso poder aprovechar equipos EOL y ponerlos a hacer un trabajo bien hecho, muchas pequeñas y medianas empresas no se pueden dar el lujo de costear equipos nuevos que cuestan 20 o 30 veces mas.

Si tienes alguna duda o quieres ampliar el tema asi como ver alternativas de configuración y para no contaminar los comentarios del documento con una conversación paralela, escríbeme a mi correo que es mi nombre de usuario aqui y con gusto te puedo tratar de ayudar o abre un  nuevo hilo. Yo trabajo muy de cerca con un par de integradores de servicios de cantv y creeme que hemos experimentado bastante con los servicios metro de cantv y los hemos llevado a sus límites

Saludos. Guilermo Peña

New Member

Hola @Hector Gustavo Serrano Gutierrez Buenas Tardes,

 

Me ha servido mucho tu post inicial, solo tengo un par de dudas:

 

1. Configuración de los DNS:

    En mi caso el ISP ha proporcionado un DNS Primario y otro Secundario

     187.141.xxx.249 Primario

     187.141.xxx.249 Secundario

 

     Cómo los incorporo a la configuración ? 

 

2. Acerca del DHCP: Actualmente manejo DHCP desde un Servidor Windows 2016, recomiendas que el router sea quien asigne las direcciones IP o     a través del servidor Windows ?.

 

Agradezco tu ayuda !

 

 

Hola @JrMeraz,

 

1. Puedes agregar servidores DNS a la configuración del Router utilizando los siguientes comandos:

configure terminal
Router(config)#ip domain-lookup     # Este comando deberia estar habilitado por default.
Router(config)#ip name-server <DNS_IP_ADDRESS_PRIMARY>
Router(config)#ip name-server <DNS_IP_ADDRESS_SECONDARY>

Ten en cuenta que esto te serviria unicamente para poder resolver nombres de dominio a direcciones IP cuando se origine la comuincacion desde el mismo Router, por ejemplo:

Router# ping www.google.com
Translating "www.google.com"...domain server (187.141.xxx.249)

2. El Router mismo puede tener el rol de Servidor DHCP y otorgar direccionamiento IP a Hosts en la red local. Si tienes una red con relativamente pocos Hosts, no veo problema con que el Router mismo tenga este rol. Sin embargo, si tienes una red muy extensa, por razones de escalabilidad puedes mover esta responsabilidad al Servidor Windows.

 

Saludos.

New Member

Muchas gracias @Hector Gustavo Serrano Gutierrez agradezco infinitamente tu ayuda,

 

Saludos

Juan.

Con gusto @JrMeraz

 

Saludos.

New Member

buenas tardes...

tengo un problema al conectar mi red lan con el ISP CANTV.

 

 

hace poco adquirí un servicio de datos cantv. y estoy teniendo problemas al realizar las configuraciones a mis equipos ya que cantv de dio unos datos para realizar la conexion de varias sucursales que estan fuera del edificio principal.  y en cada una de las sucursales cantv instala un router one acces 1424.

 

 

CIRCUITO: xxxxxxx

VPLS ID: xxxx

VLAN xxx

CARRIER 4MB

IP: xxx.xxx.xxx.xxx

TIPO CPE: T-LINDUS-1424

 

nota: la ip me la dieron sin mascara. porq dicen q la mascara se la debo asignar yo ya q es solo un servicio de datos

 

Hola tuliocastillo2003,

  1. ¿Podrias dar mas detalles de cual es el problema?
  2. ¿Que operación has realizado?
  3. ¿Con que problemática te has encontrado?

Saludos.

New Member

buenos dias. bueno el problema es el siguiente hace poco donde trabajo se contrato un servicio metro ethernet de 100 mb datos con CANTV. para interconectar varias sucursales de la empresa donde trabajo las cuales se encuentran en varias partes del pais.. 

 

cantv se dirigio a cada una de esas sucursales y instalo un router one acces 1424 en cada una de ellas, cantv me entrego una direccion ip por cada una de ellas.

 

sucursal marutin: estos son los datos que me dejo en esa sucursal.

CIRCUITO: 8683-3394114

ID: 1000028455 (VPLS)

CARRIER 4Mb

VLAN: 709

IP: 10.115.238.11

PUERTOS 1/1/2/17 Y 18

TIPO DE CPE: T-LINDUS-1424

 

en la oficina principal me dejos los siguientes datos.

 


CIRCUITO: 2242 0170585 
ORDEN SISE: U17IME69547
VELOCIDAD:100 MB.
SERVICIO CONFIGURADO  (172.10.114.129) 
PTO:5/1/4
VPLS ID:1000028455 
VLAN:709
ZTE_5928:10.150.211.13  
PTO:GEI-1/1/1/2

 

mi red esta de la siguiente forma:

ISP--------SWITCH CISCO 3750----- RED LAN

ahora el problema es q no se de que forma configurar mis equipos para tener conexion desde mi oficina principal a cada una de las sucursales.

si esta en tus manos y conocimiento decirle que tipo de configuracion le debo hacer para lograr dicha conexion

New Member

saludos cordiales, primero que todo agradecido con esta información ya que me sirvió, solo que ahora presento otro problema, tengo un 1841 y unos 40 clientes, el funciona bien pero cada cierto tiempo dejo de poder ver el router, y por consiguiente no se cae el internet, las luces del router siguen igual, solo apago y prendo el router y todo vuelve a la normalidad, he probado con 2 1841 y los 2 me presentan la misma falla,

gracias de antemano por su respuesta

Buenas compañeros, mi situacion no esta planteada en el post, ya que yo no tengo router, dispongo es de un switch capa 3 y un firewalls, alguien me podria ayudar con la configuracion.

 

ISP-----Switch Capa3--------Firewalls-------Red Lan

 

como en todos los casos tengo mi ip Wan otorgada por cantv /30, y mi pool /29 tambien otorgado por cantv.

 

El nat lo voy a realizar en mi firewalls, asi que eso no me preocupa,

de Wan a Wan le llego al siguiente extremo, mi problema esta al intentar utilizar las IPS lan publicas, al probarlas, quisiera saber como las configura para probarlas, antes de pasarlas al firewalls, gracias.

12233
Visitas
21
ÚTIL
47
Comentarios