Redundancia de WAAS y 7600 con WCCP

Hola. Soy Eduardo Aliaga.

Tengo casi 10 años de experiencia en diseño e implementación de redes, sobretodo en equipos Cisco, aunque también he manejado varios proyectos de integración de múltiples fabricantes.

En este tutorial veremos el uso de múltiples CORE WAAS en conjunto con múltiples 7600, quienes realizarán la redirección del tráfico mediante el protocolo WCCP. Los COREs WAAS se despliegan en los datacenters.

Notar que hay múltiples opciones de uso de WCCP para la redirección del tráfico y esto depende en gran medida del hardware que realiza la redirección. En este caso el 7600 utiliza túneles GRE multipoint con el objetivo de hablar con múltiples core WAAS.

Por otro lado los EDGE WAAS (los que se despliegan en las oficinas remotas) usan modo inline.

Config del WAAS Device Manager

device mode central-manager

!

Hostname <hostname>

ip domain-name <domain-name>

!

primary-interface GigabitEthernet 1/0

!

interface GigabitEthernet 1/0

ip address <ip> <mask>

no shutdown

exit

!

ip default-gateway <ip>

!

clock timezone America/Lima -5 0

ntp server <ip>

!

no auto-register enable

!

cms enable

!

username admin password <Contraseña>

username admin privilege 15

authentication login local enable primary

authentication configuration local enable primary

banner login message " No esta permitido el ingresode usuarios\nno autorizados a este sistema\n"

banner enable

Config de cada CORE WAAS

hostname <hostname>

!

primary-interface GigabitEthernet 1/0

!

interface GigabitEthernet 1/0

ip address <ip> <mask>

no shutdown

exit

!

ip default-gateway <ip>

!

wccp version 2

wccp router-list 1 <ip-router-1> ! ip loopback de cada router 7600 de su respectivo site

wccp router-list 1 <ip-router-2> ! ip loopback de cada router 7600 de su respectivo site

device mode application-accelerator

!

ip domain-name <domain-name>

wccp flow-redirect enable

wccp tcp-promiscuous router-list-num 1 password <contraseña> mask-assign

!

egress-method generic-gre intercept-method wccp

!

clock timezone America/Lima -5 0

ntp server <ip>

username admin password <Contraseña>

username admin privilege 15

authentication login local enable primary

authentication configuration local enable primary

central-manager address <ip>

cms enable

banner login message " No esta permitido el ingresode usuarios\nno autorizados a este sistema\n"

banner enable

Config de cada 7600

interface loopback 1000

ip address <ip> <mask>

interface tunnel 10

ip address <ip> <mask>

tunnel source loopback 1000

tunnel mode gre multipoint

ntp server <ip>

ip wccp version 2

ip access-list extended WCCP-ACL

deny tcp any eq 22 any

deny tcp any eq 23 any

deny tcp any any eq 22

deny tcp any any eq 23

permit tcp any any

deny ip any any

ip wccp 61 redirect-list WCCP-ACL password <Contraseña>

ip wccp 62 redirect-list WCCP-ACL password <Contraseña>

interface <WAN>

  ip wccp 61 redirect in

interface <LAN>

  ip wccp 62 redirect in

Config de los EDGE WAAS

device mode application-accelerator

hostname <hostname>

ip domain-name <domain-name>

primary-interface GigabitEthernet 1/0

!

interface GigabitEthernet 1/0

ip address <ip> <mask>

no shutdown

exit

interface inline group 1/0

inline vlan all

no inline vlan <numero> ! negar por ej. la vlan de voz

autosense

ip default-gateway <ip>

clock timezone America/Lima -5 0

ntp server <ip>

username admin password <Contraseña>

username admin privilege 15

authentication login local enable primary

authentication configuration local enable primary

central-manager address <ip>

cms enable

banner login message " No esta permitido el ingresode usuarios\nno autorizados a este sistema\n"

banner enable

Historial de versiones
Revisión n.º
1 de 1
Última actualización:
‎07-14-2013 02:45 PM
Actualizado por:
 
Etiquetas (1)