cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
Community Member

Ancho de banda distinto en 2 Lan.

Hola.

Quisiera pedir si me pueden dar una mano con esto.

Tengo configuradas 2 Lan.

Y quisiera que cada una tuviera un ancho de banda distinto.

Es decir tengo una Wan y quiero que tenga un porcentaje mayor de ancho de banda una que otra.

Alguien me podría dar una mano con esto?

Saludos y gracias

9 RESPUESTAS
Cisco Employee

Hola. ¿Qué tipo de equipo

Hola. ¿Qué tipo de equipo tienes?

Community Member

Hola.

Hola.

Tengo un Cisco 2901 (2 gigabitethernet onboard) y un módulo de 4 interfaces ethernet.

Gracias

Cisco Employee

Hola. El siguiente link

Hola. El siguiente link muestra las diversas opciones de QoS que tienes para realizar lo que buscas. Lo que necesitas es configurar policing para darle un ancho de banda máximo a determinado tráfico.

http://www.cisco.com/c/en/us/td/docs/ios/12_2/qos/configuration/guide/fqos_c/qcfwfq.html

http://www.cisco.com/c/en/us/support/docs/quality-of-service-qos/qos-policing/19645-policevsshape.html#policingvsshaping

Un ejemplo:

access-list 100 permit ip <LAN 1> any

access-list 120 permit ip <LAN 2> any

class-map LAN1

 match access-group 100

class-map LAN2

 match access-group 120

policy-map POLICE

  class LAN1

    police <BW en bits por segundo>

  class LAN2

     bandwidth <BW en kilobits por segundo>

interface <WAN>

   service-policy out POLICE

El comando "police" limita un máximo de ancho de banda para el tráfico. El comando "bandwidth" te da un mínimo de ancho de banda sin tener límites superiores.

Saludos.

Community Member

Hola. Muchísimas gracias.

Hola. Muchísimas gracias.

Existe alguna forma para mostrar que esté funcionando? (más allá de ver la velocidad que alcanza alguna pc en esa red)

Y por otro lado, en vez de poner un máximo, es viable establecer que sea variable?? Me refiero a que por ej. si la Lan 1 (a la que quiero darle más ancho de banda) no está usando su máximo pues que pueda "ceder" ese ancho de banda momentaneamente a a Lan 2 (hasta que lo necesite).

El ancho de banda...... involucra tanto la subida como la descarga??? Podría discriminarlos?

saludos y muchas gracias!!!!

Cisco Employee

La opción de "bandwidth" solo

La opción de "bandwidth" solo se puede usar para el tráfico de subida (output), para el de bajada solo se puede usar la opción de police (service-policy in POLICE). Por lo general el control del tráfico de bajada se maneja directo con el proveedor de servicios. Una forma de ver si se está aplicando es con el comando: show policy-map interface <NAME>.

Lamentablemente, la configuración de policing no permite usar ancho de banda más allá de lo que tiene permitido, aunque haya ancho de banda libre disponible. Es posible agregar un poco más de ancho de banda si juegas con los parámetros de ráfagas (exceeded burst, violate burst), pero el tráfico seguiría más limitado. La otra configuración de "bandwidth" sí permite usar más ancho de banda si es que hay disponible ya que solo garantiza el mínimo.

Algo que podrías hacer sería combinar las dos opciones, poner un bandwidth más chico para Lan2 y un police más alto (doble del ancho de banda que tenías considerado) dentro de la misma política. De esta forma, cuando haya congestión garantizas un ancho de banda menor y evitas que usen todo el ancho de banda si hay disponibilidad.

Community Member

Hola. Che me doy cuenta que

Hola. Che me doy cuenta que no está funcionando...... qué estaría mal??? este es mi archivo config...... Me podrías dar una mano???

Muchas gracias!!!!

-------------------------------------------------------------------------------------------------------------

Por cierto, la Wan es

interface GigabitEthernet0/0                                                               
 ip address 192.168.1.11 255.255.255.0      

Te aclaro por las dudas, pues es un router que está conectado a otro................

--------------------------------------------------------------------------------------------------------------

Current configuration : 3648 bytes                                                         
!                                                                                          
! Last configuration change at 17:08:04 UTC Tue Jun 28 2016                                
version 15.3                                                                               
service timestamps debug datetime msec                                                     
service timestamps log datetime msec                                                       
service password-encryption                                                                
!                                                                                          
hostname RHijos                                                                            
!                                                                                          
boot-start-marker                                                                          
boot-end-marker                                                                            
!                                                                                         
enable password 7 131512020A5F5C7D79757A60242309                                           
!                                                                                          
aaa new-model                                                                              
!                                                                                          
aaa session-id common                                                                      
!                                                                                          
ip cef                                                                                     
!                                                                                          
ip dhcp excluded-address 10.0.158.1 10.0.158.128                                           
ip dhcp excluded-address 192.168.9.1 192.168.9.128                                         
!                                                                                          
ip dhcp pool Red9                                                                          
 network 192.168.9.0 255.255.255.0                                                         
 default-router 192.168.9.1                                                                
 dns-server 192.168.1.1                                                                    
 lease 0 2                                                                                 
!                                                                                          
ip dhcp pool Red158                                                                        
 network 10.0.158.0 255.255.255.0                                                          
 default-router 10.0.158.1                                                                 
 dns-server 192.168.1.1                                                                    
 lease 0 2                                                                                 
!                                                                                          
ip domain name nombre                                                                      
ip name-server 192.168.1.1                                                                 
no ipv6 cef                                                                                
!                                                                                          
multilink bundle-name authenticated                                                        
!                                                                                          
voice-card 0                                                                               

!

license udi pid CISCO2901/K9 sn FTX180581WJ                                                
hw-module pvdm 0/0                                                                         
!                                                                                          
username xxx secret 4 18ENFd/4nHi1uEbOK8Ai/fLcHh.HWwQWGpc4D7sdqs.                        
!                                                                                          
redundancy                                                                                 
!                                                                                          
ip ssh time-out 90                                                                         
ip ssh authentication-retries 2                                                            
ip ssh version 2                                                                           
!                                                                                          
class-map match-all Red9                                                                   
 match access-group 109                                                                    
class-map match-all Red158                                                                 
 match access-group 158                                                                    
!                                                                                          
policy-map AnchoBanda                                                                      
 class Red9                                                                                
  police 512000                                                                            
 class Red158                                                                              
  police 1024000                                                                           
!                                                                                          
interface Embedded-Service-Engine0/0                                                       
 no ip address                                                                             
 shutdown                                                                                  
!                                                                                          
interface GigabitEthernet0/0                                                               
 ip address 192.168.1.11 255.255.255.0                                                     
 ip nat outside                                                                            
 ip virtual-reassembly in                                                                  
 duplex auto                                                                               
 speed auto                                                                                
 service-policy input AnchoBanda                                                          
!                                                                                          
interface GigabitEthernet0/1                                                               
 ip address 192.168.9.1 255.255.255.0                                                      
 ip nat inside                                                                             
 ip virtual-reassembly in                                                                  
 duplex auto                                                                               
 speed auto                                                                                
!                                                                                          
interface GigabitEthernet0/1/0                                                             
 switchport access vlan 158                                                                
 no ip address                                                                             
!                                                                                          
interface GigabitEthernet0/1/1                                                             
 switchport access vlan 158                                                                
 no ip address                                                                             
!                                                                                          
interface GigabitEthernet0/1/2                                                             
 switchport access vlan 158                                                                
 no ip address                                                                             
!                                                                                          
interface GigabitEthernet0/1/3                                                             
 switchport access vlan 158                                                                
 no ip address                                                                             
!                                                                                          
interface Vlan1                                                                            
 no ip address                                                                             
!                                                                                          
interface Vlan158                                                                          
 ip address 10.0.158.1 255.255.255.0                                                       
 ip nat inside                                                                             
 ip virtual-reassembly in                                                                  
!                                                                                          
ip default-gateway 192.168.1.1                                                             
ip forward-protocol nd                                                                     
!                                                                                          
no ip http server                                                                          
no ip http secure-server                                                                   
!                                                                                          
ip nat inside source list 109 interface GigabitEthernet0/0 overload                        
ip nat inside source list 158 interface GigabitEthernet0/0 overload                        
ip route 0.0.0.0 0.0.0.0 192.168.1.1                                                       
!                                                                                          
!                                                                                          
!                                                                                          
access-list 109 remark ==Red9 con acceso telefonico y bloqueo a red 1==                    
access-list 109 permit udp 192.168.9.0 0.0.0.255 192.168.1.0 0.0.0.255 range 10000 20000   
access-list 109 permit udp 192.168.9.0 0.0.0.255 192.168.1.0 0.0.0.255 range 5060 5065     
access-list 109 deny   ip 192.168.9.0 0.0.0.255 192.168.1.0 0.0.0.255                      
access-list 109 permit ip 192.168.9.0 0.0.0.255 any                                        
access-list 158 remark ==Red 158 con acceso telefC3nico y bloqueo a red 1==                
access-list 158 permit udp 10.0.158.0 0.0.0.255 192.168.1.0 0.0.0.255 range 10000 20000    
access-list 158 permit udp 10.0.158.0 0.0.0.255 192.168.1.0 0.0.0.255 range 5060 5065      
access-list 158 deny   ip 10.0.158.0 0.0.0.255 192.168.1.0 0.0.0.255                       
access-list 158 permit ip 10.0.158.0 0.0.0.255 any                                         
!                                                                                          
control-plane                                                                              !                                                                                          
mgcp behavior rsip-range tgcp-only                                                         
mgcp behavior comedia-role none                                                            
mgcp behavior comedia-check-media-src disable                                              
mgcp behavior comedia-sdp-force disable                                                    
!                                                                                          
mgcp profile default                                                                       
!                                                                                          
gatekeeper                                                                                 
 shutdown                                                                                  
!                                                                                          
line con 0                                                                                 
line aux 0                                                                                 
line 2                                                                                     
 no activation-character                                                                   
 no exec                                                                                   
 transport preferred none                                                                  
 transport input all                                                                       
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh                             
 stopbits 1                                                                                
line vty 0 4                                                                               
 password 7 0831495E084A5D40405A5E573B2A3E                                                 
 transport input ssh                                                                       
!                                                                                          
scheduler allocate 20000 1000                                                              
!                                                                                          
end   

Cisco Employee

Hola:

Hola:

   La política de QoS está aplicada como input en la interfaz WAN Gi0/0. La configuración de tus clases y access-lists indican que hay que hacer match al tráfico con origen en la red 9 o en la red 158. El tráfico originado por cualquiera de las dos redes jamás va a llegar por la interfaz WAN, es decir, tus access-lists están al revés. Veo que estás listas las usas para tu configuración de NAT, por lo que te sugiero que crees unas nuevas para reflejar exactamente la forma en la que el tráfico va a aparecer de acuerdo a la dirección en la que vas a aplicar la política de calidad de servicio:

Política input en WAN -> El tráfico viene con origen Internet y destino G0/0 (por el NAT).

Política output en WAN -> El tráfico viene con origen LAN y destino Internet.

Política input en LAN -> El tráfico viene con origen LAN y destino Internet.

Política output en LAN -> El tráfico viene con origen Internet y destino LAN (después de NAT).

Community Member

Hola.

Hola.

disculpá pero..... no llego a entender.... yo con la configuración así como está puedo navegar... desde cualquiera de esas dos Lan...

Acaso "access-list 109 permit ip 192.168.9.0 0.0.0.255 any" y su correspondiente en 158, no es justamente quien permite esto???

más

"ip nat inside source list 109 interface GigabitEthernet0/0 overload                        
ip nat inside source list 158 interface GigabitEthernet0/0 overload  "

porque ya te digo puedo navegar.

Y lo otro de las access list es para que unos teléfonos que tengo por ip se conecten al servidor que se encuentra en la red1 (saliendo por la "wan").

La políticas de calidad de servicio (match etc.) lo hice siguiendo tu comentario.

Cómo lo podría solucionar??

Saludos y muchas gracias, disculpá la molestia.

Cisco Employee

Algo que hay que entender, es

Algo que hay que entender, es que las access-lists por sí solas no bloquean o permiten nada. Las listas solo nos permiten seleccionar tráfico que después utilizamos en otras tecnologías. En tu caso, las listas 109 y 158 originalmente se utilizan en la regla de NAT que te permite salir a Internet. En este sentido, para el NAT necesitas establecer que el tráfico originado (source) desde las Vlans 9 y 158 con cierto destino se tienen que traducir a la dirección de la interfaz Gi0/0. Para esta actividad las listas están bien configuradas.

Las listas de acceso en general indican la dirección del flujo del tráfico. Ahí especificas origen y destino del tráfico y es necesario seleccionar el correcto para que la tecnología que quieres usar pueda trabajar de la manera que quieres. Tú estás aplicando otra tecnología, QoS, en la interfaz WAN G0/0 utilizando la dirección de entrada (input) en esa misma interfaz. Tráfico en este sentido del flujo, ¿cómo va a llegar? Va a llegar con un origen en Internet y con destino o bien a las redes LAN o a la dirección utilizada en la regla de NAT (g0/0).

Al usar las mismas listas que tienes en la regla de NAT, estás diciendo que el origen es la LAN y el destino Internet para QoS y este tráfico, como ya comenté en el párrafo anterior, no es el correcto. Si vas a aplicar QoS en la interfaz y dirección que estás especificando (input en WAN), el access-list debe reflejar el tráfico que esperas en esa misma interfaz y dirección (origen en Internet y con destino o bien a las redes LAN o a la dirección utilizada en la regla de NAT).

Como comenté antes, dependiendo de la dirección en la que vayas a utilizar la tecnología de QoS, el tráfico que selecciones con el access-list será diferente también:

Política input en WAN -> El tráfico viene con origen Internet y destino LAN ó G0/0 (por el NAT).

Política output en WAN -> El tráfico viene con origen LAN ó G0/0 y destino Internet.

Política input en LAN -> El tráfico viene con origen LAN y destino Internet.

Política output en LAN -> El tráfico viene con origen Internet y destino LAN.

El access-list que estás usando para QoS en la forma que lo estás aplicando es incorrecta y necesitas crear una nueva que hagan match con las condiciones reales del tráfico en la dirección e interfaz en que aplicas QoS.

178
Visitas
5
ÚTIL
9
Respuestas
CrearPor favor para crear contenido