cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión

Ayuda para router 891-k9 y acceso a internet

Que tal buen dia...

Hace poco se compro un router 891-k9 el cual se le hizo lo siguiente

se le modifico la IP a 192.168.1.0 255.255.255.0

se modifico el dhc exclude 192.168.1.0

se le modifico la puerta de enlace a 192.168.1.1 255.255.255.0

se le modifico la ip de la vlan1 a 192.168.1.1 255.255.255.0

se modifico el access list a la siguente manera:

access-list 23 permit 192.168.1.0 0.0.0.255

al momento de conectarle el ISP a Faste Ethernet no detecta la IP publica, pero si lo conecto al GIGAbit ethernet si le da mas no me deja salir a internet...

ojala que me puedan ayudar. les paso la configuracion que hasta el momento tengo.....

Current configuration : 5389 bytes

!

! Last configuration change at 19:03:49 UTC Tue Feb 25 2014 by RIFRAGA

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-1154262977

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1154262977

revocation-check none

rsakeypair TP-self-signed-1154262977

!

!

crypto pki certificate chain TP-self-signed-1154262977

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31313534 32363239 3737301E 170D3134 30323234 32323135

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31353432

  36323937 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100AD4F 7FE8B058 E296181B 1C870A3B 2B74048E B7BE61C4 0C74A0A8 8641EDA0

  668DB9F6 C091F5DC 944A8EEF F43D2DCE 9E95BB78 831C155C 85A91744 6D206C6C

  405AB8E2 3F645A3D 0210059F ADC2A9C7 D7429A62 DDC12834 A0542292 E64A68BB

  6F83CC47 79521C59 7070248C 6AB8155A 65892827 4193E28D E6809B2A 4413F06F

  A55D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 1414FE22 628CC617 E421D825 0745CDDE 7C0FE641 D8301D06

  03551D0E 04160414 14FE2262 8CC617E4 21D82507 45CDDE7C 0FE641D8 300D0609

  2A864886 F70D0101 05050003 81810008 9B04EFFE BDD7F90C 3CB4EA0C 7F4F6DF0

  8F367AF1 983077F6 01826FB5 04288F72 DB0EDEF4 26B48197 F917D4B6 30B923D0

  C4D7E386 6D087F81 6D293A9E 1EB2889A C820D2A9 BFF04A1D 9CA7B6FC CB7CF9DF

  975ADFE1 11F2CF20 595C2892 20A483AF 03AAB057 8024D849 920075BA 8775D5B9

  E37CE70A B3DA5197 D90A6B92 0DD14D

        quit

ip cef

!

!

!

!

!

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool ccp-pool

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

lease 0 2

!

!

!

no ip domain lookup

ip domain name yourdomain.com

no ipv6 cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

license udi pid CISCO891-K9 sn FTX174383GR

!

!

username ADMIN privilege 15 secret 4 RmRR4BVHa677443kOtQPf8XdEuyEV1ABXKiD.IXTvAX.T

Ik

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

!

interface FastEthernet8

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface Vlan1

description $ETH_LAN$

ip address 192.168.1.1 255.255.255.0

ip tcp adjust-mss 1452

!

interface Async1

no ip address

encapsulation slip

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

access-list 23 permit 192.168.1.0 0.0.0.255

no cdp run

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you

want to use.

-----------------------------------------------------------------------

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE

PUBLICLY-KNOWN CREDENTIALS

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want

to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL

NOT BE ABLE TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

login local

line 1

modem InOut

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

!

end

Bueno encontre esta pagina

http://xyfon.com/tech-tips/configure-internet-access-cisco-891/

y tambien hice las condifuraciones pero tampoco quedo...

Por tal motivo acudo a los expertos de este foro y que me puedan ayudar.

2 SOLUCIONES ACEPTADAS

Soluciones aceptadas
Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Hola Francisco,

Que FastEthernet interface estas tratando de utilizar? Este modelo solo tiene 2 enlaces WAN: FastEthernet8 y GigabitEthernet0. Tienes que seleccionar una de esas interfaces para conectarte a tu proveedor de servicios. Imagino que vas a obtner la IP mediante DHCP entonces una vez te hayas decido que interfaz usar; configura el siguiente comando dentro de dicha interfaz: ip address dhcp.

Con esto configurado, tu router podra obtener su ip mediante DHCP y al mismo tiempo tambien obtendra la informacion de su puerta de salida por defecto. Una vez que el router haya obtenido ip, verifica que tengas conectivdad al exterior haciendo un ping a 4.2.2.2. Si esto fallo, favor brindar las salidas de show ip route y show ip interface brief.

Si la prueba anterior ha funcionado ahora necesitamos realizar una traduccion de ipv4 para tus dispositivos en la LAN. Para ello configura lo siguiente:

ip acccess-list extended NAT_ACL

permit tcp 192.168.1.0 0.0.0.255 any

permit icmp 192.168.1.0 0.0.0.255 any

petmit udp 192.168.1.0 0.0.0.255 any

exit

ip nat inside source list NAT_ACL interface X/X overload

interface vlan 1

ip nat inside

exit

interface X/X

ip nat outside

Donde X/X es la interfaz que has utilizado para la conexion al proveedor de servicios.

Saludos,

Carlos Zeledon


Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Francisco,

Gracias a los comandos pedidos por Ricardo podemos confirmar que el puerto esta siendo bloqueado por el switch porque tiene el mecanismo de seguridad bpduguard habilitado. Este mecanismo va a suspender el puerto en caso que se reciba un BPDU en el puerto donde este configurado dicho mecanismo. El router que tienes conectado a esa interface esta enviando BPDUs y esto esta haciendo que bpduguard se active.

Para solucionar el problema tendras que desactivar ese mecanismo del switch y luego apagar y encender la interfaz.

Saludos,

Carlos Zeledon

12 RESPUESTAS
Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Hola Francisco,

Que FastEthernet interface estas tratando de utilizar? Este modelo solo tiene 2 enlaces WAN: FastEthernet8 y GigabitEthernet0. Tienes que seleccionar una de esas interfaces para conectarte a tu proveedor de servicios. Imagino que vas a obtner la IP mediante DHCP entonces una vez te hayas decido que interfaz usar; configura el siguiente comando dentro de dicha interfaz: ip address dhcp.

Con esto configurado, tu router podra obtener su ip mediante DHCP y al mismo tiempo tambien obtendra la informacion de su puerta de salida por defecto. Una vez que el router haya obtenido ip, verifica que tengas conectivdad al exterior haciendo un ping a 4.2.2.2. Si esto fallo, favor brindar las salidas de show ip route y show ip interface brief.

Si la prueba anterior ha funcionado ahora necesitamos realizar una traduccion de ipv4 para tus dispositivos en la LAN. Para ello configura lo siguiente:

ip acccess-list extended NAT_ACL

permit tcp 192.168.1.0 0.0.0.255 any

permit icmp 192.168.1.0 0.0.0.255 any

petmit udp 192.168.1.0 0.0.0.255 any

exit

ip nat inside source list NAT_ACL interface X/X overload

interface vlan 1

ip nat inside

exit

interface X/X

ip nat outside

Donde X/X es la interfaz que has utilizado para la conexion al proveedor de servicios.

Saludos,

Carlos Zeledon


Re: Ayuda para router 891-k9 y acceso a internet

Gracias, lo checo y aviso la situacion.

Saludos cordiales.

Re: Ayuda para router 891-k9 y acceso a internet

Muchas gracias quedo a la perfeccion... ya tengo internet en la PC y probare en el switch.

Solo tengo otra duda.

Si quiero hacer vlans para segmentar la red.

tengo que usar este comando con cada vlan.

ip nat inside source list NAT_ACL interface X/X overload

interface vlan 1

ip nat inside

exit

Por ejemplo.

Conecto el switch catalyst con tres vlan al router,

Creo las subinterfaces en el puerto X del router para que se puedan comunicar entre si.

configuro cada interfaz VLAN o bien solo el puerto donde se configuraron o como podre hacer eso?

En espera de respuesta, envío un cordial saludo.

Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Hola Francisco,

Mira, si deseas agregar mas subnets a tu red existente lo que tienes que hacer es modificar el ACL para que este permita a las nuevas sub-redes a ser traducidas por la configuracion de NAT que habiamos hecho. Tambien recuerda que las interfaces de 0 a 7 no se pueden partir en sub-interfaces, si deseas pasar trafico de distintas sub-redes y que pueda haber comunicacion entre ellas, tendremos que configurar las interfaces del 891 ya sea como trunk a como access y luego crear los SVI´s en el router.

Ejemplo, ahorita tienes interface vlan 1 configurado con ip en ese router, de momento todos los puertos que van del 0 al 7 estan como acceso a esa vlan. Si deseas agregar otra sub-red, llamemosla vlan 2 con ip 192.168.2.0/24, tenemos 2 opciones:

1) Usamos el mismo puerto que estas usando actualmente para el trafico de vlan 1

o

2) Reservamos otro puerto diferente del que ya estas usando y lo asignamos a vlan 2, sera necesario conectar el switch y el 891 mediante otro link.

Para el paso 1 puedes simplemente cambiar la config del puerto que estes usando, digamos Fa0 y ponemos:

interface fa0

switchport mode trunk

switchport trunk allowed vlan 1,2

exit

Ahora solo tendras que crear el vlan 2 en la base de datos del 891 y luego configuras la interface vlan 2 tal y como lo hiciste con vlan 1. Recuerda cambiar el ip address para que esta este en el mismo dominio broadcast que los clientes conectado al switch en vlan 2.

En el switch tendras que configurar tambien la interface para que sea trunk y no acceso.

interface x/x

switchport trunk encapsulation dot1q *Puede que no necesites este comando, segun del modelo del switch que tengas

switchport mode trunk

switchport trunk allowed vlan 1,2

Para el paso lo unico que tendiras que hacer seria levantar un nuevo enlace fisico entre el 891 y el switch. Configurar la interface del 891 de la siguiente forma:

interface fa0/1

switchport mode access

switchport access vlan 2

exit

Los mismos comandos seran necesario en la interface del switch. Para la parte de NAT, sin importar cual de las 2 opciones anteriores elijas tendras que hacer lo siguiente:

ip access-list extended NAT_ACL

permit tcp X.X.X.X 0.0.0.255 any

permit udp X.X.X.X 0.0.0.255 any

permit icmp X.X.X.X 0.0.0.255 any

Donde X.X.X.X es el ip subnet que vayas a configurar en cada vlan. Si fuera 192.168.2.0/24 entonces reemplaza X.X.X.X por 192.168.2.0 en cada una de las 3 lineas anteriores. Lo mismo si despues agregas otro subnet.

Saludos,

Carlos Zeledon

Re: Ayuda para router 891-k9 y acceso a internet

OOOhhhhh!!!! entonces a este router no lo puedo configurar con el dot1q?

Para poder hacer las subinterfaces por ejemplo interface fa0/1.1 para Vlan 1 y interface fa0/1.2 para VLAN2?

Y por eso me aparece este mensaje cuando trato de poner ip a una interfaz fast ethernet

% IP addresses may not be configured on L2 links.

Un detalle que encontre es que cuando conecto el router al switch catalyst 2960 serie SI y les asigno el puerto como troncal en ambos lados (router y switch) el led del switch se queda en color naranja y no me da acceso a internet.

esta es la connfiguracion que tengo en el switch.

Building configuration...

Current configuration : 5063 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname S1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$$yRK$8RK4oZHg4CSCv.lmlnIkm1

!

!

!

no aaa new-model

system mtu routing 1500

!

!

!

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos

!

crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR

enrollment selfsigned

serial-number

revocation-check none

rsakeypair HTTPS_SS_CERT_KEYPAIR

!

!

crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR

certificate self-signed 01

  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  33310C30 0A060355 04031303 53312E31 23300F06 03550405 13084337 33363141

  38303010 06092A86 4886F70D 01090216 0353312E 301E170D 39333033 30353136

  35363237 5A170D32 30303130 31303030 3030305A 3033310C 300A0603 55040313

  0353312E 3123300F 06035504 05130843 37333631 41383030 1006092A 864886F7

  0D010902 16035331 2E30819F 300D0609 2A864886 F70D0101 01050003 818D0030

  81890281 8100B810 85563F5A FC6B6356 13475CCE 2DDFB8D0 7C726DC5 70E0C13A

  2BD4D9FC B9CE457E 11AB6E96 84878BA9 C48BE263 E720EAD5 6B691031 26165BD1

  BE5C8415 5D4C7030 EFF9E27F D22AA55D 7863BDC8 FCAF47C9 A74BC0B8 242E4833

  003DFB3D 88335253 9D0A1817 46EA11A3 05D256BC 07718463 CF528736 9DAAD037

  FB3968A5 42A50203 010001A3 63306130 0F060355 1D130101 FF040530 030101FF

  300E0603 551D1104 07300582 0353312E 301F0603 551D2304 18301680 14084779

  ED37A424 6B23131E 002A54D2 F4D849FF 6C301D06 03551D0E 04160414 084779ED

  37A4246B 23131E00 2A54D2F4 D849FF6C 300D0609 2A864886 F70D0101 04050003

  8181001B 1CF38F7B EAB7AC6A 3C318693 3F344619 F9E9D578 C1E317AD 53C0CECB

  5504719E 18948D0E 7D25691D A661B2C5 52DB8184 2F76C518 801921B0 73AE158C

  2B31F893 AE020511 0785E432 DED35947 473B9173 9C3562CF 29603F50 D008CC74

  83F63A4D 303F4925 31BA5EBD CC45F0E6 0E648A7D 5015A030 FB9ED656 BAE05B15 9EE983

  quit

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!        

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

switchport mode trunk

mls qos trust cos

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

switchport mode trunk

mls qos trust cos

macro description cisco-router

spanning-tree portfast trunk

spanning-tree bpduguard enable

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

!

interface FastEthernet0/30

!

interface FastEthernet0/31

!

interface FastEthernet0/32

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

!

interface FastEthernet0/48

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.1.4 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.3

ip http server

ip http secure-server

no cdp run

!

line con 0

line vty 0 4

!

password XXXXXX

login

line vty 5 15

password XXXXXX

login

!

mac address-table static 1c6f.65a8.8a91 vlan 1 interface FastEthernet0/23

mac address-table static 082e.5f0c.af83 vlan 1 interface FastEthernet0/12

mac address-table static 0011.3211.81cc vlan 1 interface FastEthernet0/14

mac address-table static c8bc.c8a5.8a53 vlan 1 interface FastEthernet0/2

mac address-table static 0027.0e0e.8ca7 vlan 1 interface FastEthernet0/18

mac address-table static 3c07.541e.63de vlan 1 interface FastEthernet0/3

mac address-table static 109a.dd5b.3j87 vlan 1 interface FastEthernet0/7

mac address-table static 109a.dd5b.15ab vlan 1 interface FastEthernet0/5

mac address-table static 3c07.5425.9c2c vlan 1 interface FastEthernet0/1

mac address-table static c8bc.c89f.e626 vlan 1 interface FastEthernet0/13

mac address-table static 406c.8f1a.47b5 vlan 1 interface FastEthernet0/6

end

Espero me puedan ayudar con esta situacion, estoy adentrandome mas a CISCO y sus comandos porque estan muy interesantes y solo se lo básico.

En espera de respuesta, envío un cordial saludo.

NOTA: los comandos del switch en el puerto 10 y 19 se asignaron desde la web page que trae este switch.

Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Estimado Francisco,

Los primeros 8 puertos son solo de capa 2:

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

En estos puertos no podemos configurar IPs como tú ya mencionaste así que necesitamos usar “interface vlans” o mejor conocidas como “SVI” (Switched Virtual Interfaces) para segmentar tu entorno. En otros enrutadores sí se puede usar el método de sub-interfaces y dot1q pero no en este.

Mencionas que cuando configuras el router y switch como troncal no tienes conectividad y el LED del lado del switch se queda color naranja así que profundicemos un poco más para ver donde puede estar la falla.

Cuando puedas, postea los siguientes comandos:

Enrutador:

sh ip int bri

sh cdp nei

show vlan-switch

sh run

Switch:

sh vlan bri

sh int fas0/x -> interface que conecta al enrutador.

sh cpd nei

sh int trunk

Un saludo a la distancia,

R.T.

Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Hola Francisco,

Agregandole a lo que Rick te explicó, cuanto tiempo esperas despues de que la interfaz se pone en color Ambar? Lo que has observado puede se un proceso esperado por parte de spanning-tree y si te esperas alrededor de 50 segundos la interfaz se deberia volver a poner en verde.

Saludos,

Carlos Zeledon

Re: Ayuda para router 891-k9 y acceso a internet

Router-RIF#show ip int brie

Interface                  IP-Address      OK? Method Status                Prot

ocol

Async1                     unassigned      YES unset  down                  down

FastEthernet0              unassigned      YES unset  down                  down

FastEthernet1              unassigned      YES unset  down                  down

FastEthernet2              unassigned      YES unset  down                  down

FastEthernet3              unassigned      YES unset  down                  down

FastEthernet4              unassigned      YES unset  down                  down

FastEthernet5              unassigned      YES unset  down                  down

FastEthernet6              unassigned      YES unset  down                  down

FastEthernet7              unassigned      YES unset  down                  down

FastEthernet8              unassigned      YES DHCP   down                  down

GigabitEthernet0           unassigned      YES unset  administratively down down

NVI0                       unassigned      NO  unset  up                    up

Vlan1                      192.168.1.1     YES manual down                  down

Router-RIF#show cdp neighbors

% CDP is not enabled

Router-RIF#show vlan-switch

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0, Fa1, Fa2, Fa3, Fa4, Fa5

                                                Fa6, Fa7

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        1002   1003

1002 fddi  101002     1500  -      -      -        -    -        1      1003

1003 tr    101003     1500  1005   0      -        -    srb      1      1002

1004 fdnet 101004     1500  -      -      1        ibm  -        0      0

1005 trnet 101005     1500  -      -      1        ibm  -        0      0

Router-RIF#show run

Building configuration...

Current configuration : 5828 bytes

!

! Last configuration change at 19:42:27 UTC Thu Feb 27 2014 by RIFRAGA

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router-RIF

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-1154262977

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1154262977

revocation-check none

rsakeypair TP-self-signed-1154262977

!

!

crypto pki certificate chain TP-self-signed-1154262977

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31313534 32363239 3737301E 170D3134 30323234 32323135

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31353432

  36323937 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100AD4F 7FE8B058 E296181B 1C870A3B 2B74048E B7BE61C4 0C74A0A8 8641EDA0

  668DB9F6 C091F5DC 944A8EEF F43D2DCE 9E95BB78 831C155C 85A91744 6D206C6C

  405AB8E2 3F645A3D 0210059F ADC2A9C7 D7429A62 DDC12834 A0542292 E64A68BB

  6F83CC47 79521C59 7070248C 6AB8155A 65892827 4193E28D E6809B2A 4413F06F

  A55D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 1414FE22 628CC617 E421D825 0745CDDE 7C0FE641 D8301D06

  03551D0E 04160414 14FE2262 8CC617E4 21D82507 45CDDE7C 0FE641D8 300D0609

  2A864886 F70D0101 05050003 81810008 9B04EFFE BDD7F90C 3CB4EA0C 7F4F6DF0

  8F367AF1 983077F6 01826FB5 04288F72 DB0EDEF4 26B48197 F917D4B6 30B923D0

  C4D7E386 6D087F81 6D293A9E 1EB2889A C820D2A9 BFF04A1D 9CA7B6FC CB7CF9DF

  975ADFE1 11F2CF20 595C2892 20A483AF 03AAB057 8024D849 920075BA 8775D5B9

  E37CE70A B3DA5197 D90A6B92 0DD14D

        quit

ip cef

!

!

!

!

!

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.1.2 192.168.1.20

ip dhcp excluded-address 192.168.1.90 192.168.1.145

!

ip dhcp pool ccp-pool

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

lease 0 2

!

!

!

no ip domain lookup

ip domain name yourdomain.com

no ipv6 cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

license udi pid CISCO891-K9 sn FTX174383GR

!

!

username admin privilege 15 secret 4 RmRR8BKH3436O7QPf8XdEuyEV1ABXKiD.IXTvAX.T

Ik

!

redundancy

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

switchport mode trunk

no ip address

!

interface FastEthernet8

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface Vlan1

description $ETH_LAN$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

interface Async1

no ip address

encapsulation slip

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list NAT_ACL interface FastEthernet8 overload

!

ip access-list extended NAT_ACL

permit tcp 192.168.1.0 0.0.0.255 any

permit icmp 192.168.1.0 0.0.0.255 any

permit udp 192.168.1.0 0.0.0.255 any

!

access-list 23 permit 192.168.1.0 0.0.0.255

no cdp run

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username privilege 15 secret 0

Replace and with the username and password you

want to use.

-----------------------------------------------------------------------

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE

PUBLICLY-KNOWN CREDENTIALS

Here are the Cisco IOS commands.

username   privilege 15 secret 0

no username cisco

Replace and with the username and password you want

to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL

NOT BE ABLE TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

logging synchronous

login local

line 1

modem InOut

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

!

end

SWITCH

S1#show vlan brief

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8

                                                Fa0/9, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16

                                                Fa0/17, Fa0/18, Fa0/20, Fa0/21, Fa0/22, Fa0/23, Fa0/24

                                                Fa0/25, Fa0/26, Fa0/27, Fa0/28, Fa0/29, Fa0/30, Fa0/31

                                                Fa0/32, Fa0/33, Fa0/34, Fa0/35, Fa0/36, Fa0/37, Fa0/38

                                                Fa0/39, Fa0/40, Fa0/41, Fa0/42, Fa0/43, Fa0/44, Fa0/45

                                                Fa0/46, Fa0/47, Fa0/48, Gi0/1, Gi0/2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

S1#show inter fastEthernet 0/37

FastEthernet0/37 is down, line protocol is down (err-disabled)

  Hardware is Fast Ethernet, address is 1ce6.c736.1aa5 (bia 1ce6.c736.1aa5)

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, media type is 10/100BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:15:27, output 00:15:28, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     1 packets input, 64 bytes, 0 no buffer

     Received 1 broadcasts (1 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 1 multicast, 0 pause input

     0 input packets with dribble condition detected

     2 packets output, 128 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

S1#show cdp nei

% CDP is not enabled

S1#show int trunk

Port        Mode             Encapsulation  Status        Native vlan

Fa0/10      on               802.1q         trunking      1

Fa0/19      on               802.1q         trunking      1

Port        Vlans allowed on trunk

Fa0/10      1-4094

Fa0/19      1-4094

Port        Vlans allowed and active in management domain

Fa0/10      1

Fa0/19      1

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/10      1

Fa0/19      1

Ademas de que el switch marca un error en la seccion grafica (adjunto imagen)

En espera de respuesta, envío un cordial saludo.

switch.png

Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Francisco,

Aquí tenemos algo interesante:

FastEthernet0/37 is down, line protocol is down (err-disabled)

Es este el puerto que conecta al enrutador?

Si ese es el caso, postea el siguiente comando del switch para averiguar por que el puerto está en err-disable:

sh interfaces status err-diable

Y muy importante, por favor confirma el puerto en el router que conecta al switch.

Gracias.

Re: Ayuda para router 891-k9 y acceso a internet

Claro, es el puerto que esta conectado al router actualmente.

y esto es lo que me da el comando solicitado:

S1#show interfaces status err-disabled

Port      Name               Status       Reason               Err-disabled Vlans

Fa0/37                       err-disabled bpduguard

En espera de respuesta, envío un cordial saludo.

Cisco Employee

Re: Ayuda para router 891-k9 y acceso a internet

Francisco,

Gracias a los comandos pedidos por Ricardo podemos confirmar que el puerto esta siendo bloqueado por el switch porque tiene el mecanismo de seguridad bpduguard habilitado. Este mecanismo va a suspender el puerto en caso que se reciba un BPDU en el puerto donde este configurado dicho mecanismo. El router que tienes conectado a esa interface esta enviando BPDUs y esto esta haciendo que bpduguard se active.

Para solucionar el problema tendras que desactivar ese mecanismo del switch y luego apagar y encender la interfaz.

Saludos,

Carlos Zeledon

Re: Ayuda para router 891-k9 y acceso a internet

Muchas gracias, a Carlos y a Ricardo por ayudarme, con este problema ya quedo solucionadao ahora vere los de las vlans para ver si me funciona correctamente....

Espero aportar algo lo mas pronto posible a este foro.

Saludos cordiales desde León Guanajuato.

651
Visitas
15
ÚTIL
12
Respuestas