cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión

configurar cisco 891 para balanceo de carga

Buen día.

adquirimos un router cisco 891 y queremos ajustarlo para que tenga los dos provedores ISP.

Para ello quisiera saber como tengo que configurarlo para que al momento de que un proveedor falle el otroentre de inmediato sin perdida de datos o señal?

Desconozco como poder hacerlo por eso requiero de su ayuda.

Etiquetas (5)
2 SOLUCIONES ACEPTADAS

Soluciones aceptadas
Cisco Employee

configurar cisco 891 para balanceo de carga

Hola Francisco,

Lo que estas tratando de hacer se conoce comunmente como redudnancia de internet o bien; "Internet Failover". Para poder hacerlo vamos a tener que configurar las siguientes herramientas:

1) IP SLA

2) Object Track

3) PBR

4) 2 Default static routes, una con una distancia administrativa mas alta que la otra.

Usemos la siguiente topologia como ejemplo:

topology.JPG

La siguiente configuracion sera aplicada en R1 y utilizara a ISP1 como el proveedor primario y a ISP2 como el secundario. Esta configuracion solo hace uso de un ISP a la vez y automaticamente si detecta un fallo a traves del proveedor primario entonces R1 hara uso de ISP2. Cuanto se re-establezca el servicio brindado por ISP1; R1 volvera a usar este proveedor como el primario:

1) ip access-list extended PBR_LCL_ACL

    permit icmp host 192.168.2.1 host 4.2.2.2

    exit

    route-map PBR_LCL_RM

    match ip address PBR_LCL_ACL

    set ip next-hop 192.168.2.254

    exit

    ip local policy route-map PBR_LCL_RM

2) ip sla 10

     icmp-echo 4.2.2.2 source-ip 192.168.2.1

    ip sla schedule 10 life forever start-time now

    track 10 rtr 10

3) ip route 0.0.0.0 0.0.0.0 fa0/0 192.168.2.254 track 10

    ip route 0.0.0.0 0.0.0.0 fa0/1 192.168.1.254 5

He dividido la configuracion anterior en 3 secciones. La primer seccion nos permite asegurarnos que los ICMP request que sean generados por el router para verificar la conectividad hacia 4.2.2.2 se vayan siempre por el ISP1. Hacer esto es importante porque es lo que nos va a permitir confirmar si hay algun problema de conectividad en ISP1 que eventualmente pueda estar afectando nuestros servicios.

La segunda seccion se encarga de configurar el SLA (el feature que nos permite hacer pruebas de conectividad automaticas) y el object track para monitorear el resultado del SLA. Y la tercer y ultima seccion se encarga de agregar la ruta por defecto estatica primary y la que estara "flotando" en la configuracion pero que se hara uso de ella solo si se detectara un fallo a traves del SLA via ISP1.

Espero esto sea de ayuda.

Carlos Zeledon



Cisco Employee

configurar cisco 891 para balanceo de carga

Hola Francisco,

Al tratarse de IP's dinamicas vamos a tener que cambiar un poco la configuracion:

1) Supongamos que es la misma topologia, un solo router conectado a dos ISP diferentes. Aplicamos los siguientes comandos:

!

ip route 4.2.2.2 255.255.255.255 FastEthernet0/0 permanent

ip sla 10

icmp-echo 4.2.2.2 source-interface FastEthernet0/0

ip sla schedule 10 life forever start-time now

!

track 10 rtr 10

track 11 list boolean and

object 10 not

!

interface FastEthernet0/0

ip dhcp client route track 10

ip address dhcp

!

interface FastEthernet0/1

ip dhcp client route track 11

ip address dhcp

Es este ejemplo Fa0/0 es el que conecta a ISP primario y Fa0/1 conecta al secundario. Pudes hacer caso omiso a los comandos que comparti contigo en el post anterior ya que esos solo sirven si tuvieras una IP estatica en las interfaces hacia los ISP.

Saludos,

18 RESPUESTAS
New Member
Cisco Employee

configurar cisco 891 para balanceo de carga

Hola Francisco,

Lo que estas tratando de hacer se conoce comunmente como redudnancia de internet o bien; "Internet Failover". Para poder hacerlo vamos a tener que configurar las siguientes herramientas:

1) IP SLA

2) Object Track

3) PBR

4) 2 Default static routes, una con una distancia administrativa mas alta que la otra.

Usemos la siguiente topologia como ejemplo:

topology.JPG

La siguiente configuracion sera aplicada en R1 y utilizara a ISP1 como el proveedor primario y a ISP2 como el secundario. Esta configuracion solo hace uso de un ISP a la vez y automaticamente si detecta un fallo a traves del proveedor primario entonces R1 hara uso de ISP2. Cuanto se re-establezca el servicio brindado por ISP1; R1 volvera a usar este proveedor como el primario:

1) ip access-list extended PBR_LCL_ACL

    permit icmp host 192.168.2.1 host 4.2.2.2

    exit

    route-map PBR_LCL_RM

    match ip address PBR_LCL_ACL

    set ip next-hop 192.168.2.254

    exit

    ip local policy route-map PBR_LCL_RM

2) ip sla 10

     icmp-echo 4.2.2.2 source-ip 192.168.2.1

    ip sla schedule 10 life forever start-time now

    track 10 rtr 10

3) ip route 0.0.0.0 0.0.0.0 fa0/0 192.168.2.254 track 10

    ip route 0.0.0.0 0.0.0.0 fa0/1 192.168.1.254 5

He dividido la configuracion anterior en 3 secciones. La primer seccion nos permite asegurarnos que los ICMP request que sean generados por el router para verificar la conectividad hacia 4.2.2.2 se vayan siempre por el ISP1. Hacer esto es importante porque es lo que nos va a permitir confirmar si hay algun problema de conectividad en ISP1 que eventualmente pueda estar afectando nuestros servicios.

La segunda seccion se encarga de configurar el SLA (el feature que nos permite hacer pruebas de conectividad automaticas) y el object track para monitorear el resultado del SLA. Y la tercer y ultima seccion se encarga de agregar la ruta por defecto estatica primary y la que estara "flotando" en la configuracion pero que se hara uso de ella solo si se detectara un fallo a traves del SLA via ISP1.

Espero esto sea de ayuda.

Carlos Zeledon



configurar cisco 891 para balanceo de carga

Muy bien, deja lo intento hacer y les comento que paso.

Saludos cordiales.    

Cisco Employee

configurar cisco 891 para balanceo de carga

Excelente ejemplo por parte de Carlos.

Estimado Francisco, como te fué con la configuración?

configurar cisco 891 para balanceo de carga

Que tal rtroyoqu,

Estoy en eso compañero. Ahorita tengo un problema con el switch que no me deja que el router asigne la ip por dhcp, de hecho lo comento en otra discusion.

a ver si me puedes ayudar....

esta es la otra discusion:

https://supportforums.cisco.com/message/4177478#4177478

ya solo me falta eso para comenzar con este paso...

Ya hice y deshice en las configuraciones y no me deja el switch.

configurar cisco 891 para balanceo de carga

Estoy iniciando esta configuracion pero los puertos Gigabit ethernet y el fast ethernet puerto 8 estan configurados para que les de ip por dhcp el ISP, en esta caso como le tengo que hacer aqui, ya que en la topologia aparece que tengo que poner IP 192.168.2.1 ..... .254

Espero haberme explicado jeje, en espera de respuesta, envío un cordial saludo.

Cisco Employee

configurar cisco 891 para balanceo de carga

Hola Francisco.

Esto va a depender completamente en tu ISP. Si ellos te dan IPs dynamicas, entonces está bien que las inferfaces estén configuradas para recibir su IP del ISP. Las IPs que menciona Carlos son de ejemplo y funcionaría con cualquier otra IP.

Te aconsejo que verifiques con tu provedor de servicios (ISP) para ver como deberías de configurar las interfaces.

Saludos,

R.T.

configurar cisco 891 para balanceo de carga

Que tal Ricardo buen día.

Ya me comunique con ellos y me dijeron que la ip es dinamica y que la configuracion de la interfaz ya no es parte de ellos, que su responsabilidad (configuracion, instalacion, etc) llega hasta donde se entrega la Ip Publica dinamica y con salida a Internet.

Con respecto a las IP no me queda muy claro como puedo configurar el router para la salida de internet y hacer el monitoreo, ya que en la configuracion aparece ip fija y en este caso no lo es....

Espero me puedan ayudar....

Saludos cordiales

Cisco Employee

configurar cisco 891 para balanceo de carga

Hola Francisco,

Al tratarse de IP's dinamicas vamos a tener que cambiar un poco la configuracion:

1) Supongamos que es la misma topologia, un solo router conectado a dos ISP diferentes. Aplicamos los siguientes comandos:

!

ip route 4.2.2.2 255.255.255.255 FastEthernet0/0 permanent

ip sla 10

icmp-echo 4.2.2.2 source-interface FastEthernet0/0

ip sla schedule 10 life forever start-time now

!

track 10 rtr 10

track 11 list boolean and

object 10 not

!

interface FastEthernet0/0

ip dhcp client route track 10

ip address dhcp

!

interface FastEthernet0/1

ip dhcp client route track 11

ip address dhcp

Es este ejemplo Fa0/0 es el que conecta a ISP primario y Fa0/1 conecta al secundario. Pudes hacer caso omiso a los comandos que comparti contigo en el post anterior ya que esos solo sirven si tuvieras una IP estatica en las interfaces hacia los ISP.

Saludos,

configurar cisco 891 para balanceo de carga

Gracias Carlos, ya comence la configuracion y al ingresar el primer comando

"ip route 4.2.2.2 255.255.255.255 FastEthernet0/0 permanent"

me aparece este mensaje:

*Mar  4 18:29:59.606: %IPRT-6-STATICROUTESACROSSTOPO: Cannot install inter-topology static route 4.2.2.2/32 topology base on outgoing interface GigabitEthernet

Al investigarlo en internet encontre un caso parecido pero este es con accesos virtuales, pero yo estoy utilizando interfaces fisicas.

este es el link

https://supportforums.cisco.com/docs/DOC-12173

esta es la seccion que encontre con el mismo problema:

Kirill Sulima 07-jun-2012 23:05

Hi everyone!

I have a problem

I've configured webvpn on my router that is behind ASA-firewall (nat, and other features configured correctly)

When I tried to connect to webvpn with anyconnect. User authenticates successfully. But this message appears in debug. And connected client can't see anything except his own IP address

Jun  8 04:57:58.371: %IPRT-6-STATICROUTESACROSSTOPO: Cannot install inter-topology static route 192.168.200.100/32 topology base on outgoing interface Virtual-Access2

Regards,

Kirill Sulima

NOTA: alli el error lo marca en el Virtual-Access2 y no en la interfaz, espero haberme explicado bien jeje....

En espera de respuesta, envio un cordial saludo.

Re: configurar cisco 891 para balanceo de carga

Solo comentar que ya me dejo realizar el punto anterior (solo lo volvi a escribir y ya me dejo hacerlo), pero despues de un rato me vuelve ese mensaje.

Continue con los comandos y ahora me quede en el siguiente:

track 10 rtr 10

ya que no reconoce rtr, al darle track 10 ? me devuelve lo siguiente:

Router-RIF(config)#track 10 ?

  application  Application

  interface    Select an interface to track

  ip           IP protocol

  list         Group objects in a list

  stub-object  Stub tracking object

en este caso que tengo que seleccionar?

En espera de respuesta, envio un cordial saludo    

Cisco Employee

Re: configurar cisco 891 para balanceo de carga

Francisco,

Las interfaces que tienes que usar en tu caso serian la F8 y la Gi0. Esas son las interfaces WAN para tu dispisitivo entonces segun el ejemplo que te di, cambia lo que en el mio dice Fa0/0 por la que vayas a dejar como primaria (sea F8 o Gi0) y tambien cambia la F0/1 por la otra que te quede entre F8 y Gi0. Asi mismo la ruta estatica que te di antes tambien cambia la Fa0/0 por la que sea que vaya a ser usada como conexion primaria (una vez mas entre Fa8 y Gi0)

Con respecto al rtr. Favor usa track 10 ip sla 10.

Saludos,

Carlos Zeledon

Re: configurar cisco 891 para balanceo de carga

Carlos Buen día.

Las configuraciones las hice como me dijiste (cambiando fa 0/0 por Giga0 y fa 0/1 por fa8).

He hice la prueba y no me hizo el cambio de internet.... te paso los datos que me arrojo el router y tambien te pongo los datos del show running-config.

*Mar  6 15:11:15.447: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed state

to up

*Mar  6 15:11:16.447: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0, changed state to up

*Mar  6 15:11:20.615: %DHCP-6-ADDRESS_ASSIGN: Interface GigabitEthernet0 assigne

d DHCP address 189.211.5.34, mask 255.255.252.0, hostname Router-RIF

*Mar  6 15:11:38.471: %TRACKING-5-STATE: 10 ip sla 10 state Down->Up

*Mar  6 15:11:38.471: %TRACKING-5-STATE: 11 list boolean and Up->Down

*Mar  6 15:11:41.931: %LINK-3-UPDOWN: Interface FastEthernet8, changed state to

up

*Mar  6 15:11:42.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et8, changed state to up

*Mar  6 15:11:48.591: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet8 assigned D

HCP address 187.189.10.113, mask 255.255.255.0, hostname Router-RIF

Router-RIF#show ip inter b

Interface                  IP-Address      OK? Method Status                Prot

ocol

Async1                     unassigned      YES unset  down                  down

FastEthernet0              unassigned      YES unset  down                  down

FastEthernet1              unassigned      YES unset  down                  down

FastEthernet2              unassigned      YES unset  down                  down

FastEthernet3              unassigned      YES unset  down                  down

FastEthernet4              unassigned      YES unset  down                  down

FastEthernet5              unassigned      YES unset  down                  down

FastEthernet6              unassigned      YES unset  down                  down

FastEthernet7              unassigned      YES unset  down                  down

FastEthernet8              187.189.10.113  YES DHCP   up                    up

GigabitEthernet0           189.211.5.34    YES DHCP   up                    up

NVI0                       unassigned      YES unset  administratively down down

Vlan1                      192.168.1.1     YES NVRAM  up                  up

Router-RIF#

*Mar  6 15:13:07.623: %LINK-3-UPDOWN: Interface FastEthernet4, changed state to

up

*Mar  6 15:13:08.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et4, changed state to up

*Mar  6 15:13:36.643: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, cha

nged state to up

En estas lines es donde desconecto el acceso a internet.... y me aparece el error que mencione antes...


*Mar  6 15:16:13.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0, changed state to down

*Mar  6 15:16:13.591: %IPRT-6-STATICROUTESACROSSTOPO: Cannot install inter-topol

ogy static route 4.2.2.2/32 topology base on outgoing interface GigabitEthernet0

Router-RIF#

*Mar  6 15:16:38.619: %TRACKING-5-STATE: 10 ip sla 10 state Up->Down

*Mar  6 15:16:38.619: %TRACKING-5-STATE: 11 list boolean and Down->Up

Router-RIF#show ip int br

Interface                  IP-Address      OK? Method Status                Prot

ocol

Async1                     unassigned      YES unset  down                  down

FastEthernet0              unassigned      YES unset  down                  down

FastEthernet1              unassigned      YES unset  down                  down

FastEthernet2              unassigned      YES unset  down                  down

FastEthernet3              unassigned      YES unset  down                  down

FastEthernet4              unassigned      YES unset  up                    up

FastEthernet5              unassigned      YES unset  down                  down

FastEthernet6              unassigned      YES unset  down                  down

FastEthernet7              unassigned      YES unset  down                  down

FastEthernet8              187.189.10.113  YES DHCP   up                    up

GigabitEthernet0           unassigned      YES DHCP   down                  down

NVI0                       unassigned      YES unset  administratively down down

Vlan1                      192.168.1.1     YES NVRAM  up                  up

Esta es la configuracion que tengo en el running-config.

NOTA: Le tuve que cambiar la mac al puerto GIGA0 porque el proveedor de ISP lo solicito para el acceso a internet.

Current configuration : 6210 bytes

!

! Last configuration change at 16:45:01 UTC Wed Mar 5 2014 by RIFRAGA

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router-RIF

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-1154262977

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1154262977

revocation-check none

rsakeypair TP-self-signed-1154262977

!

!

crypto pki certificate chain TP-self-signed-1154262977

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31313534 32363239 3737301E 170D3134 30323234 32323135

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31353432

  36323937 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100AD4F 7FE8B058 E296181B 1C870A3B 2B74048E B7BE61C4 0C74A0A8 8641EDA0

  668DB9F6 C091F5DC 944A8EEF F43D2DCE 9E95BB78 831C155C 85A91744 6D206C6C

  405AB8E2 3F645A3D 0210059F ADC2A9C7 D7429A62 DDC12834 A0542292 E64A68BB

  6F83CC47 79521C59 7070248C 6AB8155A 65892827 4193E28D E6809B2A 4413F06F

  A55D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 1414FE22 628CC617 E421D825 0745CDDE 7C0FE641 D8301D06

  03551D0E 04160414 14FE2262 8CC617E4 21D82507 45CDDE7C 0FE641D8 300D0609

  2A864886 F70D0101 05050003 81810008 9B04EFFE BDD7F90C 3CB4EA0C 7F4F6DF0

  8F367AF1 983077F6 01826FB5 04288F72 DB0EDEF4 26B48197 F917D4B6 30B923D0

  C4D7E386 6D087F81 6D293A9E 1EB2889A C820D2A9 BFF04A1D 9CA7B6FC CB7CF9DF

  975ADFE1 11F2CF20 595C2892 20A483AF 03AAB057 8024D849 920075BA 8775D5B9

  E37CE70A B3DA5197 D90A6B92 0DD14D

        quit

ip cef

!

!

!

!

!

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.1.2 192.168.1.20

ip dhcp excluded-address 192.168.1.90 192.168.1.145

!

ip dhcp pool ccp-pool

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

lease 0 2

!

!

!

no ip domain lookup

ip domain name yourdomain.com

no ipv6 cef

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

license udi pid CISCO891-K9 sn FTX174383GR

!

!

username admin privilege 15 secret 4 RmRR4BVH593pOtQPf8XdEuyEV1ABXKiD.IXTvAX.T

Ik

!

redundancy

track 10 ip sla 10

!

track 11 list boolean and

object 10 not

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

switchport mode trunk

no ip address

interface FastEthernet8

ip dhcp client route track 11

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0

mac-address c8be.195d.486f

ip dhcp client route track 10

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Vlan1

description $ETH_LAN$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

interface Async1

no ip address

encapsulation slip

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list NAT_ACL interface GigabitEthernet0 overload

ip route 4.2.2.2 255.255.255.255 GigabitEthernet0 permanent

!

ip access-list extended NAT_ACL

permit tcp 192.168.1.0 0.0.0.255 any

permit icmp 192.168.1.0 0.0.0.255 any

permit udp 192.168.1.0 0.0.0.255 any

!

ip sla auto discovery

ip sla 10

icmp-echo 4.2.2.2 source-interface GigabitEthernet0

ip sla schedule 10 life forever start-time now

access-list 23 permit 192.168.1.0 0.0.0.255

no cdp run

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

line con 0

logging synchronous

login local

line 1

modem InOut

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

!

end

Ojala me puedan ayudar....

En espera de respuesta, envío un cordial saludo.

Carlos, sabes porque me

Carlos, sabes porque me aparece asi una de las respuestas que me pusiste?

supportforums.cisco.com

y no los comandos donde me explicas que no es balanceo de carga sino IPSLA

Si puedes volver a poner esa respuesta, te lo agradeceria muchisimo.

 

Cisco Employee

Hola Francisco, Podrias

Hola Francisco,

 

Podrias obtener un show ip route antes de hacer el switchover y otro despues? Idealmente cuando Gi0 se apaga, el object track 10 se deberia mostrar abajo y el object track 11 deberia mostrar arriba (hasta ahorita eso se ha podido confirmar en los logs que muestras) cuando el object track 10 se cae, la ruta que antes se aprendia por DHCP mediante Gi0 se deberia remover y al levantarse el object track 11 se deberia tambien agregar la ruta mediante Fa8 (esto lo tendremos que comprobar a traves de los show ip routes que te pedi.)

Adicionalmente, puedo ver que NAT esta solo configurado para el uso de Gi0, tenemos que hacer que la configuracion tambien sea efectiva para Fa8 y al mismo tiempo que si y solo si el trafico sale fuera de esas respectivas interfaces entonces hacer la traduccion a esas IPs. Para eso favor remueve el siguiente comando:

no ip nat inside source list NAT_ACL interface GigabitEthernet0 overload

Agrega lo siguiente:

route-map ISP1

match ip address NAT_ACL

match interface Gi0

exit

route-map ISP2

match ip address NAT_ACL

match interface Fa8

exit

ip nat inside source route-map ISP1 interface Gi0 overload

ip nat inside source route-map ISP2 interface Fa8 overload

 

Cuando hayas configurado eso en tu router y vayas a probar nuevamente si se hace el cambio de un proveedor al otro, tambien obten la salida de comando de show ip nat translation junto con los show ip routes a como te indique anteriormente (antes de apagar la interfaz y luego de haberlas apagado).

 

Saludos,

 

Carlos Zeledon

Buen día Carlos.Si me

Buen día Carlos.

Si me sirvieron los comandos, muchisimas gracias.

Solo tengo dos dudas:

1.- Tarda alrededor de 2 minutos en desconectar el track 10 y levantar el 11, estuve leyendo algo del ipsla y para que el cambio lo haga mas rapido seria con el comando:

frecuency "milisegundos"

ó

timeout "milisegundos".

2.- nosotros configuramos track 10 ip sla 10  y en algunas paginas que habla de ipsla aparece track 10 ip sla 10 reachability o track 10 ip sla 10 state

Cual es la diferencia?

 

Aun asi te paso lo resultados de los comandos que me solicitaste para que los observes.

*Mar 12 15:36:58.195: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed stateto up

Router-RIF#
*Mar 12 15:36:59.195: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed state to up
Router-RIF#
*Mar 12 15:37:06.647: %DHCP-6-ADDRESS_ASSIGN: Interface GigabitEthernet0 assigned DHCP address 188.211.4.7, mask 255.255.252.0, hostname Router-RIF

Router-RIF#
*Mar 12 15:37:36.227: %TRACKING-5-STATE: 10 ip sla 10 reachability Down->Up
*Mar 12 15:37:36.231: %TRACKING-5-STATE: 11 list boolean and Up->Down

*Mar 12 15:29:40.055: %LINK-3-UPDOWN: Interface FastEthernet8, changed state toup
*Mar 12 15:29:41.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern
*Mar 12 15:29:45.175: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet8 assigned DHCP address 187.189.16.113, mask 255.255.255.0, hostname Router-RIFet8, changed state to up

Router-RIF#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 188.211.4.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 188.211.4.1
      4.0.0.0/32 is subnetted, 1 subnets
S        4.2.2.2 is directly connected, GigabitEthernet0
      187.189.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        187.189.16.0/24 is directly connected, FastEthernet8
L        187.189.16.113/32 is directly connected, FastEthernet8
      188.203.0.0/32 is subnetted, 1 subnets
S        187.203.40.20 [254/0] via 187.189.16.1, FastEthernet8
      188.210.0.0/32 is subnetted, 1 subnets
S        188.210.192.1 [254/0] via 189.211.4.1, GigabitEthernet0
      188.211.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        188.211.4.0/22 is directly connected, GigabitEthernet0
L        188.211.4.7/32 is directly connected, GigabitEthernet0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Vlan1
L        192.168.1.1/32 is directly connected, Vlan1


Router-RIF#show ip nat tra
Pro Inside global      Inside local       Outside local      Outside global
tcp 188.211.4.7:49401  192.168.1.26:49401 65.54.238.213:80   65.54.238.213:80
tcp 188.211.4.7:49409  192.168.1.26:49409 74.125.198.95:443  74.125.198.95:443
tcp 188.211.4.7:49411  192.168.1.26:49411 207.249.186.89:443 207.249.186.89:443
tcp 188.211.4.7:49414  192.168.1.26:49414 207.249.186.123:443 207.249.186.123:44
3


Esto es despues de desconectar el ISP 1

Router-RIF#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 187.189.16.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 187.189.16.1
      187.189.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        187.189.16.0/24 is directly connected, FastEthernet8
L        187.189.16.113/32 is directly connected, FastEthernet8
      187.203.0.0/32 is subnetted, 1 subnets
S        187.203.40.20 [254/0] via 187.189.16.1, FastEthernet8
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Vlan1
L        192.168.1.1/32 is directly connected, Vlan1


Router-RIF#show ip nat tra
Pro Inside global      Inside local       Outside local      Outside global
tcp 187.189.16.113:49474 192.168.1.26:49474 199.59.150.46:443 199.59.150.46:443
tcp 187.189.16.113:49476 192.168.1.26:49476 207.249.186.104:443 207.249.186.104:
443
tcp 187.189.16.113:49477 192.168.1.26:49477 74.125.227.107:443 74.125.227.107:44
3
tcp 187.189.16.113:49478 192.168.1.26:49478 99.198.107.26:80 99.198.107.26:80
tcp 187.189.16.113:49479 192.168.1.26:49479 99.198.107.26:80 99.198.107.26:80
tcp 187.189.16.113:49480 192.168.1.26:49480 66.171.224.89:80 66.171.224.89:80
tcp 187.189.16.113:49481 192.168.1.26:49481 74.125.227.128:80 74.125.227.128:80
tcp 187.189.16.113:49482 192.168.1.26:49482 199.187.193.130:80 199.187.193.130:80

En espera de respuesta, envío un cordial saludo,

 

P.D. Esta discusion la convertire a documento para tenerlo todo ya ordenado y para que otras personas que lo necesiten ya lo encuentren organizado y listo para programar.

Cisco Employee

Por cierto, ya se arreglo el

Por cierto, ya se arreglo el problema con el post original.

Saludos,

Carlos Zeledon

Cisco Employee

Hola Francisco, Favor hazme

Hola Francisco,

 

Favor hazme saber si te sirvio de ayuda la ultima configuracion que te mande incluyendo route-maps en los comandos de NAT.

 

Saludos,

 

Carlos Zeledon

3925
Visitas
10
ÚTIL
18
Respuestas