Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Dudas con VLan

Hola a todos.

Este es mi primer post y no estoy seguro si va aqui.

Antes que nada debo reconocer que mis conocimientos sobre switches Cisco es muy pobre y tambien sobre las VLAN.

Tengo un Switch SG500 que actua como Core y varios SG300 que son de acceso (no tengo la capa de distribuciòn).

Tengo que armar una vlan entre dos edificios pero que no se comuniquen entre si, es decir, no se necesita enrutamiento entre ellas.

En el Switch SG500 he creado una vlan con estos datos:

Vlan ID: 2

Nombre: vlpersonal

Puertos: 25,26 (modo access)

Puerto Trunk: 4 (allowed vlan all)

En el Switch SG300 he creado tambien una vlan con estos datos:

Vlan ID: 2

Nomrbe: vlpersonal

Puertos: 1 al 5 (mode access)

Puerto trunk: 50 (allowed vlan all)

Para probar puse un pc en conectado a cada switch por un puerto de la vlan 1 (default) y el resultado es que se comunican sin problemas.

Luego conecte ambas PC en cada switch por un puerto de la vlan 2, pero no hay comunicación.

Y hasta ahi llego mis conocimientos

Si alguien tiene alguna sugerencia sera bienvenida.

10 RESPUESTAS
New Member

Dudas con VLan

Hola Carlos si pudieras compartirnos la configuración de los equipos seria mas fácil, la vlan 1 por defecto esta configurado por lo cual no tienes problemas, puedes hacer una cosa para comprobar fácilmente donde esta el problema, si pone dos maquinas en la misma vlan (recuerda misma subnet) en el mismo switch y tienes comunicación a nivel del switch esta bien la configuración de la vlan si no es un problema de la creación de la vlan a nivel local, si pruebas ambos y funcionan bien localmente significa que el problema es el trunk, recuerda que aparte de permitir el allowed vlan all también se debe colocar en mode trunk el puerto.

Me comentas tu verificación y si es posible que nos compartas la configuración.

Saludos,

New Member

Dudas con VLan

Hola Victor.

Apenas llegue a la oficina, voy a colocar la configuracion de los swithes.

En cuanto a la prueba q mencionas, fue lo primero q hicimos y funciona, es decir, dos pc conectados a la misma vlan en el mismo. switch, se comunican.

En cuanto al puerto trunk, la secuencia de comandos fueron:

conf t

interface ge 1/1/4

switchport mode trunk

switchport trunk allowed vlan add all

end

wr

Esto lo hicimos en ambos switch. Por supuesto q la confg fue guardada.

New Member

Dudas con VLan

Gracias Carlos tambien seria idela que nos puedas compartir los siguientes comandos para evaluar si todo esta bien:

show vlan

show interfaces switchport gi x/x/x (para los puertos que usas)

Saludos,

New Member

Dudas con VLan

Hola Victor.

Aquid estan las salidas de los comandos

SG500
switch8ea9e5#show vlan

Vlan       Name                   Ports                Type     Authorization
---- ----------------- --------------------------- ------------ -------------
1           1         gi1/1/1-24,gi1/1/27-48,       Default      Required
                       te1/1/1-4,gi2/1/1-48,
                       te2/1/1-4,gi3/1/1-48,
                       te3/1/1-4,gi4/1/1-48,
                       te4/1/1-4,Po1-8
2      vlpersonal         gi1/1/4,gi1/1/25-26        static      Required

switch8ea9e5#show interfaces switchport GigabitEthernet 1/1/4
Port : gi1/1/4
Port Mode: Trunk
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 1

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
1                  1                  Untagged          System
2              vlpersonal              Tagged           Static


Forbidden VLANS:
Vlan               Name
---- --------------------------------


Classification rules:

Protocol based VLANs:
  Group ID   Vlan ID
------------ -------


Mac based VLANs:
  Group ID   Vlan ID
------------ -------


SG300
DI-SWS4BE#show vlan

Vlan       Name                   Ports                Type     Authorization
---- ----------------- --------------------------- ------------ -------------
1           1                gi7-52,Po1-8           Default      Required
2     vlanPersonal            gi1-6,gi50             static      Required

DI-SWS4BE#show interfaces switchport GigabitEthernet 50
Port : gi50
Port Mode: Trunk
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 1

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------
1                  1                  Untagged          System
2             vlanPersonal             Tagged           Static


Forbidden VLANS:
Vlan               Name
---- --------------------------------


Classification rules:

Mac based VLANs:
  Group ID   Vlan ID
------------ -------

New Member

Dudas con VLan

Hola de nuevo.

Ya estoy en la oficina y esta es la configuración del ambos switches, es el resultado del show run-config

Switch SG300---------------------------------------------------

DI-SWS4BE#show running-config
config-file-header
DI-SWS4BE
v1.2.7.76 / R750_NIK_1_2_584_002
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 2
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
hostname DI-SWS4BE
username ciriondo password encrypted 453d539d8baa5d3f2d56547e27b61d44e04db7f4 privilege 15
username cisco password encrypted d18d61a5566c2d9bee36ed2900ad918a440ff1ce privilege 15
ip ssh server
snmp-server location "BE-Sala 4 RPyTV"
snmp-server contact netadmin@pol.una.py
security-suite enable
security-suite dos protect add stacheldraht
security-suite dos protect add invasor-trojan
security-suite dos protect add back-orifice-trojan
!
interface vlan 1
ip address 10.13.90.5 255.255.0.0
no ip address dhcp
!
interface vlan 2
name vlanPersonal
!
interface gigabitethernet1
switchport mode access
switchport access vlan 2
switchport general pvid 2
!
interface gigabitethernet2
switchport mode access
switchport access vlan 2
switchport general pvid 2
!
interface gigabitethernet3
switchport mode access
switchport access vlan 2
switchport general pvid 2
!
interface gigabitethernet4
switchport mode access
switchport access vlan 2
switchport general pvid 2
!
interface gigabitethernet5
switchport mode access
switchport access vlan 2
switchport general pvid 2
!
interface gigabitethernet6
switchport mode access
switchport access vlan 2
!
interface gigabitethernet50
switchport trunk allowed vlan add 2
!


Switch SG500-------------------------------------------------

switch8ea9e5#show running-config
config-file-header
switch8ea9e5
v1.2.7.76 / R750_NIK_1_2_584_002
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 2
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname switch8ea9e5
logging host 10.13.100.210 severity notifications
username cisco password encrypted e3006d91f3596d4d2ac5e981faafe488fdaa51fc privilege 15
ip ssh server
snmp-server location DI-SWMAIN
snmp-server contact netadmin@pol.una.py
security-suite enable
security-suite dos protect add stacheldraht
security-suite dos protect add invasor-trojan
security-suite dos protect add back-orifice-trojan
!
interface vlan 1
ip address 10.13.90.1 255.255.0.0
no ip address dhcp
!
interface vlan 2
name vlpersonal
!
interface gigabitethernet1/1/4
switchport trunk allowed vlan add 2
!
interface gigabitethernet1/1/25
switchport mode access
switchport access vlan 2
switchport general pvid 2
!
interface gigabitethernet1/1/26
switchport mode access
switchport access vlan 2
!

Lo que a mi me llama la atención son básicamente dos cosas:

1) Por defecto todos los puertos aparecen como Trunk Admit all y Enable. Despues de crear la vlan 2, asignar los puertos, ponerlos en modo access, los puertos de la vlan 1 siguen como "Trunk". Ahi está mi duda, porque por lo que entiendo el puerto 4 ya está en modo Trunk y admite todo...Es normal?

2) Al realizar el comando sobre el puerto que se utilizará como Trunk "switchport trunk allowed vlan add all", en el listado figuran que solo fue adicionado la vlan 2, y la vlan1? porque no aparece?, es normal.

Gracias por cualquier ayuda...

Saludos cordiales

New Member

Dudas con VLan

Carlos respondiendo rapidamente a tus preguntas, lo que sucede con la vlan 1 en los troncales es que esta es utilizada por defecto como vlan nativa que tiene trafico de control y que basicamente no utiliza etiqueta a diferencia de las otras que agregues, la configuracion parece estar bien solo tengo la duda si entre SG300 existe la comunicación hacia otro switch que pudiera ser un problema de bloqueo de STP.

New Member

Dudas con VLan

Pues no, entre el SG500 y el SG300 la comunicación es por FO, en cada extremo hay un conversor de FO/UTP.

Para aclarar un poco el panorama la estructura es basicamente la siguiente:

Te adjunto un pequeño grafico de como es la red.

Cada edifcio tiene un Switch que se conecta al principal por FO por medio de conversores FO/UTP, dentro de cada edificio se distribuye la señal a los PC's y en algunos casos a otro switch.

Que piensas que podria estar interfiriendo si la configuracion esta bien?

Saludos cordiales

New Member

Dudas con VLan

Estoy confudido...He hecho algunas pruebas y al final no si es el enlace de FO el culpable o que esta pasando.

Para verificar traje a la oficina 2 switches SG300 para una prueba de laboratorio.

Primera prueba.

Configure de la misma forma en como se muestra en el listado de mas arriba. Los conecté por el puerto trunk.

Conecte dos PC a la vlan 2 de cada switch y funcionó sin problemas.

Conecte las dos PC a la vlan 2 de uno de los switches y viceversa, en ambos casos funciona.

Segunda prueba.

Fui hasta la sala de comunicaciones y conecte el puerto Trunk del SG500 (port 4) al switch SG300 que utilice en el laboratorio en el puerto trunk (port 50) utilizando un cables utp cat 6.

Conecte una PC al SG500 a la vlan 2 y otra PC a la vlan 2 en el SG300. Resultado...funcionaaa

En el SG500 conecte ambos PC a la vlan 2 y funciona

En el SG300 conecte ambos PC a la vlan 2 y funciona

Tercera prueba.

Nuevamente lleve el SG300 al edificio con el que tengo problemas...

Conecte el cable del Conversor al puerto Trunk (port 50).

Conecte la PC a la vlan 2

Fui hasta la sala de comunicaciones y en el SG500 conecte el otro extremo del enlace al puerto trunk (port 4) y luego una PC a un puerto de la vlan 2.

Resultado :-(((( no funciona

Pero si conecto ambos PC de cada switch por la Vlan 1...SI Funciona...

No se si se entendió lo que hice ...pero el tema es que cuando estan conectados al enlace de FO, solo la vlan 1 funciona, pero si conecto ambos switches por cable UTP funcionan ambas vlan (1 y 2)...

Me tiene loco...no se que hacer...obviamente no puedo cambiar el enlace de FO ni los conversores (no tengo repuesto)..

Pero dudo que los conversores tengan la culpa...porque una vlan si y otra no...

Si alguien tuvo algun problema similar...

New Member

Dudas con VLan

Al final esta solucionado el tema.

No era culpa de la configuración ni de los switches.

Resulta q estaba utilizando el enlace equivocado

El conversor estaba mal identificado, alguien se equivoco de etiqueta.

Por culpa de eso estuve coml loco 2 dias.

Muchisimas gracias Victor y perdon por el tiempo q te he hecho perder.

Ahora tendre q verificar todas la identficaciones de los cables.

Saludos cordiales ...

New Member

Dudas con VLan

Es un gusto Carlos que bien que todo te funciono correctamente.

Saludos,

1104
Visitas
0
ÚTIL
10
Respuestas