Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

FailOver y topologia problema

Buenos dias,

tengo un problema ya que debo de configurar un router cisco 881-4g de una forma determinada con failover incluido.

 

La topología es la siguiente..

 

                               ISP 1 >  Cisco 800 -> Cisco 881-4G (with SIM, ISP2) -> LAN

 

Se que es un poco rara dado los 2 routers pero es que el Cisco 800 no puedo quitarlo y debe estar ahi entre medias.

 

Cisco 800 tiene una red 192.168.1.1 255.255.0.0 que debe ser identica que el 881-4G por lo que el 881 deberia trabajar como un "Switch" pero con failover.

He realizado el siguiente código pero me gustaría saber si estoy en lo cierto o no.

 

el gateway de todo la Lan es 192.168.1.1 y no me gustaria cambiarla  por lo que algo tendría que hacer para mantenerla.

Puede alguien ayudarme??

Gracias.

cellular 0 lte profile create 1 internet.vodafone.pt chap vodafone vodafone ipv4
config t
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
line 3
script dialer lte
exit


flow record nbar-appmon
match ipv4 source address
match ipv4 destination address
match application name
collect interface output
collect counter bytes
collect counter packets
collect timestamp absolute first
collect timestamp absolute last
exit
!
!
flow monitor application-mon
cache timeout active 60
record nbar-appmon
exit

interface Vlan 1
!
description vlan1
!
ip address 192.168.1.254 255.255.0.0
!
no shutdown
!
ip nat inside
!
ip nat enable
!
end
!
config t
!
interface cell0
!
ip address negotiate
!
encap slip
!
dialer in-band
!
dialer-group 1
!
ip nat outside
!
no shutdown
!
exit
!
dialer-list 1 protocol ip permit
!
interface fastethernet 4
!
description
!

no ip address
!
ip dhcp client route track 22
!
ip address dhcp
!
ip flow ingress
!
no shutdown
!
ip nat outside
!
ip nat enable
!
exit
!
interface FastEthernet 0
!
switchport mode access
!
switchport access Vlan 1
!
no shutdown
!
exit
!
interface FastEthernet 1
!
switchport mode access
!
switchport access Vlan 1
!

no shutdown
!
exit
!
interface FastEthernet 2
!
switchport mode access
!
switchport access Vlan 1
!
no shutdown
!
exit
!
interface FastEthernet 3
!
switchport mode access
!
switchport access Vlan 1
!
no shutdown
!
exit
!
ip access-list extended NAT
!
permit ip 192.168.0.0 0.0.255.255 any
!
exit
!


!


access-list 101 permit ip 192.168.0.0 0.0.255.255 any
no access-list 1 permit 10.10.10.0 0.0.0.7
no access-list 23 permit 10.10.10.0 0.0.0.7
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 23 permit 192.168.0.0 0.0.255.255


!
ip nat inside source list 101 interface fa04 overload
!
ip nat inside source list NAT interface cell0 overload
!
ip nat inside source static tcp 192.168.1.200 80 192.168.1.1 80 extendable
ip nat inside source static tcp 192.168.0.171 554 192.168.1.1 80 554 extendable
ip nat inside source static tcp 192.168.0.172 1024 192.168.1.1 80 1024 extendable
ip nat inside source static tcp 192.168.0.173 1025 192.168.1.1 80 1025 extendable
ip nat inside source static tcp 192.168.0.171 2080 192.168.1.1 80 2080 extendable


end
!
config t
!

ip routing
ip route 4.2.2.2 255.255.255.255 DHCP
ip sla 33
icmp-echo 4.2.2.2 source-interface FastEthernet4
threshold 500
timeout 1000
frequency 3
exit
ip sla schedule 33 life forever start-time now
track 22 ip sla 33 reachability
delay down 3 up 1
exit

ip dhcp-client default-router distance 200
ip route 0.0.0.0 0.0.0.0 cell0 201
!

ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool cvo-pool
import all
network 192.168.1.1 255.255.0.0
default-router 192.168.1.1
dns-server 8.8.4.4
lease 0 2
!
end
!

48
Visitas
0
ÚTIL
0
Respuestas