cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

ip next-hop Route-map

Hola.

estoy realizando un load-sharing para equilibrar la carga en dos enlaces punto a punto, el problema es que al fallar el que tiene el route-map este no es capaz de enrutar al proximo.  Si me pudierana yudar aqui dejo la configuración:

 

interface GigabitEthernet0/0

 description LAN
 ip address 10.21.10.1 255.255.255.0
 ip access-group PERMIT-CCS-INTERNET in
 ip flow ingress
 ip flow egress
 ip policy route-map QoS-Bronce
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description MPLS_MOVISTAR
 ip address 192.168.10.45 255.255.255.252
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description CONEXION METROETHERNET
 no ip address
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
!
interface GigabitEthernet0/2.701
 encapsulation dot1Q 701
 ip address 192.168.14.49 255.255.255.0
 ip flow ingress
 ip flow egress
!
!
router eigrp 100
 network 10.21.10.0 0.0.0.255
 network 192.168.10.44 0.0.0.3
!

ip route 0.0.0.0 0.0.0.0 192.168.14.5 200
!
ip access-list extended Bronce
 
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.2
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.3
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.6
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.89
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.43
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.44
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.45
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.51
 permit ip 10.21.10.0 0.0.0.255 host 10.5.11.12
 permit ip 10.21.10.0 0.0.0.255 host 10.10.23.37
ip access-list extended MONITOR
 permit icmp any host 192.168.4.37 echo
ip access-list extended PERMIT-CCS-INTERNET
 permit ip any 10.21.10.0 0.0.0.255
 permit ip any 10.10.31.0 0.0.0.255
 permit ip any 10.10.24.0 0.0.0.255
 permit ip any 10.10.28.0 0.0.0.255
 permit ip any 10.10.23.0 0.0.0.255
 permit ip any 10.10.25.0 0.0.0.255
 permit ip any 10.5.10.0 0.0.0.255
 permit ip any 10.5.11.0 0.0.0.255
 deny   ip any 10.0.0.0 0.255.255.255
 permit ip any any
!
!

!
route-map QoS-Bronce permit 5
 match ip address Bronce
 set ip next-hop 192.168.14.5
!         
!
-------------------

 

Como veran el trafico de bronce es direccionado al enlace d ela g0/2, pero en caso de falla no se como enrutarlo al G0/1 automaticamente.

 

3 RESPUESTAS

Hola,

Hola,

se puede combinar PBR con EOT (Enhanced Object Tracking), por ejemplo:


ip sla monitor 1
 type echo protocol ipIcmpEcho 192.168.14.5
exit

ip sla monitor schedule 1 life forever start-time now

track 2 rtr 1 reachability
 delay down 60 up 60
exit

route-map QoS-Bronce permit 5
 match ip address Bronce
 set ip next-hop verify-availability 192.168.14.5 10 track 2
!


(Depende del Router/IOS, los comandos para IP SLA pueden variar un poco.)

Link: http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_pi/command/iri-cr-book/iri-cr-s1.html#wp8093935770

 

Saludos

Rolf

New Member

Rolf

Rolf

El problema de esta configuración es que el IOS no lo soporta.

 

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M2, RELEASE SOFTWARE (fc2).

Eh visto el comando

set ip next-hop verify-availability

 es valida hasta esta sentencia, pero no se cual es el alcanse de esta sentencia, de igual forma la aplique y no es capaz de conmutar automaticamente.

 

 

 

 

Cisco Employee

Hola Frank  Si tu router 2900

Hola Frank 

 

Si tu router 2900 no soporta la configuracion de ip sla, es necesario hacer upgrade la licencia a "data". Hasta el final del show version viene el nivel de la licencia. Puedes habilitar la licensia de prueba con el siguiente comando:

 

(config)#license boot module c2900 technology-package ?
  datak9          data technology
  securityk9_npe  security technology
  uck9            unified communications technology

Guardar la configuracion y reiniciar el equipo. Sin embargo la licensia solamente sera valida por 60 dias. 

Saludos

Gabriel

167
Visitas
0
ÚTIL
3
Respuestas
CrearPor favor para crear contenido