cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

NAT estático para servidor WEB

Hola a todos.

Esta es mi primera consulta y tiene que ver con NAT ESTÁTICO. En el primer caso tengo un enlace de F.O. con algo similar a esto y para acceder a un servidor por el puerto 8080 acceso sin ningún problema.

interface Loopback0
 ip address 186.x.x.x 255.255.255.255
interface FastEthernet4
 description Enlace Datos 
 ip address 172.16.x.x 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 duplex full
 speed 100
interface Vlan1
description Lan 
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip nat inside source list 1 interface Loopback0 overload
ip nat inside source static tcp 192.168.1.3 8080 186.x.x.x 8080 extendable
ip route 0.0.0.0 0.0.0.0 172.16.x.x
access-list 1 permit 192.168.1.0 0.0.0.255

el problema radica en este segundo caso en donde es similar pero no logro acceder a ningún puerto 80. La única diferencia con el primer caso es que este segundo enlace tiene mas IP PUBLICAS por lo que la LOOPBACK 0 tiene otra IP PUBLICA. Otra cosa que debo mencionar es que el trafico de la RED 192.168.10.0 no tiene ningún problema en navegar por Internet por la IP de la LOOPBACK 1. 

Por ultimo en este caso no se configuraron VLAN pero aun así no creo que tenga que ver en el caso.

interface Loopback1
 ip address 187.x.x.x 255.255.255.255
interface FastEthernet4
 description Enlace Datos 
 ip address 172.17.x.x 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 duplex full
 speed 100
interface fastethernet 1
description Lan 
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly

ip nat inside source list 1 interface Loopback1 overload
ip nat inside source static tcp 192.168.10.3 80 187.x.x.x 80 extendable
ip route 0.0.0.0 0.0.0.0 172.17.x.x

access-list 1 standar
permit 192.168.10.0 0.0.0.255

si alguien puede ayudar estaré muy agradecido.

Etiquetas (1)
1 RESPUESTA
Cisco Employee

Ya ha pasado tiempo de esta

Ya ha pasado tiempo de esta pregunta, pero espero que todavía te sirva la información. Tu configuración de NAT es correcta, además de esto tienes habilitada la opción "extendable" para tu NAT estático por lo que nos da la ventaja de poder checar dinámicamente si la traducción se está efectuando o no. Intenta conectarte a la IP pública en puerto 80, puedes hacer incluso un simple telnet en puerto 80. Es muy importante que esta prueba de conexión la hagas desde una IP en Internet, el router Cisco no soporta una conexión desde la LAN hacia la IP pública. Si no obtienes respuesta revisa el siguiente comando en el equipo:

show ip nat translations

Deberías poder ver la IP con la que intentaste conectarte en las columnas que indican "outside local" y "outside global". Si no ves tu IP bajo estos rubros, significa que tu tráfico ni siquiera está llegando al router y es un problema de ruteo posiblemente con el ISP. Si ves tu IP, hay un problema de ruteo interno y habría que sacar debugs de NAT para confirmar si el router está mandando el tráfico hacia tu LAN de manera correcta. Aquí hay un link que muestra cómo hacer esto último:

http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/8605-13.html

En mi experiencia, cuando el NAT estático no funciona y el debug muestra que el equipo está traduciendo, generalmente es un problema con el default gateway del servidor que no está apuntando al router que hace NAT.

265
Visitas
5
ÚTIL
1
Respuestas