cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Native VLAN mismatch discovered on FastEthernet0/11

Hola Estimados

Por favor me podrian guiar sobre estos mensajes q obtengo en un switch  cisco WS-C3524-XL

SW1POP26#show logging
Syslog logging: enabled (0 messages dropped, 101 flushes, 0 overruns)
    Console logging: level debugging, 19464 messages logged
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 9729 messages logged
    File logging: disabled
    Trap logging: level informational, 9733 message lines logged

Log Buffer (4096 bytes):
ered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).
3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).

                 

Este switch esta conectado a otro switch a traves de un radio enlace.

Etiquetas (2)
1 SOLUCIÓN ACEPTADA

Soluciones aceptadas

Re: Native VLAN mismatch discovered on FastEthernet0/11

Hola Fernando,

El log que estas recibiendo es debido a que ambos lados del enlace trunk estan utilizando una vlan nativa diferente, como sabes a partir de 802.Q va a existir la posibilidad de no taggear cierto trafico con un identificador de vlan, este trafico es el de la vlan nativa. Por ende debe ser configurado de igual manera en ambos lados del enlace

Como arreglarlo

Vas a cada switch, te metes a la interface que conlleva al otro switch mediante el enlace trunk y seteas la vlan para que ambos la tengan de igual manera

          -Interface fastethernet 0/11

          -switchport trunk native vlan 20

          -Interface fastethernet 0/9

          -switchport trunk native vlan 30

Saludos

Julio

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
4 RESPUESTAS

Re: Native VLAN mismatch discovered on FastEthernet0/11

Hola Fernando,

El log que estas recibiendo es debido a que ambos lados del enlace trunk estan utilizando una vlan nativa diferente, como sabes a partir de 802.Q va a existir la posibilidad de no taggear cierto trafico con un identificador de vlan, este trafico es el de la vlan nativa. Por ende debe ser configurado de igual manera en ambos lados del enlace

Como arreglarlo

Vas a cada switch, te metes a la interface que conlleva al otro switch mediante el enlace trunk y seteas la vlan para que ambos la tengan de igual manera

          -Interface fastethernet 0/11

          -switchport trunk native vlan 20

          -Interface fastethernet 0/9

          -switchport trunk native vlan 30

Saludos

Julio

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

Re: Native VLAN mismatch discovered on FastEthernet0/11

Hola Julio, gracias por responder.

El tema es q no estan unidos por un trunk los dos switch.

Esta asi

sw1 (port 0/1 vlan20) -------- Radio enlace -------- (port 0/5 vlan 103) sw2 ---------INTERNET

En el sw2 no obtengo esos logs, solo en el sw1

El tráfico q entra por el port1(v20) del sw1, lo saco por el port9 (v20) y lo vuelvo a meter (previo equipo q hace qos en modo bridge) por el port11(v30). Luego sale por el port2(v30) hacia los clientes finales.

Slds.

Re: Native VLAN mismatch discovered on FastEthernet0/11

Hola Fernando,

Disculpa, no entendi tu descripcion

"

El tráfico q entra por el port1(v20) del sw1, lo saco por el port9 (v20) y lo vuelvo a meter (previo equipo q hace qos en modo bridge) por el port11(v30). Luego sale por el port2(v30) hacia los clientes finales"

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

Native VLAN mismatch discovered on FastEthernet0/11

Hola Fernando

Espero te encuentres bien.

Analisando la informacion que proporcionas entiendo lo siguiente.

-El trafico de VLAN20 entra al puerto 1 y va por el puerto 9 al dispositivo que hace QOS, todo esto en VLAN20

-El trafico lo regresas al mismo SW en puerto 11 pero ya es VLAN30 de ahi fluye y sale por el puerto 2.

-El mensaje de log indica lo esperado :

3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/9 (20), with SW1POP26 FastEthernet0/11 (30).

3d10h: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/11 (30), with SW1POP26 FastEthernet0/9 (20).

El [SW1POP26] se "conoce a el mismo" ya que esta Interconectado entre puerto 9 y 11 con el dispositivo de QOS de por medio.

Pero al estar estos dos puertos (Fa0/9 y Fa0/11) en VLAN distintas, es por eso que te aparece el mensaje de LOG

Quiero suponer que esto no te representa ningun impacto en el performance de tu red, pero si deseas que el mensaje no aparezca mas, basta con deshabilitar CDP en ambos puertos, tanto Fa0/9 como Fa0/11

interface Fa0/9

no cdp enable

interface Fa0/11

no cdp enable

Espero sea de tu ayuda mi informacion.

Saludos!

Carlos Tapia.

12575
Visitas
0
ÚTIL
4
Respuestas