cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

no tengo hace a internet cuando estoy dentro de la vlan switch sg300

buenas

tengo problemas para darle haceso a internet a unas vlan, tengo un switch sg 300 layer 3 (capa3) esta es la configuracion que estoy haciendo

Switch#configure terminalEnter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface Vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z. Switch(config)#interface Vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown
configure la interface 1 para que tuviera haceso al router
Switch(config)#interface GigabitEthernet 1
Switch(config-if)#no switchport access vlan
Switch(config-if)#ip address 192.168.80.100 255.255.255.0 <- ip que da el router Switch(config-if)#no shutdown

Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.80.1 <- ip del router
como le pongo internet a las vlan 


les agradesco la ayudaa

  • Routing & Switching
7 RESPUESTAS

no tengo hace a internet cuando estoy dentro de la vlan switch s

Buena Nefer,

Entiendo que tienes 2 SVIs (Vlan 10 y Vlan 20).

Aparte de eso tienes un Routed port.

Pero al parecer no tienes internet en las VLANs.

Acá estan mis preguntas?

  • Sabe tu router como llegar a vlan 10 y 20?
  • Estas realizando NAT en el router para las Vlans 10 y 20?

Saludos

Registrate en mi sitio web para informacion semanal de networking en  http://laguiadelnetworking.com


Any question contact me at jcarvaja@laguiadelnetworking.com

Cheers,

Julio Carvajal Segura

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com

no tengo hace a internet cuando estoy dentro de la vlan switch s

Hola Nefer,

te recomendaria que hicieras la siguiente prueba:

Crea una nueva vlan (vlan 30):

interface Vlan 30
ip address 192.168.80.100 255.255.255.0

no shutdown

En la interfaz quita la direccion IP y hazla de nivel 2:

Switch(config)#interface GigabitEthernet 1
Switch(config-if)#switchport
Switch(config-if)#switchport access vlan 30

Hasta aqui tienes habilitado el routing entre las vlans 10, 20 y 30 (acceso a Internet): solo routing, no acceso a Internet ya que te faltan, por ejemplo los DNS.

El router de Internet hace NAT sobre la direccion 192.168.80.0/24 hacia la publica, y las direcciones de las vlans 10y 20, me imagino que no las conoce.

Habilita el NAT en el switch L3 para las direcciones 192.168.10/0/24 y 192.168.20.0/24 sobre la direccion (192.168.80.0/24).

En el caso que tengas acceso al router, y sea configurable...configura el NAT en el router y no en el switch.

Un saludo.

New Member

no tengo hace a internet cuando estoy dentro de la vlan switch s

Buenas gracias por responder

es que no tengo acceso al ruter como aria el nat en el switch ??

no tengo hace a internet cuando estoy dentro de la vlan switch s

Siento desilusionarte pero no se si un sg300 soporta NAT, no conozco ese switch.

Lo mas sencillo, y que creo que acabaras teniendo que hacer, es pedir que te habiliten el NAT en el router.

No se me ocurre nada mejor.

Un saludo.

New Member

Re: no tengo hace a internet cuando estoy dentro de la vlan swit

gracias por responder

pues lo que pasa es que el router no es cisco :/ es un mikrotik

y yo entro y no puedo hacer ping a las vlan como ´puedo  hacer que las reconoscaa como ago para el switch llege al router

les agradesco su respuesta

Re: no tengo hace a internet cuando estoy dentro de la vlan swit

Buenas,

Pues ocupas configurar enrutamiento (ya sea dinamico o estatico), estatico es el mas sencillo y rapido de configurar.

Dile al router que para llegar a cada una de esas VLANs debe enviar el trafico a el Switch IP address que esta directamente conectado a el

For more information about Core and Security Networking follow my website at http://laguiadelnetworking.com

Any question contact me at jcarvaja@laguiadelnetworking.com

Cheers,

Julio Carvajal Segura

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

no tengo hace a internet cuando estoy dentro de la vlan switch s

Comen to un par de cosas pero nada mas confirmando lo que los compañeros comentan:

Aclaracion de conceptos switch, router  NAT/ PAT

Los switches de cisco son capa 2, y los modelos que soportan capa 3 (enrutadores) no disponen de la funcion NAT (Network Address Translation , hace que una red con ip's privadas salgan como una ip encabezada publica) y

PAT (Port Address Translation hacen que las peticiones a puertos a una ip normalmente la publica se trasladen a una ip privada), pues estas ya son de Capa 4.

En otras palabras, los switches de capa 3 de cisco no tienen NAT PAT porque su unica funcion es la posibilidad de enrutar entre Vlans y hacer enrutamiendos dinamicos mayores que RIP (Eigrp, OSPF,etc)

Los unicos que permiten estas funciones son Catalyst de series superiores (4500, 6400,7400) pero deben llevar la tarjeta adecuada (son modulares), esta tarjeta es propiamente un router donde ya puedes generar NAT, PAT, VPN,ETC.

Conestacion a la duda:

Dado que el NAT y PAT lo ejecutan los routers propiamente, deberás configurar el router para que las redes privadas que

tienen en cada VLAN puedan salir a internet, eso significa:

-Poner una ip en el router por cada una de las VLAN, esa sera la puerta de enlace hacia internet que deberás poner en cada una de ellas.

-Activar el NAT en el router por cada una de ellas para poder salir hacia internet

Por ultimo y muy importante:

Para conectar el router al switch tienes 2 opciones:

  1. Si el router tiene varios puertos de LAN,
    1. poner la ip privada que tendra cada vlan como puerta de enlace en tantos puertos como vlan's tengas en este caso 3
    2. Conectar cada puerto a un puerto del switch con la vlan que le corresponda
    3. poner a los equipos que conectan al switch la ip de puerta de enlace contenida en el router y claro esta de su rango.
  2. La mejor opcion:
    1. en el router configurar las 3 vlans con las ip's comentadas de puerta de enlace
    2. Configurar el puerto a conextar al switch como Trunk
    3. Configurar el puerto del switch en modo Trunk
    4. Definir el protocolo de Trunk (normalmente elijo yo uno standard el dot1q)
    5. Permitir el paso en mabos equipos de las VLAN

Esta ultima opcion es la mejor, puesto que ahorras puertos de ethernet y ademas si un dia tienes que dar de alta otra

VLAN, tan solo la configuras en el router, la añades en el switch y asignas los puertos en este ultimo.

Recomendaciones:

  • Verifica que tu router permite esas funciones (muchos routers de por ejemplo Telefonica no permiten nada mas que una LAN!)
  • Si no tienes acceso al router como comentas, explica al que lo gestione que necesitas que programe una de las dos opciones anteriores
  • Como ultima recomendacion... y no te lo tomes a mal, no estaria de mas que estudiaras un poco el tema de switching VLAN, Routers NAT y PAT, no hace falta que hagas un curso, pero por ejemplo los libros del CCNA (son 2, auqnue el primero te iria de fabula) te explica todos estos conceptos muy reuqetebien.

Aun asi, si tienes mas dudas puedes enviarme un mensaje que te contestaré gustosamente.

Salu2

David López


3931
Visitas
4
ÚTIL
7
Respuestas
No se pudo mostrar este complemento.