cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
cancel
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
Community Member

Problema con conectar dos redes lan a un router Cisco 1841

Saludos equipo,

Muy seguramente esto para ustedes es muy fácil pero le he estado trabajando y no he podido:

Tengo una red LAN con red 192.168.0.x/24 y sobre esta red tengo Internet por un ADSL de un proveedor ISP. Ahora quiero utilizar el router para que me comunique dos redes, la 192.168.0.x/24 con una nueva red 192.168.1.x/24 y esta última tenga Internet y las dos redes se comuniquen.

El gráfico es más o menos el siguiente:

Intenet ------ >   ADSL ----------> Switch ---------------> 192.168.0.x/24

                                                        |--------------------> Cisco 1841 ------------------->   192.168.1.x/24

del switch se desprende todo prácticamente.

Puedo establecer comunicación desde la red 192.168.1.x/24 hacia la 192.168.0.x/24 pero no lo puedo hacer al contrario.

Esta es la rutina de configuración del Cisco 1841:

Current configuration : 1194 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco1841
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password 7 <removed>
!
no aaa new-model
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.0.201
ip dhcp excluded-address 192.168.0.202
ip dhcp excluded-address 192.168.1.201
!
!
ip cef
!
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description $ETH-WAN$
ip address 192.168.0.202 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.1.201 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip http server
no ip http secure-server
!
!
ip nat inside source list 10 interface FastEthernet0/0 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
line con 0
password 7 <removed>
login
line aux 0
line vty 0 4
password 7 <removed>
login
!
scheduler allocate 20000 1000
end

Por favor agradezco su enorme ayuda al respecto.

1 SOLUCIÓN ACEPTADA

Soluciones aceptadas
Cisco Employee

El problema que estás viendo

El problema que estás viendo es por tu configuración de NAT. En este momento tienes una configuración de NAT dinámico, que traduce todo el tráfico de la red 192.168.1.0/24 hacia la IP 192.168.0.202. Los equipos en la red 192.168.0.0/24 ven tráfico de otro host de la misa red y responden y como ya existe una traducción de NAT para ese tráfico, el router lo permite. Cuando la comunicación se empieza desde la red 192.168.0.0/24 no existe una traducción de NAT previa y seguramente su default gateway es el router DSL. Tendrías que hacer los siguientes cambios:

  • Deshabilitar NAT momentáneamente:

interface FastEthernet0/0

 no ip nat outside

  • Cambiar la config de NAT:

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 120 permit ip 192.168.1.0 0.0.0.255 any

no ip nat inside source list 10 interface FastEthernet0/0 overload

ip nat inside source list 120 interface FastEthernet0/0 overload

interface FastEthernet0/0

  ip nat outside

  • Cambiar el default gateway de los equipos en la red 192.168.0.0/24 hacia el router: 192.168.0.202. O bien, agregar una ruta estática en el router ADSL para que diriga todo el tráfico a la red 192.168.1.0/24 a través del gateway 192.168.0.202.

Estos cambios en la configuración van a evitar realizar NAT al tráfico entre las dos LAN, por lo que cualquiera de las dos redes podrá iniciar la comunicación.

10 RESPUESTAS
Cisco Employee

El problema que estás viendo

El problema que estás viendo es por tu configuración de NAT. En este momento tienes una configuración de NAT dinámico, que traduce todo el tráfico de la red 192.168.1.0/24 hacia la IP 192.168.0.202. Los equipos en la red 192.168.0.0/24 ven tráfico de otro host de la misa red y responden y como ya existe una traducción de NAT para ese tráfico, el router lo permite. Cuando la comunicación se empieza desde la red 192.168.0.0/24 no existe una traducción de NAT previa y seguramente su default gateway es el router DSL. Tendrías que hacer los siguientes cambios:

  • Deshabilitar NAT momentáneamente:

interface FastEthernet0/0

 no ip nat outside

  • Cambiar la config de NAT:

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 120 permit ip 192.168.1.0 0.0.0.255 any

no ip nat inside source list 10 interface FastEthernet0/0 overload

ip nat inside source list 120 interface FastEthernet0/0 overload

interface FastEthernet0/0

  ip nat outside

  • Cambiar el default gateway de los equipos en la red 192.168.0.0/24 hacia el router: 192.168.0.202. O bien, agregar una ruta estática en el router ADSL para que diriga todo el tráfico a la red 192.168.1.0/24 a través del gateway 192.168.0.202.

Estos cambios en la configuración van a evitar realizar NAT al tráfico entre las dos LAN, por lo que cualquiera de las dos redes podrá iniciar la comunicación.

Community Member

Ricardo, muchas gracias por

Ricardo, muchas gracias por su apoyo y aporte.

Ya solucioné el impase. Nuevamente muchas gracias.

Community Member

Ricardo, nuevamente

Ricardo, nuevamente solicitando ayuda.

Ahora tengo el siguiente inconveniente. Antes de tener el Cisco 1841, yo configuré el ADSL para que realizara el port forwarding. Ya tengo configurados mi DNS para que respondiera por un CNAME a la IP pública que me entrega mi proveedor ISP.

Esta es la configuración que tengo en mis registros DNS

correo.midominio.com:8010  ------------>  IP.Publica.xx.xx:8010

Y esta es la configuración que tengo en mi ADSL (port forwarding)

IP.Publica.XX.XX:8010 ----------------------> 192.168.0.xx:8010

Ahora que tengo el Cisco con la configuración arriba mencionada, como hago para tener Internet y realizar el port forwarding para que mis aplicaciones funcionen correctamente desde Internet?

Nuevamente gracias.

Cisco Employee

Como el DSL es el que negocia

Como el DSL es el que negocia la IP pública, mientras el servidor al que hacías el port-forwarding siga en la red 192.168.0.0/24 no necesitas hacer nada más.

Si vas a mover el servidor atrás del 1841 y por la configuración de NAT que ya tienes, tendrías que hacer un port forwarding similar al que tienes en el DSL, excepto que ahora sería entre tus redes privadas en lugar de usar la pública:

ip nat inside source static tcp <IP 192.168.0.X> 8010 <IP 192.168.1.X> 8010 extendable

La primer IP debe ser la misma que está configurada en el DSL y la segunda IP debe ser la IP configurada en el servidor.

Community Member

Gracias por la pronta

Gracias por la pronta respuesta,

Tal vez no me hice entender con mi inquietud, el ADSL hace el port forwarding, antes tenía mis servidores después del ADSL.

Ahora tengo el ADSL, luego el 1841 y allí conecto mis servidores a través de un switch.

Como el ADSL me hacía todo (dhcp, port forwarding, etc) no tenía el problema de enmascarar el cname público.

Ahora como resuelvo con la misma topología (ADSL, 1841, Servidores) este problema.

Como hago para resolver correo.midominio.com:8010 ------------> 192.168.1.xx:8010 (red proporcionada por el 1841)

Cisco Employee

La opción sería la segunda

La opción sería la segunda que mencioné en mi respuesta con un port forwarding de la red 192.168.0.0 a la 192.168.1.0. El DSL va a seguir manejando tu IP pública, el 1841 no, ya que se encuentra dentro de tu red privada.

Con tu configuración actual no te recomendaría cambiar la configuración de port forwarding del DSL ya que esa red está detrás del 1841. Este mismo router ya realiza NAT y cualquier tráfico que se mande al servidor 192.168.1.X va salir nateado con la IP del 1841. Por eso requieres un segundo port forwarding en 1841 para redirigir el tráfico que va a la IP 192.168.0.X a la 192.168.1.X y viceversa.

Community Member

En ese orden de ideas mi

En ese orden de ideas mi configuración quedaría:

Current configuration : 1410 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco1841
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password 7 <removed>
!
no aaa new-model
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.0.xx
ip dhcp excluded-address 192.168.0.xx
ip dhcp excluded-address 192.168.1.xx
!
!
ip cef
ip name-server 192.168.1.xx
ip name-server 192.168.0.xx
!
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description $ETH-WAN$
ip address 192.168.0.xx 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.1.xx 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.0.xx
ip http server
no ip http secure-server
!
!
ip nat inside source list 120 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.0.181 8010 192.168.1.181 8010 extendable
!
access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255
access-list 120 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
control-plane
!
!
line con 0
password 7 <removed>
login
line aux 0
line vty 0 4
password 7 <removed>
login
!
scheduler allocate 20000 1000
end

Cisco Employee

Esa configuración debería

Esa configuración debería funcionar sin problemas, siempre y cuando el DSL mande el tráfico del puerto 8010 a la IP 192.168.0.181 y no exista ningún equipo con esa IP en tu red 192.168.0.0/24

Community Member

Ricardo, muchas gracias por

Ricardo, muchas gracias por tu asistencia técnica.

Te cuento que no me funciona, le he estado trabajando en el asunto y no ha sido posible. Existe una regla para generalizar este proceso dentro del 1841?

Es decir que si yo hago desde Internet correo.midominio.com:8010 (y cualquier servicio por cualquier puerto) me responda a mi dirección IP interna 192.168.1.xx:8010 (y cualquier servicio por cualquier puerto) sin cambiar el esquema de red que tengo actualmente?

Quisiera solucionar este inconveniente con tu apoyo.

Cisco Employee

La configuración que hemos

La configuración que hemos manejado es la mejor opción para el escenario que tienes. Si no está funcionando tendríamos que realizar un debug o una captura desde el 1941 para ver qué está fallando.

Este link podría ayudar para el debug de NAT y ver si está recibiendo el tráfico desde el DSL o no:

http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/8605-13.html

902
Visitas
10
ÚTIL
10
Respuestas
CrearPor favor para crear contenido