cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión

Redistribución entre Protocolos de ruteo. Pregunte al Experto

con Jorge Figueroa

Lea la biografía

Durante este evento en vivo, el experto Jorge Figuera dará una introducción a la "Redistribución entre protocolos de ruteo".

Jorge actualmente se desempeña como ingeniero de soporte HTTS  para el TAC de LATAM. Trabajó en REDUNO como ingeniero de arquitectura  realizando análisis y  diseño de la red RCDT, después prestó sus  servicios en T-systems como consultor y  antes de entrar a Cisco estuvo  como Trainner en Global Knowledge /  Netec.  Cuenta con conocimientos en  plataformas para Carrier, protocolos  de Capa 2 ( STP ), Protocolos de  ruteo asi como en MPLS asi como  MP-BGP. Jorge estudió en el ITESM CCM y  se graduó como Ingeniero en Sistemas Electrónicos, cuenta con las  certificación CCNA/CCDA/CCNP/CCIP.

Por favor use las estrellas para calificar las respuestas e indique si la respuesta que ha recibido es la corrrecta.

Puede ser que Jorge no pueda  responder cada una de las preguntas debido la cantidad que     anticipamos  para este evento. Recuerde que usted puede preguntar o     seguir haciendo  preguntas en la comunidad de Routing

Este evento estará disponible del miércoles 23 de octubre al viernes 8 de noviembre del 2013.

3 RESPUESTAS
New Member

Redistribución entre Protocolos de ruteo. Pregunte al Experto

hola que tal buenas tardes me gustaria hacer una  pregunta a cerca de la redistribucion, el tema donde recae mi pregunta es en el de "Redistributing from Classless to Classful Protocols"

Redistributing from Classless to Classful Protocols

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093fd9.shtml#ospf_longer

en la liga anterior de sitio oficial de cisco se plantean ejemplos de redistribucion de protocolos classsless a classful

mi pregunta gira en torno al primer ejemplo donde se realiza la redistribucion entre ospf y rip, siendo el dominio de ospf con subredes de una mascara mayor al de las subredes en el dominio con rip, el objetivo es la redistribucion entre ospf y rip, se maneja en esta liga alcanzar la meta mediante la configuracion de una ruta estatica de la red 128.103.35.0/24 apuntando a la null0 en el ASBR o GW-2

!en GW-2

ip route 128.103.35.0 255.255.255.0 null0

!
router rip
redistribute static
default metric 1

!

!redistribucion en ospf 1

router ospf 1

redistribute rip metric 20000 subnets

la pregunta seria cual es el efecto en GW-2 y en general en el dominio de rip al configurar la ruta estatica hacia null0 y como serian tratados los paquetes que viajan desde el dominio de ospf a rip y viceversa???

Redistribución entre Protocolos de ruteo. Pregunte al Experto

Buenas a ambos,

Dejame ayudar a ambos mientras Jorge no esta presente:

la pregunta seria cual es el efecto en GW-2 y en general en el dominio de rip al configurar la ruta estatica hacia null0 y como serian tratados los paquetes que viajan desde el dominio de ospf a rip y viceversa??

El problema en este scenario es que por la restriccion mostrada en el ejemplo la ruta no es mostrada en el RIP domain.

Que pasa si los dispositivos en el RIP network quieren contactar a los del OSPF domain entonces, simplemente no pueden,

La solucion es configurar una ruta apuntando hacia la Null y luego redistribuirla a RIP.

  1. Una ruta al Null interface es basicamente, una ruta apuntando al basurero Los paquetes hacia esta ruta se botaran.
  2. En este caso la ruta redistribuida en el dominio de RIP tendra como next hop a GW-2. El paquete llega a GW-2 y este chequeara su tabla de enrutamiento y encontrara una ruta + especifica que la null por ende los paquetes se transmitiran de la manera correcta.

Recuerda calificar todas las respuestas.

Regards,

Jcarvaja

Follow me on http://laguiadelnetworking.com

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com

Redistribución entre Protocolos de ruteo. Pregunte al Experto

Gracias Julio por tu respuesta realmente es muy util, entonces cuando  GW-1 tiene un paquete para una ip en la red 128.103.35.192/28 (que no  forma parte de esta red) y otro paquete para la ip  128.103.35.65/28(interfaz  LAN de GW-8), GW-1 revisara su tabla de ruteo  y utilizando la logica de "longest match" encontrara la ruta  128.103.35.0 via 128.103.36.2 y enviara los dos paquetes hacia la  interfaz e2/0 de GW-2, cuando GW-2 reciba los paquetes realizara la  misma busqueda en su tabla de enrutamiento y no encontrara una ruta  especifica hacia la red 128.103.35.80/29 pero en cambio encontrara la  ruta estatica 128.103.35.0 255.255.255.0 hacia null0 que es la que tiene mas bits coincidentes y tirara el paquete, el mismo  tratamiento recibira el paquete con destino a la  ip 128.103.35.65/27  que encontrara coincidencia con la red 128.103.35.62/27 via GW-8 al cual  enviara el paquete y asi hasta que el paquete llega a su destino. Creo  que me queda claro.

para el segundo ejemplo en donde se muestra el mismo  caso de redistribucion pero ahora RIP tiene una mascara mmayor que la  del dominio de OSPF se plantea como solucion el configurar rutas  estaticas y redistribuirlas de igual forma en rip  pero creo yo que las lineas que pongo  en negritas  y subrayadas son inecesarias o existe alguna razon por la cual deban de ser inculidas

ip route 128.103.35.32 255.255.255.248 E0/0 
ip route 128.103.35.40 255.255.255.248 E0/0

ip route 128.103.35.16 255.255.255.248 E1/0
ip route 128.103.35.24 255.255.255.248 E1/0

ip route 128.103.35.64 255.255.255.248 128.103.35.34
ip route 128.103.35.64 255.255.255.248 128.103.35.18
ip route 128.103.35.72 255.255.255.248 128.103.35.34
ip route 128.103.35.72 255.255.255.248 128.103.35.18

router rip redistribute static default metric 1
1257
Visitas
15
ÚTIL
3
Respuestas