Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Routing con Cisco 1841

Hola, tengo un router 1841 con una configuracion previa y ya tiene en FE0/1 un nateo.

Se puede hacer un segundo NAT, es decir, direccionar una ip interna con otra ip externa?

Parte de la configuracion actual es

interface FastEthernet0/1
bandwidth 16000
ip address 161.132.103.250 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

.

.

.

!
ip nat inside source route-map nat interface FastEthernet0/1 overload
ip nat inside source static 192.168.7.17 161.132.103.251
ip nat inside source static 172.18.7.15 190.216.177.149 vrf telefonia route-map asterisk
ip route 0.0.0.0 0.0.0.0 161.132.103.249
ip route 10.10.7.0 255.255.255.0 Null0
ip route 10.254.7.0 255.255.255.0 192.168.7.254
ip route 172.18.7.0 255.255.255.0 192.168.7.254
ip route 192.168.7.0 255.255.255.0 192.168.7.254
ip route vrf telefonia 0.0.0.0 0.0.0.0 190.216.177.145
ip route vrf telefonia 172.18.7.15 255.255.255.255 Vlan7 192.168.7.254
!

Etiquetas (1)
2 SOLUCIONES ACEPTADAS

Soluciones aceptadas
Silver

Hola Cesar!

Hola Cesar!

¿Hiciste algún nuevo comentario en esta publicación? no me es posible visualizarlo.

---No olvides puntear y/o marcar las respuestas útiles---

Saludos,

Silver

Hola Cesar,

Hola Cesar,

Tomando en cuenta tu requerimiento (tengo instalado un servidor linux con la ip interna 192.168.7.17 y necesito que se publique con la ip 161.132.103.251), no comprendo la razón de tu problemática, ya que en la configuración que me enviaste tienes estas líneas:

ip nat inside source route-map nat interface FastEthernet0/1 overload
ip nat inside source static 192.168.7.17 161.132.103.251
ip nat inside source static 172.18.7.15 190.216.177.149 vrf telefonia route-map asterisk

En la segunda línea se esta realizando el NAT que necesitas. Incluso entre tus traducciones se ve el Nateo que esta corriendo entre las IPs:

tcp 161.132.103.251:10401 192.168.7.17:10401 47.21.85.178:3220 47.21.85.178:3220
tcp 161.132.103.251:19145 192.168.7.17:19145 1.34.72.100:64137 1.34.72.100:64137
--- 161.132.103.251    192.168.7.17       ---                ---

¿Qué pruebas estas realizando para validar la información? ¿Qué servicio tienes corriendo allí? ya que tampoco tienes ninguna lista de acceso que te este denegando el tráfico. 

¿qué pruebas de conectividad has hecho? ¿Hiciste un tracert desde el server hacia el exterior? ¿en donde se queda el paquete? ¿tienes algún firewall en el medio? 

Saludos,

11 RESPUESTAS
Silver

Hola!

Hola!

Si por supuesto que puedes realizarlo, sin embargo me gustaría hacerte un par de preguntas: ¿Qué tipo de NAT usarás? ¿estático? ¿cómo es la configuración del route-map que se llama NAT?

---No olvides puntear y/o marcar las respuestas útiles---

Saludos,

New Member

Hola

Hola

La verdad estoy aprendiendo a configurar los router y creo que tendria que ser un Nat estatico de ip a ip.

En cuanto a la configuracion seria :

PC - Switch Cisco - Router Privado - Router Proveedor - Nube

Lo que estaria configurando seria el Router Privado.

Gracias.

Cesar Izquierdo

Silver

Hola!

Hola!

Creo que no has comprendido mi pregunta, en tu configuración tienes esta línea:

 ip nat inside source route-map nat interface FastEthernet0/1 overload

¿Qué esta configurado en ese route-map que tiene por nombre nat? puedes haces un show route-map en tu equipo para ver esa configuración. Te lo pregunto porque es necesario que conozcas qué se esta nateando y ver si tiene relación con lo que deseas natear. De todas formas la configuración estática es bastante sencilla, solo deberías agregar una línea como esta:

ip nat inside source static  ip-interna  ip-externa (en el rango de publicas de esa interfaz, del /29 que te dio tu proveedor)

---No olvides puntear y/o marcar las respuestas útiles---

Saludos,

New Member

Hola, en verdad no entiendo

Hola, en verdad no entiendo nada.... soy nuevo en estos temas de configuracion.

Te agradeceria si me puedes detallar los comandos y que debo poner.

Te adjunto la config. actual.

Muchas gracias por tu apoyo.

Silver

Hola Cesar!

Hola Cesar!

¿Hiciste algún nuevo comentario en esta publicación? no me es posible visualizarlo.

---No olvides puntear y/o marcar las respuestas útiles---

Saludos,

New Member

Hola Diana

Hola Diana

Como no entiendo y soy nuevo en estos menesteres, adjunto la configuracion actual del router para que puedas darme una idea mas  exacto de lo que tendria que colocar para habilitar mi nat, inicialmente puse lo que me indicaste pero no funciona.

Gracias por tu apoyo

Saludos

Cesar Izquierdo

Silver

Revisé la configuración, pero

Revisé la configuración, pero es necesario que hagas la prueba del NAT y me proveas las salidas de estos comandos:

#Show ip nat translations 

#Show log

Otra consulta: ¿Hacia que ip estas intentando llegar desde la 192.168.7.17?

Saludos,

New Member

Hola Diana

Hola Diana

Adjunto lo que me pediste.

En cuanto a la ip tengo instalado un servidor linux con la ip interna 192.168.7.17 y necesito que se publique con la ip 161.132.103.251

He tratado por todos las formas, pero cada vez que modifico algo en el fastethernet 0/1 se corta el internet y tengo que restaurar la configuracion.

Espero que puedas ayudarme.

Muchas gracias.

Saludos

Cesar Izquierdo

Silver

Hola Cesar,

Hola Cesar,

Tomando en cuenta tu requerimiento (tengo instalado un servidor linux con la ip interna 192.168.7.17 y necesito que se publique con la ip 161.132.103.251), no comprendo la razón de tu problemática, ya que en la configuración que me enviaste tienes estas líneas:

ip nat inside source route-map nat interface FastEthernet0/1 overload
ip nat inside source static 192.168.7.17 161.132.103.251
ip nat inside source static 172.18.7.15 190.216.177.149 vrf telefonia route-map asterisk

En la segunda línea se esta realizando el NAT que necesitas. Incluso entre tus traducciones se ve el Nateo que esta corriendo entre las IPs:

tcp 161.132.103.251:10401 192.168.7.17:10401 47.21.85.178:3220 47.21.85.178:3220
tcp 161.132.103.251:19145 192.168.7.17:19145 1.34.72.100:64137 1.34.72.100:64137
--- 161.132.103.251    192.168.7.17       ---                ---

¿Qué pruebas estas realizando para validar la información? ¿Qué servicio tienes corriendo allí? ya que tampoco tienes ninguna lista de acceso que te este denegando el tráfico. 

¿qué pruebas de conectividad has hecho? ¿Hiciste un tracert desde el server hacia el exterior? ¿en donde se queda el paquete? ¿tienes algún firewall en el medio? 

Saludos,

New Member

Diana, tienes razon,

Diana, tienes razon, verifique la salida y el acceso y ya esta funcionando.

No veia antes el resultado porque se habia desconfigurado la tarjeta de la pc que tiene que verse.

Muchas gracias por tu ayuda....

Saludos,,

Cesar Izquierdo

Silver

Genial Cesar me alegra que ya

Genial Cesar me alegra que ya todo este funcionando, gracias por la retroalimentación, cuenta conmigo para futuras problemáticas, ¡que tengas un feliz día!

Saludos :)

36
Visitas
14
ÚTIL
11
Respuestas