cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Switch capa3 Catalyst 3750-X 48ports Gigabit configuracion con VLAN no enruta al gateway

Hola tengo 2 Switch capa3 cisco Catalyst 3750-X con 48 puertos Gigabit, IOS 12.2(55)SE5, la verdad después de tantos años he vuelto a redes... me costó recordar... no se si pueden ayudarme?  La configuración que hice la muestro mas abajo.
 
Todavìa no he configurado el 2do Switch puesto que estan haciendo uso de el, una vez que termine de configurar el 1er Switch paso al 2do.
En el Switch capa3 que estoy configurando puedo hacer Telnet, ping a mi gateway, ping al DNS de mi proveedor de Internet.
 
Desde cualquier PC puedo hacer ping al gateway de cada VLAN ej PC de VLAN3  192.168.3.3 su gateway 192.168.3.1
 
Así mismo desde cualquier PC dentro de una VLAN puedo hacer ping al ip de la interfaz FastEthernet0 (que es donde va mi conexion a internet), pero no me acepta el ping hacia el gateway que viene a ser la IP del modem de mi proveedor de internet XX.XX.XX.193.  Y por lo mismo no tengo acceso a internet desde las PC.
 
No sé qué mas me falta configurar?.
Ya revisé muchos documentos de cisco para esta versión de IOS pero no encuentro que mas puede faltar configurar.
Muchas Gracias.
 
 
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CISCO
!
boot-start-marker
boot-end-marker
!
enable secret 5 $···········/
!
!
!
no aaa new-model
switch 1 provision ws-c3750x-48
system mtu routing 1500
ip routing
!
!
!
!
 
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
 ip address XX.XX.XX.194 255.255.255.248    
                                                                       ------en un documento en la pag web de cisco muestra esto de letras azules y el comando en negrilla:!                                                                             --- El puerto que se conecta al router se convierte en un puerto enrutado (L3).   no switchport  Pero 
                                                                                                          no tengo este comando en este Switch para que mi puerto Fa0 se convierta en un
                                                                                                          puerto enrutado. Creo que es aquí donde va fallando.
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
!
interface GigabitEthernet1/0/1
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast  ---- habilité esto para hacer la prueba si en algo ayudaba pero no, solo puse para hacer la prueba
                                              en 2 puertos. ¿Es bueno que habilite  spanning-tree portfast en todas las interfaces? Excepto claro el enlace Troncal
!
interface GigabitEthernet1/0/2
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/4
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/5
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/6
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/7
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/8
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/9
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/10
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/11
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/12
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/13
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/14
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/15
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/16
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/17
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/18
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/19
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/20
 switchport access vlan 3
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/21
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/22
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/23
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/24
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/25
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/26
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/27
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/28
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/29
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/30
 switchport access vlan 5
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/31
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/32
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/33
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/34
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/35
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/36
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/37
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/38
 switchport access vlan 7
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/39
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/40
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/41
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/42
 switchport access vlan 10
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/43
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/44
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/45
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/46
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/47
 speed 1000
 duplex full
!
interface GigabitEthernet1/0/48
 description conexion Sw_2
 switchport trunk encapsulation dot1q
 speed 1000
 duplex full
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan4
 ip address 192.168.4.1 255.255.255.0
!
interface Vlan5
 ip address 192.168.5.1 255.255.255.0
!
interface Vlan6
 ip address 192.168.6.1 255.255.255.0
!
interface Vlan7
 ip address 192.168.7.1 255.255.255.0
!
interface Vlan8
 ip address 192.168.8.1 255.255.255.0
!
interface Vlan9
 ip address 192.168.9.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan11
 ip address 192.168.11.1 255.255.255.0
!
interface Vlan12
 ip address 192.168.12.1 255.255.255.0
!
ip default-gateway XX.XX.XX.193   ----puse el default-gateway porque no me redirecciona a internet.
ip classless
ip route 0.0.0.0 0.0.0.0 XX.XX.XX.193  ---- es el mismo ip que en el default-gateway
ip http server
ip http secure-server
!
!
!
line con 0
 password 7 *******
 login
line vty 0 4
 password 7 *******
 login
line vty 5 15
 password 7 *******
 login
!
end
 
    Etiquetas (1)
    3 RESPUESTAS
    Cisco Employee

    Hola, Espero te encuentres

    Hola,

     

    Espero te encuentres bien.

     

    Mira por lo que puedo leer de la descripcion de tu problema y basado tambien en la configuracion que has brindado te puedo decir que el problema que tienes no es por enrutamiento ni por una mala configuracion del puerto FastEthernet0, el problema que tienes es porque la IP a la que le estas tratando de llegar es una ip publica (corrigeme si me equivoco) y la IP de donde originas el paquete de ICMP es una ip definida en el RFC 1918 (IP privada). Esto no te va a funcionar ya que los provedores de servicio de internet generalement configuran politicas de acceso en los dispositivos de acceso las cuales botan cualquier paquete recibido cuya IP de origen sea una IP privada.

     

    Para poder solucionar este problema vas a necesitar configurar NAT (Network Address Translation) para que podamos traducir la IP privada de esa computadora a una IP publica que tu proveedor de servicio conozca y sepa que se alcanza a traves de tu enrutados. Lamentablemente NAT no es una funcionalidad disponible en ese switch.

     

    Saludos,

     

    Carlos Zeledon

    New Member

    Hola Carlos Zeledon,Gracias

    Hola Carlos Zeledon,

    Gracias por tu ayuda, pero no creo que sea por ser una ip pública, en sí debería enrutar como lo hace un router, pero este switch no lo hace, mira también me hice esa misma pregunta como es ip pública, lo que hice fue hacer la prueba, la empresa dispone de un router cisco wi-fi para smallbussines no tiene puerto consola, puse la ip pública en ese router, y configuré con una ip privada para que se conectara al SW capa3 por la interfaz Fa0 que es un puerto capa3 (ya que por ser capa3 en ese puerto no me admite el comando NO SWITCHPORT) coniguré la ip privada en el puerto Fa0 con su gateway de la ip privada, y que crees tampoco funcionaba!!! ya me quiero morir, invertir en un Switch que es capa3 y no hace el trabajo de enrutar, que supuestamente es lo que debería hacer y es en vano todo lo que nos han enseñado en ccna?? Bueno estoy renegando a full.

    En fin hice otras pruebas con ese router wi-fi smallbussines me permitía crear VLANs pero solamente 4 VLANs, y puse uno de sus 4 puertos en modo troncal, lo mismo hice con mi Switch capa 3 usé el puerto gigabit 48 que estaba como TRUNK y los conecté, y que crees recién enrutaba, pero no me sirve de nada, porque el router maneja solo 4 VLANs y yo estoy usando 12 VLANs en mi Sw capa 3.

    Documentos de cisco:

    http://www.cisco.com/cisco/web/support/LA/7/76/76455_189.html

    http://www.cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/41860-howto-L3-intervlanrouting.html

    http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_58_se/configuration/guide/3750xscg/swvlan.html

     

    Y los documentos de cisco no aparece nada de este problema, es mas muestran las configuraciones así como lo hice pero supuestamente en ellos si funcionan, y hasta en Packet Tracer no funciona!! ya cree la misma configuración en Packet Tracer y nada!

    Te dejo una imagen del Packet Tracer, donde si puedo hacer ping y telnet al router desde el SW pero no ping ni telnet desde un PC, tomando en cuenta que en la vida real el router es de mi ISP.

    Saludos

    Gladys.

    Cisco Employee

    Hola Gladys.Carlos tiene

    Hola Gladys.

    Carlos tiene razon, no vamos a poder hacer ping hacia Internet sin que NAT este configurado pero creo que el tema aqui es que el puerto FastEthernet0 es solo para Management y no para enruteo normal.

    Understanding the Ethernet Management Port

    The Ethernet management port, also referred to as the Fa0 or fastethernet0 port, is a Layer 3 host port to which you can connect a PC. You can use the Ethernet management port instead of the switch console port for network management. When managing a switch stack, connect the PC to the Ethernet management port on a Catalyst 3750-X or Catalyst 3750-E stack member.

    http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/12-2_53_se/configuration/guide/3750xscg/swint.html

    No se de que tipo de modem estamos hablando pero recomiendo usar otro puerto en el 3750 para connectar al modem teniendo en cuenta que si el modem no esta haciendo NAT, igual vamos a tener este problema. Si el modem lo permite, puedes agregar una ruta estatica para la red 192.168.3.0/24 y probar pings desde la PC hacia el modem para confirmar que el 3750 esta haciendo bien su trabajo.

    Topologia:

     

    Internet--Modem--X.X.X.194--x.x.x.193--Catalyst3750--usuarios VLAN VLAN 3.

    ruta estatica en el modem: 192.168.3.0/24 next-hop  = x.x.x.193

    Una vez mas, direcciones RFC1918 no pueden ser enruteadas en Internet asi que no me sorprenderia si aun con estas recomendaciones no puedas obtener acceso a Internet al menos que podamos aplicarle NAT a la red 192.168.3.0.

    Saludos,

    R.T.

    2862
    Visitas
    0
    ÚTIL
    3
    Respuestas
    CrearPor favor para crear contenido