Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

892w internal ap problem

I have an 892w with internal ap. The problem is after an unplug of device and plug back in, the ap functions have ceased. All three wifi led's are on continuosly. I cannot console into the internal ap. Upon entering user name and password, the session freezes and goes no further. The service status of the module is as follows,

892w#service-module wlan-ap 0 status
Service Module is Cisco wlan-ap0
Service Module supports session via TTY line 2
Service Module is waiting for registration message
Service Module reset on error is disabled
Service Module heartbeat-reset is enabled
Service Module is in fail open
Service Module status is not available

I have read that fail open suggests module is blank and without software, maybe corrupt. How can I reinstall, if possible using tftp server or another way? I'm pulling whatever hair is left, out. Any help would be appreciated.

9 REPLIES
Hall of Fame Super Gold

Can you post the output to

Can you post the output to the router command "sh run | include service-module wlan-ap 0 bootimage".

New Member

Hello,Thanks for the response

Hello,

Thanks for the response, the results are,

892w#service-module wlan-ap 0 bootimage
                                                    ^
% Invalid input detected at '^' marker.

892w#

 

Any ideas?

 

 

Hall of Fame Super Gold

Sorry, the correct command is

Sorry, the correct command is "sh run | include service-module wlan-ap 0 bootimage".

New Member

Thanks, Here is the response

Thanks, 

Here is the response.

892w#sh run | include service-module wlan-ap 0 bootimage
service-module wlan-ap 0 bootimage autonomous
892w#

Hall of Fame Super Gold

Ok.  Your AP is running

Ok.  Your AP is running autonomous IOS.  You might as well post the entire config of your router.  I've got a strange feeling you can't "contact" your AP because you've got a faulty configuration somewhere.

New Member

892w#sh runBuilding

892w#sh run
Building configuration...

Current configuration : 6122 bytes
!
! Last configuration change at 13:33:05 PCTime Sat Apr 19 2014 by admin
!
version 15.0
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname 892w
!
boot-start-marker
warm-reboot
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200
logging console critical
enable secret 5 $1$ezHK$vKihsVzIc9u9nFKxGlpGS0
!
no aaa new-model
!
!
!
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
service-module wlan-ap 0 bootimage autonomous
!
crypto pki trustpoint TP-self-signed-1083034100
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1083034100
 revocation-check none
 rsakeypair TP-self-signed-1083034100
!
!
crypto pki certificate chain TP-self-signed-1083034100
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31303833 30333431 3030301E 170D3134 30343138 32303030
  31395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30383330
  33343130 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009E55 34997FF2 1D724247 9C778311 31FB1961 6FC5CBFB 5785161F 714F2659
  BFCAC1DB C0D8198A 4A43BD8C 623D564D B64546FC BDF8F82A 2162930F EB851EFF
  1FF078DE 492ADB0C ACF27DAB 0E555069 BD0480C9 61B51CF4 E7D46E38 10FCCF40
  4AF76D71 AF9E88A1 245FEA1E 83E5B60D 96DC337E FC84A6F6 4ADF6E99 9D86E46E
  F73D0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04383932 77301F06 03551D23 04183016 8014B298 2FE76799
  5F908313 B1B559E8 1C5CBDE0 F72D301D 0603551D 0E041604 14B2982F E767995F
  908313B1 B559E81C 5CBDE0F7 2D300D06 092A8648 86F70D01 01040500 03818100
  33DCC378 338C2770 11092887 1D0817C4 B7FCA500 BA42F798 9D9B865B 8CF88732
  D13290B7 776DFBD9 52A36868 917E14C0 4F466586 74FC249A 5C95B8C9 D762667A
  879BF832 9D010123 52CFE8C3 36ED92BE C8D28820 02DC80E4 3613D356 6F96646F
  4ACBB823 7D0F573B 1DFC40DC 79DEBD21 24322791 04B00728 41955B11 476977C4
        quit
no ip source-route
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool1
   import all
   network 10.10.10.0 255.255.255.0
   dns-server Blocked Out
   default-router 10.10.10.1
!
!
ip cef
no ip bootp server
ip name-server Blocked
ip name-server Blocked
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO892W-AGN-E-K9 sn FHK134170CT
!
!
username admin privilege 15 secret 5 $1$ZvHK$ahLW3f9GLSTxWC02w9ACh0
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
!
!
!
interface BRI0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 encapsulation hdlc
 shutdown
 isdn termination multidrop
 !
!
interface FastEthernet0
 !
!
interface FastEthernet1
 description Thermostat
 !
!
interface FastEthernet2
 !
!
interface FastEthernet3
 !
!
interface FastEthernet4
 !
!
interface FastEthernet5
 !
!
interface FastEthernet6
 !
!
interface FastEthernet7
 !
!
interface FastEthernet8
 description $ES_WAN$$FW_OUTSIDE$
 ip address dhcp client-id FastEthernet8
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 !
!
interface GigabitEthernet0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 shutdown
 duplex auto
 speed auto
 !
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip unnumbered Vlan1
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 arp timeout 0
 !
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 !
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$$ES_LAN$$FW_INSIDE$
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 !
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface FastEthernet8 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
no cdp run

!
!
!
!
!
!
control-plane
 !
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for  one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 transport output telnet
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin udptn ssh
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

892w#

Hall of Fame Super Gold

Try this:   config t

Try this:  

 

config t

 interface wlan-g0

 switchport mode trunk

end

 

New Member

No change, still cannot login

No change, still cannot login to AP. Any other ideas?

New Member

I appreciate the help on this

I appreciate the help on this issue, but still no access. Any other ideas or should this unit be taken out for target practice? Is there any other way to reload software onto the AP? Documentation for any of this is pretty much non existent. Have seen a few people with the same problem, but people seem to give up. Any ideas on a price for a new ap module and where to locate them if it's n/g?

Thanks

120
Views
0
Helpful
9
Replies
CreatePlease login to create content