Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Aironet 1140 dhcp service

Hi,

I've set up an Aironet 1140 with 2 SSID's, but I am having trouble getting dhcp service working for these.

I've tried googling for answers, but can't really find anything.

The AP is set up with 3 vlan's and 3 BVI¨s. Vlan1 is the native Vlan, and the BVI1 interface is configured with an IP for management.

I've configured the two SSID's with seperate Vlan's and WPA2 PSK.

I've configured the BVI interface for each SSID Vlan with an IP, and created dhcp pools.

I have no trouble authenticating to each SSID, but I can't seem to retrieve an IP address.

Anyone got a sample configuration, or some tips as how this problem can be resolved.


Any help is much appreciated.

/Jeppe

3 REPLIES
Hall of Fame Super Gold

Re: Aironet 1140 dhcp service

Shouldn't this post be in the Wireless section?

Can you post your config?
Just want to make sure, your 1140 is running on autonomous IOS or LWAP?

New Member

Re: Aironet 1140 dhcp service

Yes you're right, wrong section.

Sorry bout that, first post

The AP is running autonomous IOS.


I don't have the config at hand right now, but will get to it in the morning.

Is it at all possible to set up the AP this way, do you know?

Also, come to think about it, I haven't configured Gi0 subinterfaces for each vlan, but I guess it should have worked anyways.

/Jeppe

Silver

Re: Aironet 1140 dhcp service

You're going to need sub-interfaces for both the radio and the gi0 interface.

I don't think you need different BVI's, but you do need different bridge-groups.

So something like:

do0.1

encapsulation dot1q 1 native

bridge group 1

...

do0.2

encapsulation dot1q 2

bridge group 2

...

gi0.1

encapsulation dot1q 1 native

bridge group 1

..

gi0.2

encapsulation dot1q 2

bridge group 2....

If you don't have the gi0 subinterfaces, then nothing is bridging to the wired network.....    Just post your config when you get it.

1264
Views
0
Helpful
3
Replies