Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Aironet Conversion Upgrade Image for Cisco IOS

Who try to use subject?

My AP1200 can`t run one!

4 REPLIES
New Member

Re: Aironet Conversion Upgrade Image for Cisco IOS

I was able to upgrade fine from Vxworks to IOS...However I can not get PEAP authentication working now....

I am using XP SP1, Windows 2000 server IAS, and the 1220 upgraded to IOS.

My laptop contains the Cisco 350 series card and I am using the XP SP1. The laptop worked fine with the Vxworks and Peap. So I know the server, etc is correct. I even did an erase start this morning and tried configuring the AP from scratch, but I am back at the same point I was after the upgrade..

The event log on the radius server says....

The user attempted to use an unauthorized authentication method...

Still playing with it...

Don Hickey

New Member

Re: Aironet Conversion Upgrade Image for Cisco IOS

I am still can`t use this image on my AP!

APs Bootstrap can't run it - show errror message... :(

Cisco Employee

Re: Aironet Conversion Upgrade Image for Cisco IOS

I went through this last night here is the notes I wrote as i went through it I hope this helps I welcome feedback on the procedure I wrote as I will try to make more formal documentation from it for you all to use on CCO

The below is not official documentation but simply my notes from when I had to work this out myself last night. I have tested it and it works.

This is the instructions to convert the AP and keep the current configuration.

Remember this util only works for AP1200's it will NOT convert AP350's

If you want to default the config to factory and upgrade then simply install the helper image as you would upgrade firmware normally.

Before you start make sure the AP has SNMP set up correctly and you know the username (community string) and password. Also upgrade to the latest VxWorks firmware 12.02T1 It will not work with 12.01T !!! But does with 11.54

Make sure the SNMP username has rights to all including firmware.

1. Download Aironet-AP-Cisco-IOS-Conversion-Tool-v1.exe and AP1200-Cisco-IOS-Upgrade-Image-v1.img Yes you need both even though the description doest look like you do.

Here is the link to this software

http://www.cisco.com/cgi-bin/tablebuild.pl/aironet_1200_series_ap

2. Install the conversion tool

3. Add task

4. Under source configuration select "from" as device in device information put in the IP address of the AP and admin name which will be the SNMP username (community string)

5. Under Target configuration select "to" as device, helper image will be the location of AP1200-Cisco-IOS-Upgrade-Image-v1.img on your PC's hard disk, enable password will be the password you set for the SNMP user, IP address of the device (same as in step 4) admin name will be the SNMP username (same as step 4)

6. Interface for communicating with target access point should be filled in by default but if not it is your PC's IP address.

7. click next

8. select yes to the warning that this is a one way process

9. Get security config

10. When it has downloaded the security config click on each line of config it has downloaded and set the password to what was configured on the AP for these fields

11. Click finish

12. Highlight the task you have just selected

13. Click start task, it is all done for you from here on, but it encounters an error there is a log to give you more information on what went wrong.

Here is the link to the release notes for the conversion tool

http://www.cisco.com/en/US/products/hw/wireless/ps430/prod_release_note09186a0080184b05.html

New Member

Re: Aironet Conversion Upgrade Image for Cisco IOS

Thanks for answer!

But now i can't make steps you write...

Ñause:

I tried to upgrade firmware from VxWorks 12.00T to IOS version

with downloaded image: AP1200-Cisco-IOS-Upgrade-Image-v1.img

After executing steps, such as written in manual for this image,

my AP goes down, and now a i can get access to AP with CONSOLE

CABLE only.

Now only bootstrap work, and i tried to run some old images,

but bootstrap can't run it!

Look at message:

System ID: 000C30DA9FDA

Motherboard: IBM405 200MHz, 8192KB FLASH, 16384KB DRAM, Revision 04

Bootstrap Ver. 1.00: FLASH, CRC 1C914641 (OK)

Initialization: Unexpected Boot Error

342
Views
0
Helpful
4
Replies
CreatePlease to create content