Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Prime Network Control System (NCS) - database

Hiya supporters !

I got a entry in my NCS database that I can not get rid of - it belongs to a AP and shows it as autonomous and offline.

The AP post is a leftover of something that went bad, i guess, and have the effect that the MAC that belongs to this AP is unusable due to NCS knowing about it allready.

So I need to delete it completely, but I can not !

Here is what I do trying to delete it:

Under

Configure - Access Points

i choose the AP by checking next to it and selecting the Drop-down command "Remove APs" and click GO

only to get this respondse:

Error(s): You must correct the following error(s) before proceeding:

Error:Unknown Exception Occured. If the problem persists please send logs to the Tech Support.

I am a bit "tripping" over what I need to correct ...

I think i need a *nice* CLI command to choke the database record, but i also want to keep all the correct records !

Help ..

AP show N/A under "controller",  "controller name" and "audit-status"

The AP is offline (Oper Status = down)

5 REPLIES

Re: Cisco Prime Network Control System (NCS) - database

mbilgrav,

What version of NCS?

Have you tried to restart the NCS server and then tried removing the AP?

Does NCS let you modify any AP parameters? If so, maybe try changing something to see if that straightens out the db record, then try deleting again.

Justin

Sent from Cisco Technical Support iPhone App

New Member

Re: Cisco Prime Network Control System (NCS) - database

sorry about that - NCS Version is Appliance on ESX (OVA image) version number is 1.0.2.29

I am acutally not sure how I would go about restartingthe NCS ... besides powerdown the appliance via VMWare

The AP that hangs are a leftover fro ma WCS migration, so I think the AP was there when NCS was installed.

So i am not really confident that restart is the solution here.

Re: Cisco Prime Network Control System (NCS) - database

mbilgrav,

I recommend you try a restart first, even though it does not seem a likely fix. It is very easy and is probably the fastest way to eliminate a database lock issue and to make sure that the db is mounted correctly. It could save you a lot of hassle and time over other solutions.

From the NCS command line:

  • To stop and restart the NCS application, which includes dismount and mount of the db:

# ncs stop

# ncs start

  • To reload the whole appliance:

# reload

If you still can't delete the AP record after the reinitialization, then the next thing I suggest is to backup your current install image and then upgrade to NCS v1.1. The upgrade process in WCS/NCS sometimes includes database migration or rebuild operations, which may or may not include fixing or removing corrupt records. Regardless, it seems like it would be worthwhile to try the upgrade as you still get updated code even if you're still dealing with a stubborn AP record.

Justin

New Member

Re: Cisco Prime Network Control System (NCS) - database

ncs stop - ncs start did not do the trick ...

any more ideas, beside upgrade ?

Re: Cisco Prime Network Control System (NCS) - database

mbilgrav,

There is a command on the NCS CLI that looks interesting:

# ncs db reinitdb

wilab-ncs/admin# ncs db ?

  reinitdb  Reinitialize NCS database by dropping all the tables

DISCLAIMER: I'm not a database guy, I've never used this command, and I have no idea what the ramifications are (I've searched and haven't found much). If you do decide to try it, snapshot/backup first and proceed at your own risk.

UPDATE: Curiousity got the best of me and I ran this command on my own lab NCS. I can confirm that this wipes out the NCS database completely and dumps you back to defaults. All user accounts except root are deleted, along with maps, devices and settings. The only thing that appears to be preserved is licensing. So... this could be useful if you wanted to re-attempt a WCS database migration: You could delete the offending AP entry within WCS first, then migrate your db over to NCS and presumably it would import without this AP record. That's assuming you came over from WCS in the first place, which I don't think you mentioned.

Other than that, you could try TAC. It sounds like a corrupt database entry or a bug to me, so maybe they can give you a sql query that will clear it out from the CLI or something.

If it were my system, I would snapshot/backup the 1.0 installation and then upgrade to 1.1. If you don't like the upgrade or if it breaks anything, you can restore your 1.0 snapshot.

Please let us know if/how you are able to resolve the issue.

Justin

4745
Views
0
Helpful
5
Replies
CreatePlease login to create content