Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Custom WebAuth won't preview

Banging my head against the wall here, as we've done this before just a few weeks ago.

2504, running 7.1.91.0.  I've tried downloading the custom webauth bundle through PI 1.3 (System - Commands - Download customized Web Auth) from my local machine, and when that hasn't worked, through the WebUI of the controller itself via a FTP server.

Unlike most of the threads I've seen, I don't get any errors - "TRANSFER_SUCCESSFUL".

However, on the controller's Web UI, (Security - Web Auth - Web Login Page), when I hit Preview, I get the generic "Welcome to Your_Company_Here" login.html page, not the one we have customized.  We're using 7zip to .tar the file, and only have aup.html, login.html, and a 10KB JPG.

I've tried stripping it down to just the login.html file, tarring that by itself - no change.

I also tried tarring and using the basic login.html that is a direct download from the WebAuth bundle template - no change.

Tried changing the Web Authentication type from Customized to Internal, Apply, and then back to Customized - no change.

It seems that no matter what we do, the controller won't use the bundle we've downloaded to it.

  • Security and Network Management
4 REPLIES

Custom WebAuth won't preview

How to Configure a Custom Local WebAuth with Custom Page??

Custom webauth can be configured with redirectUrl from the Security tab. This forces a redirect to a specific web page you enter. When the user is authenticated, it overrides the original URL the client requested and displays the page for which the redirect was assigned.

The custom feature allows you to use a custom HTML page instead of the default login page. Upload your html and image files bundle to the controller. In the upload page, look for webauth bundle in a tar format. Usually, PicoZip creates tars that work compatibly with the WLC. For an example of a WebAuth bundle, refer to the Download Software page for Wireless Controller WebAuth Bundles. Be sure to select the appropriate release for your WLC. A good recommendation is to customize a bundle that exists; do not create a bundle from scratch.

There are some limitations with custom webauth that vary with versions and bugs. Things to watch for include:

    the .tar file size (no more than 1Mb)

    the number of files in the .tar

    the filename length of the files (should be no more than 30 characters)

If your customer package does not work, try with a simple custom package. Then add files and complexity one at a time to reach the package the customer tried to use. This should help you identify the problem.

Re: Custom WebAuth won't preview

You also might want to upgrade. 7.1 has a ton of known bugs and I believe they have deferred the release. 7.2 would be the suggested release.

Sent from Cisco Technical Support iPhone App

New Member

Custom WebAuth won't preview

We need to stay on 7.1.91 for a litle while longer until our WCS is completely shut down, but good call.

New Member

Re: Custom WebAuth won't preview

WCS is no longer an issue...    Upgraded the 2504 to 7.4.110.0, but unfortunately, still nearly the same behavior.

If I name the tar file anything other than "login.tar", the transfer will fail.  If it's named login.tar, the transfer succeeds, but when we do a preview, we still get the default custom auth page.

230
Views
1
Helpful
4
Replies