Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dynamic VLAN-Assignment from RADIUS with Aironet 1242AG doesn't work properly

Hello All,

our setting is to assign VLANs dynamically from RADIUS (freeradius) to Clients connected to the 1242 Access-Points with one SSID. We have Firmware

12.4(10b)JA/JDA on the Aironet 1242.

The clients should be connected to one of three VLANs - one for staff, one for students and one for guests. I use the Web-Interface of

the 1242, because I'm not very familiar with IOS cli.

After assigning the first VLAN to the SSID -> click Accept, assigning the second VLAN to the SSID (overwriting the previous one) -> click Accept,

assigning the third VLAN to SSID (overwriting again) -> click Accept,  the assignment of VLANs works really fine,

(the only thing i change on the page is VLAN, the SSID is set to mandatory WPAv2)

BUT...

when the 1242 is rebooted (due a building power off or similar) it doesn't work anymore. Clients end up in an endless authentication loop.

After doing the procedure again from above - assigning all VLANs sequently once, it works fine again !  till next reboot...

All VLANs have same encryption, cypher, TKIP+AES CCM. On the Cisco-Site I found a command, which i also tried with no success:

'aaa authorization network default group radius'.

I also tried to save the working config and load it into the 1242 again, this also did not work.

It seems that i'm doing something wrong, but what ?

Thanks for some help,

Frank

1 REPLY
Gold

Re: Dynamic VLAN-Assignment from RADIUS with Aironet 1242AG does

All you really need to do is make sure the subinterfaces/vlans are created for each VLAN you need, then have radius push down IETF attributes 64, 65, and 81.

1162
Views
0
Helpful
1
Replies
CreatePlease to create content