Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

High CAPWAP traffic when locally switched

Hello all,

We're seeing an ongoing issue where several APs accross multiple sites log the error, "%CAPWAP-3-ERRORLOG: Retransmission count for packet exceeded max(CAPWAP_WTP_EVENT_REQUEST., 12)", then disassociates from the controller, and reassociates almost immediately.  The issue is the users get disassociated from the AP and call the helpdesk.

A counter measure at one site was to add the CAPWAP traffic (udp ports 5246 & 5247)  to the controller in our QOS Platinum policy (setting the DSCP bit to 'ef'), but that doesn't seem to help.

We're using Flexconnect with central authentication, local switching.

A couple of questions:

1) The Platinum queue on the QOS is showing over 500 kbps when the only thing put in that queue is the CAPWAP traffic - there aren't any phones.  Why so much bandwidth for authentication and control traffic?

2) What is happening with the APs that they can't talk to the controller that causes the issue in the first place?  Bandwidth doesn't seem to be an issue.

Below are some config and outputs:

AP-1242#show capwap reap status

AP Mode:         REAP, Connected

Radar detected on:

AP-1242#show capwap reap association

...

REAP Data Switching: Local

2960#show int fa0/22

  Hardware is Fast Ethernet

  ...

  Full-duplex, 100Mb/s, media type is 10/100BaseTX

  Last input 00:00:22, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 23000 bits/sec, 13 packets/sec

  5 minute output rate 208000 bits/sec, 48 packets/sec

     37478173 packets input, 13839718021 bytes, 0 no buffer

     Received 2818773 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 502342 multicast, 0 pause input

     0 input packets with dribble condition detected

     118634332 packets output, 36491262361 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

2811#show policy-map interface multilink 1

Service-policy output: MPLS-QOS

    queue stats for all priority classes:

       queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 300637/46124112

    Class-map: PLATINUM (match-any)

      300637 packets, 46124112 bytes

      30 second offered rate 28000 bps, drop rate 0 bps

      Match: ip dscp ef (46)

        300637 packets, 46124112 bytes

        30 second rate 28000 bps

      Priority: 18% (552 kbps), burst bytes 13800, b/w exceed drops: -16

Any help is appreciated.

2 REPLIES
VIP Purple

Re: High CAPWAP traffic when locally switched

Hi Jeff,

I think you are hitting a bug (CSCse92856) specific to 1242 AP. Solution given is "Enable Proxy ARP on the default-gateway device of your AP". You can try that & see.

Even I cannot view detail of this bug as of insufficient access permission.Therefore I do not know more details about this bug fix & which software version affected,etc. Better you contact Cisco TAC & get more information.

I found this infomration here

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a008081103d.shtml

One other reason that H-REAP APs do not join WLCs is if the Proxy ARP is disabled on the gateway for the H-REAP APs. From the AP console, this message is logged:

*Jul 29 14:04:10.897: LWAPP_CLIENT_ERROR_DEBUG:  
Retransmission count for packet exceeded more than max(CHANGE_STATE_EVENT , 1)

This can be caused by Cisco bug ID CSCse92856. This problem applies only to AP1130 and AP1240. This problem does not apply to AP1000s, AP1100, or AP1200.

This problem occurs when these conditions are met:

  1. HREAP mode is used in the WLAN. Local mode is not affected by this issue. Native VLAN mapping is required.
  2. The APs have to be on a different IP subnet than the AP Manager of the WLCs.
  3. Proxy ARP is disabled on the default gateway for the AP.
  4. The H-REAP AP gets the default gateway from a DHCP server.

In order to resolve this issue, enable Proxy ARP on the default gateway router of the AP

HTH

Rasika

*** Pls rate all useful responses ****

New Member

I ran across this post while

I ran across this post while revisiting the problem so posting for all to benefit.

The excessive UDP CAPWAPP traffic was a direct result of the global multicast setting on the controller.  When enabled, we were seeing ~500kbps of CAPWAPP to this site.  Once I disabled multicast on the controller, the rate dropped to about 15kbps total for the site.  

The APs at the remote sites are in flexconnect mode and the controller is in the data center.  As a result, any multicast that the controller receives on any of its interfaces, is automatically converted to unicast and sent across the WAN to all flexconnect APs in an individual stream.

For those that need to enable/disable this setting, it was a "hitless" change for us.  Did not require a reboot, did not cause an outage.    

Controller --> Multicast on the left hand side --> "Enable Global Multicast" checkbox is unchecked.

941
Views
0
Helpful
2
Replies
CreatePlease login to create content